OpenWrt Forum Archive

Topic: Luci installation problem on TPLINK TL-WR841N v8.x

The content of this topic has been archived on 20 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello,

I am new to OpenWRT. I installed Attitude Adjustment RC1 on my TPLINK TL-WR841N v8.4 with ease. However, i didnt get Luci with the instalation. Nevermind, I followed the instruction, was able to set interent connection through vi editor and /etc/config/network.

After that I wanted to install Luci with this set of commands:

opkg update
opkg install luci

as is described in OpenWRT documentation section.

Despite my great effort, when I execute any of these two commands nothing happens. In the (PuTTY) console only one new completely empty line appears with green rectangle in its beginning. In this empty line I can write anything but with no effect.

I also tried "grep luci" command with exactly same conclusion as described above.

Do I miss something obvious? Thank you for help.

Because one image is more than thousand words, below you can see how it looks when I try to execute OPKG command with any parameter.

http://imageshack.us/a/img6/6962/opkg.png

It stays like this for over half an hour after what I always loose my patience and shut the PuTTY down.
The router is connected to network and set correctly - I am posting this text connected to internet through it.

Thanks.

EDIT 12:40
When I try to acces the router with web browser (http://192.168.2.1/cgi-bin/luci) I get this error:

The CGI process did not produce any response

I also tried these commands:

/etc/init.d/uhttpd enable
/etc/init.d/uhttpd start

... just in case that LuCI is already present on the router but not activated. These commands were executed; however, with no effect. I still get abovementioned error (about the CGI process) when I try to acces router with IP address in web browser.

(Last edited by jiri.macat on 8 Apr 2013, 13:44)

can you "ping www.google.com" from putty??
have you tried other web browsers to open http://192.168.2.1  ?

(Last edited by nebbia88 on 9 Apr 2013, 16:16)

nebbia88 wrote:

can you "ping www.google.com" from putty??
have you tried other web browsers to open http://192.168.2.1  ?

Hi,

I tried ping from PuTTY to google with 100% success.
I also tried accessing router from another browser (Chrome and IE10) - both with the same (no LuCI) result.

When accessing the router at http://192.168.2.1 from both IE10 and Chrome exactly this happen:
For the first less-than-half second completely black page appear with text LuCI - Lua Configuration Interface. After this short time, the page is automatically redirected to http://192.168.2.1/cgi-bin/luci. This page is all white with abovementioned text The CGI process did not produce any response. I was able to make screenshots:
http://imageshack.us/a/img163/6612/lual.png http://imageshack.us/a/img13/6826/cgio.png

never saw anything similar sad
tried reflashing?

nebbia88 wrote:

never saw anything similar sad
tried reflashing?

Not yet, right now I am away from the router for couple of days.

Just to be sure, for reflash should I use "sysupgrade" firmware?
I am also littlebit confused about the OpenWRT versions: Is Altitude Adjustment older than Barrier Breaker? Is Barrier Breaker is some kind version in development and AA is stable (although it is only in RC1 version)?

BB is older than AA
AA is "nearly" the current stable version.
Do not upgrade to trunk unless you know what you are doing!

I would suggest you beg/borrow/steal another computer running linux or osx and use terminal. Failing that check your virus/firewall settings.

Boss is right, except he wanted to say BB is newer than AA wink Attitude Aadjustment is an ancestor of Barrier Breaker, but some builds of BB might be unstable, or not working at all, but if you like to play, you may want to give BB a try (with a risk of bricking your router, but I haven't a single problem with replacement here in CZ).

(Last edited by nozombian on 15 May 2013, 14:39)

haha, well noticed! I was just checking to see if you were awake.

The discussion might have continued from here.