OpenWrt Forum Archive

Topic: Arcor EasyBox 803A Astoria ARV752DPW22

The content of this topic has been archived between 23 Mar 2017 and 13 Apr 2018. Unfortunately there are posts – most likely complete pages – missing.

I also used terra term some weeks ago with the following steps to recover:

1. You need to set the hardware into UART mode by modifying the following pads during startup:

    * Shortcut R80 (for example with a screwdriver)
    * and bring +3.3V on the left side of R65 (for example with the voltage from the serial port)
    
    If the UART    is activated, you will see:

        ROM VER: 1.0.3
        CFG 04
        Read EEPROMX
        X
        UART

2. After that you have to remove the shortcut and the voltage on R65, otherwise you can not upload.
3. Upload U-boot (u-boot.asc) with TeraTerm (just send, no xmodem or ymodem).
   U-boot will start automatically.

After that I flashed brnboot depending on the u-boot version with ubootwrite.py, tftpd or loadx.

DOH!

ok, i know why it didn't work.. i didn't unsolder the bridge..

THANKS FOR THAT!

I'll try it tomorrow when i'm back at my working place.

Could you also give me a litle walkthrouh how to upload the squashfs from SNK? either brnboot or u-boot, actually i'm only hopeing to get this to work, and if it means to upload the image with ubootwrite i'll go with that smile

Also, do you have an idea, why all uboot versions i tried were unable to get files through httpd, tftp or loadx? i couldn't even ping the box..

I flashed OpenWRT on another easybox a few days ago - and bricked bootloader when trying to install uboot.
I used uboot.asc referenced in 2nd post here: https://forum.openwrt.org/viewtopic.php … 95#p214995 to debrick device. It has xmodem/ymodem built in, so uploading uboot image by serial was easy. Look for loadx command reference - load it to ram (same address as through original bootloader) and then copy to flash.

Not sure if this is going to be helpful, but I've aleady bricked one of my four Easyboxes a couple of times and have collected some experience in the meantime.

If you have a helping hand available (actually you'd need two helping hands), you can do the job without any soldering. The UART mode has only got to be initiated for a short moment...once it says UART on the terminal window you can forget about the neccessary connections. That means: Let some other person realize the shortcut of R80 with something conductive, while you bring 3.3V to the left side of R65 and then power on the Easybox (using a switched socket-outlet). As soon as you can read UART on the console you can relax and remove everything (except the power, of course).

I used to send a u-boot.asc to the Easybox's RAM using TeraTerm and once it is uploaded and starts automatically I normally use loady to reinstall the complete backup of the original firmware (which does take some time, of course).

So be patient!

Many thx to puma14, - my wifi is running after flashing the snk image BUT: only in "ap" - Mode.

When I want to start wifi in sta mode it gives:
root@OpenWrt:/# [ 3168.760000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

Any Idea why?

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option path 'pci0000:00/0000:00:0e.0'
        option htmode 'HT20'
        option txpower '20'
        option country 'DE'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option ssid 'BETCN'
        option key 'Pass123!'
        option mode 'sta'
        option encryption 'psk2'


config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd56:b7d8:9017::/48'

config interface 'lan'
#       option force_link '1'
        option type 'bridge'
        option proto 'dhcp'
#       option ipaddr '192.168.2.20'
#       option netmask '255.255.255.0'
#       option ip6assign '60'
        option ifname 'eth0.1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 3 4 5'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'

config interface 'wan'
        option ifname 'nas0'
        option proto 'pppoe'
        option username 'foo'
        option password 'bar'
        option ipv6 '1'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config adsl 'dsl'
        option annex 'a'
        option firmware '/lib/firmware/adsl.bin'

Ok, i allready booted to u-boot with UART, and flashed u-boot from SNK back to device.
strange thing is, now i have loadx and things on board (not httpd but that's not a big problem with loadx working)

At the moment i'm uploading the squashfs from SNK to 0xb00b0000. let's hope it works...

Well, I'm not sure I understand what you're doing there, but nevertheless I think you know that the load address should normally be 0xb0040000. That's where I usually load my images and they boot fine....even the ones that I compiled myself recently.

As to running the Easybox's wifi in STA mode I've been making the same experience as TurboELK....
Have been experimenting with different attempts to let a second Easybox work as a range extender and all my tries have failed so far. Even "simple" WDS seems impossible, for it's giving me kernel oopses and memory dumps saying STA mode isn't supported. :-(

Ok, it made me pull out my hair, but i'm in a running state now. (seems like tftp got some problems with transfering the image) after several writing errors over serial, i tried with tftpboot an was satisfied with the speed. but at first i killed the bootloader again with (i think) the "erase 0xb0020000 0xb07effff" command from the guide (I#m useing the uboot from SNK wich is a litle bit bigger, so i think this caused the problems) but now i have a booting openWRT. But wireless seems to be not working. it might be possible that the wlan firmware is gone. could you give me the command to extract the firmware from the backup i did yesterday?

everytime i scan for wireless networks, i only got the top menu and a white site after.

Sorry I forgot, it is true that the new uboot is slightly bigger. We have too much changes and different versions ......

Regarding wifi, I configured everything with the LuCI webinterface and I remember that after that I only could activated the wifi with the command line

uci set wireless.@wifi-device[0].disabled=0; uci commit wireless; wifi
taxidriver wrote:

As to running the Easybox's wifi in STA mode I've been making the same experience as TurboELK....
Have been experimenting with different attempts to let a second Easybox work as a range extender and all my tries have failed so far. Even "simple" WDS seems impossible, for it's giving me kernel oopses and memory dumps saying STA mode isn't supported. :-(

I am using one of my 803 as repeater, so 'ap' and 'sta' mode works fine.

My configuration is as follows.

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path 'pci0000:00/0000:00:0e.0'
    option htmode 'HT20'
    option txpower '20'
    option country 'DE'
    option channel '13'

config wifi-iface
    option encryption 'psk2'
    option device 'radio0'
    option macaddr '11:22:33:44:55:66'
    option mode 'sta'
    option key 'MYPASSWORD'
    option network 'lan'
    option wds '1'
    option bssid '77:88:99:AA:BB:CC'
    option ssid 'My Network'

config wifi-iface
    option device 'radio0'
    option macaddr '11:22:33:44:55:67'
    option mode 'ap'
    option wds '1'
    option network 'lan'
    option ssid 'My Network'
    option encryption 'psk2'
    option key 'MYPASSWORD'
        option macfilter 'allow'
        list maclist '55:55:55:55:55:55'

Does the example help?

puma14 wrote:

Sorry I forgot, it is true that the new uboot is slightly bigger. We have too much changes and different versions ......

Regarding wifi, I configured everything with the LuCI webinterface and I remember that after that I only could activated the wifi with the command line

uci set wireless.@wifi-device[0].disabled=0; uci commit wireless; wifi

nope, doesn't work hmm

but at least, with the wlan flash recoverd from the backup, i can search for wlans (but there a none found.. but at least 4 have to be there)

Just try the image I am using: https://www.wetransfer.com/downloads/4b … 552/87c7ed

It is OpenWrt Barrier Breaker r41737 from the trunk on the 18th of July.

It might be compatible with the version from SNK, so probably the settings could be kept.

Tried your listing on my two Easyboxes:

Unfortunately I wasn't able to adapt your config example to my system successfully. One of the things you said seems to be right: STA mode really can be invoked without causing any errors. But on the other hand I wasn't able to connect the two Easyboxes.
All I actually did was f*** up the complete config, so that presently I can't get through to the D-Link router, which used to be a working repeater before I started messing up.

Guess I'm confusing all the MACs and BSSIDs that have to be unblocked before the system works. Another thing is, I noticed that both Easyboxes have identical MAC adresses now (which they did not with the original firmware). Shouldn't be a problem, but I'm not completely sure about that at the moment.

Moreover, how about DHCP and Firewall? Nothing left to be done there?

For me the wds Option from Puma14 works. So ap and sta are working with the snk Image but a Simple Client Mode does still NOT work.

Strange.... Im confused

Ok,

flashed you firmware, and now it works! I can do everything with the webinterface. bridgeing a wlan with the lan to archive internet (from the wlan) works also.

Great. Now i have to fiddle around with the USB UMTS modem, but i allready found a guid for that.

Thank for you help!!!

EDIT: just noticed that there a no PMs in PunBB so i'll write it here, can i do you a favor in exchange for your help?

(Last edited by kubax on 25 Jul 2014, 12:03)

got some new problem -.-

I'm trying to install kmod-hid to make the hardware buttons working again. but can't install it, because repository version of trunk is 3.10.49 and kernel installed is 3.10.44.

Is there another repository path, or a way to update kernel to the right version?

EDIT:
I allready tried to change the repository to "http://downloads.openwrt.org/barrier_br … /packages/" wich uses the same kernel, but with a different commit numer (i asume that the alpha numeric blob after the version number is the commit number)

(Last edited by kubax on 25 Jul 2014, 16:35)

Either override it (which may not work) or reflash with RC1.

I just got wireless crash - devices were contecting, but no packet transmission from device at all. Dmesg:

[16876.808000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[16876.816000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[16876.824000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[16876.832000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[16876.840000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[16876.852000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[16876.860000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[17002.760000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[17002.768000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[17002.776000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[17002.784000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[17002.796000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[17002.804000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[17002.812000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[17002.820000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[17003.784000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[17003.792000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[17220.872000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[17220.880000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[17220.888000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[17854.528000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[17854.536000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[32071.468000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[32071.476000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[32071.484000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[32071.496000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[32072.696000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[32072.704000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[32072.716000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[32072.724000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[32072.732000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[32072.740000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[32072.752000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[32072.760000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[32072.768000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[32072.776000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[32072.788000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 2
[34389.628000] nf_conntrack: automatic helper assignment is deprecated and it will be removed soon. Use the iptables CT target to attach helpers instead.
[35048.200000] device wlan0 left promiscuous mode
[35048.204000] br-lan: port 2(wlan0) entered disabled state
[35048.396000] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 2 failed to flush
[35048.576000] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 2 failed to flush
[35054.676000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[35054.688000] device wlan0 entered promiscuous mode
[35055.908000] br-lan: port 2(wlan0) entered forwarding state
[35055.912000] br-lan: port 2(wlan0) entered forwarding state
[35055.916000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[35056.200000] ieee80211 phy0: rt2x00queue_write_tx_frame: Error - Arrived at non-free entry in the non-full queue 2
[35056.200000] Please file bug report to http://rt2x00.serialmonkey.com

Is it a known problem, or I should report bug at this given address?

[e]I found similar bug on Ubuntu forums and there are suggestions that there's problem with rt2x00 driver on 3.10 and 3.11 kernels; we're running on 3.10.36.

(Last edited by kitor on 25 Jul 2014, 20:35)

3.10.36 kernel? We are using 3.10.44. Did you try the image I posted yesterday?

Some modules with kmod-hid for the image can be found on https://www.wetransfer.com/downloads/44 … 801/cf2faa.

Regarding MAC addresses, it has to be avoided having identical addresses. Therefore I set them manually in the config file.

(Last edited by puma14 on 25 Jul 2014, 20:58)

I have OpenWRT flashed about two weeks ago, from old image - not noticed new one. I'll try to flash it later.

Yeah, meanwhile I noticed that having identical MAC addresses does cause unneccessary problems. I wasn't prepared to run into this, so I didn't prepare the Easyboxes to avoid it. Meanwhile I managed to have different MAC addresses although the boxes have identical images installed. Will have to see if I manage to get it do what I want now.

Hi,

my wifi works now in client mode with the snk image. The settings are:

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path 'pci0000:00/0000:00:0e.0'
    option htmode 'HT20'
    option txpower '20'
    option country 'DE'
    option channel '11'

config wifi-iface
    option encryption 'psk2'
    option device 'radio0'
    option mode 'sta'
    option key 'MYPASS'
    option network 'lan'
    option ssid 'MYNETWORK'

config interface 'lan'
        option proto 'dhcp'

installing mpd-mini and mpc and extending the root with /overlay to get space also works.

BUT: I can't install the packages kmod-usb-audio and kmod-usb-ohci (which I need for my sound card)
The Error is:

 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-audio:
 *      kernel (= 3.10.49-1-bed6db45851b19f2799d35f9b4ae105e) *         kernel (= 3.10.49-1-bed6db45851b19f2799d35f9b4ae105e) *         kernel (= 3.10.49-1-bed6db45851b19f2799d35f9b4ae105e) *         kernel (= 3.10.49-1-bed6db45851b19f2799d35f9b4ae105e) *

So with the image from snk I can set up wifi but not install the packages I need. With the standard BB I can't setup wifi but install the packages I want. Is there any way to find a solution to get both?

TurboELK wrote:

BUT: I can't install the packages kmod-usb-audio and kmod-usb-ohci (which I need for my sound card)
The Error is:

 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-audio:
 *      kernel (= 3.10.49-1-bed6db45851b19f2799d35f9b4ae105e) *         kernel (= 3.10.49-1-bed6db45851b19f2799d35f9b4ae105e) *         kernel (= 3.10.49-1-bed6db45851b19f2799d35f9b4ae105e) *         kernel (= 3.10.49-1-bed6db45851b19f2799d35f9b4ae105e) *

So with the image from snk I can set up wifi but not install the packages I need. With the standard BB I can't setup wifi but install the packages I want. Is there any way to find a solution to get both?

The kernel modules are dependent on the image version. If you do not want to change the image, you have to find someone who install the source with the same image release as snk and generate the kmod files.

But you can also install the image from the snapshot http://downloads.openwrt.org/snapshots/trunk/lantiq/ with all related modules and configure it, which seems currently even newer than my image, or you use the image I have posted in the past. It might be compatible to the one from snk, so perhaps you can keep your settings. Then I can create the suitable kmod files for you.