Hi
I am new to OpenWRT. My environment:
OpenWrt Backfire 10.03.1
A Dlink DIR 655 Router is connected to the internet.The Dlink router is connected to an internal network: 192.168.0.0/24 with ip address 192.168.0.1
I connected OpenWRT to Dlink via (OpenWrt's WAN port to Dlink's LAN port)
OpenWRT's /etc/config/network is as follows:
#### VLAN configuration
config switch eth0
option enable 1
config switch_vlan eth0_0
option device "eth0"
option vlan 0
option ports "1 2 3 4 5"
config switch_vlan eth0_1
option device "eth0"
option vlan 1
option ports "0 5"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0
#### WAN configuration
config interface wan
option ifname "eth0.1"
option proto static
option ipaddr 192.168.0.54
option netmask 255.255.255.0
option gateway 192.168.0.1
The Dlink router is configured with a static route to 192.168.1.0/24 via 192.168.0.54
I have a machine (192.168.0.22) connected to Dlink router via LAN port
I have a second machine (192.168.1.4) connected to OpenWrt router via LAN port.
The firewall at machine (192.168.1.4) is disabled.
The firewall at machine (192.168.0.22) is disabled.
In the /etc/config/firewall, the wan interface's option masq setting is set to 0 (off)
Problem:
1. Machine (192.168.0.22) can ping machine (192.168.1.4) but machine(192.168.1.4) failed to ping Machine (192.168.0.22).
2. Machine (192.168.0.22) failed to ssh Machine (192.168.1.4).
Thank you in advance for help extended.
Regards,