OpenWrt Forum Archive

Topic: Easybox 904 LTE open source code to be provide soon

The content of this topic has been archived between 1 Apr 2018 and 5 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Hello. if it is possible to run eb904 wifi in STA (ap-client) mode?

AFAIK no, I did some survey and I was at least able to scan availabe APs on a fixed channel, but no connect.
You have to: replace the module-insert param with mode=sta in /etc/init.d/rt3883, supply a proper iNIC_sta.bin, iNIC_sta.dat(1) firmware in the firmware directory (where iNIC_ap.bin resides), but then I was lost, some necessary
iwpriv settings where not possible, maybe I took a wrong firmware, but I have no more time for further investigations

@QAuge: I finally found some time to tinker with this device again. I upgraded to your latest snapshot (2018-03-29, sysupgrade leads to a boot loop so I did a full re-install with the new fullimage.img).

However, Wifi is not working anymore, the kernel module fails to load. This is from a fresh install with no customizations:

Thu Mar 29 05:06:48 2018 daemon.notice procd: /etc/rc.d/S60rt3883: Insmod with MAC1=18:83:bf:65:b1:c6 and MAC2=18:83:bf:65:b1:c8
Thu Mar 29 05:06:48 2018 kern.warn kernel: [   79.299890] Warnning!! syncmiimac is foreced to 0 in dual concurrent mode.
Thu Mar 29 05:06:48 2018 kern.warn kernel: [   79.305419] ERROR! Please assign miimaster=[MII master device name] at module insertion.
Thu Mar 29 05:06:48 2018 daemon.err insmod: failed to insert /lib/modules/4.14.29/rt3883_iNIC.ko

Edit: This goes back to the 2018-02-26, i.e. all your squashfs/4.14 builds. I don't have that problem with Plonk34's build, so it seems not to be due to my hardware. Something that happened when you rebased your code?

(Last edited by metai on 17 Apr 2018, 23:42)

@QAuge, @Plonk34: I lost my notes on the topic a few months ago after I had to stop on reworking/comparing /lib/wifi/ralink.sh. But here's something I immediately noticed again: Your /lib/wifi/ralink.sh is missing the code to set the wifi channel stated in /etc/config/wireless.

It's actually just one line that goes into /lib/wifi/ralink.sh, at or around line #240:

  append vif_post_up "iwpriv '$ifname' set SSID=$ssid " ";$N"
  # the following line sets the channel
  append vif_post_up "iwpriv '$ifname' set Channel=$channel" ";$N"
  append vif_post_up "iwpriv '$ifname' set Enable=1" ";$N"
  append vif_post_up "iwpriv '$ifname' set RadioOn=1 " ";$N"

Of note is that, for whatever reason, if wl000 is set to a channel > 48 it takes about minute until the wifi shows up, maybe even longer. Also I'm sure that I was able to in the past, but I can't get it to work with channels >= 100 anymore, it just never comes up.

(Last edited by metai on 18 Apr 2018, 00:24)

The discussion might have continued from here.