OpenWrt Forum Archive

Topic: TP-Link TL-WR802N - double speed to classical TL-WR702N

The content of this topic has been archived between 23 Apr 2018 and 5 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.


I resubmitted the patch for this device because a lot of people asked for it. But it looks like the development of OpenWRT is stalled for some time - so I'll leave the firmware binaries here until it has been integrated. There's an image with and one without LuCI in case you need more space for additional packages. This is the current trunk (Designated Driver) from 04-04-2016. It's not completely tested so your device might catch fire.

WR802N image with LuCI: … actory.bin

WR802N image without LuCI: … o_luci.bin

(Last edited by rickp on 4 May 2016, 21:46)

I used the WR802N image with LuCI. I was able to flash the device through the GUI. Once flashed, the LED switches on for a second at every boot-up and then remains off. Everything else appeared to be working fine. Unfortunately I misconfigured one of the network interfaces, leaving me unable to login to access the device via SSH or the web interface. No luck getting the device into failsafe mode either, despite repeatedly clicking the reset button throughout boot-up. Unfortunately it looks like I might have to bin it now :-(

UPDATE: I managed fix the network configuration by logging into SSH using the device's ipv6 address. It turns out that I had two interfaces using the same ipv4 address. All is working as it should now :-)

(Last edited by blacksmith on 16 Jul 2016, 18:47)

just wanted to report that i successfully used both the images on my WR802N.
Tho i had to install BOTH of them via the legacy-firmware's web-frontend, installing via commandline from within a working openWrt did not work and i nearly bricked my device this way.
But i was able to recover the device using the TFTP method - but strangely this worked only with the legacy-firmware image, an attempt to install one of the openwrt images via TFTP failed.

As i want a VPN server on the device i tried to install the openvpn package, which failed because of the really tight free space, so my plan now is to create an image myself with LuCI and the openvpn-package installed, but without LuCI for saving space. It COULD work, but i have to try it to be sure.
It could take some days/weeks as i dont have much spare time for this, but i will keep you updated and eventually post the image here when it's done.

As i am completely new to building openwrt myself i would appreciate any help or hints on which packages i should include and in general if there are any traps in the process.

(Last edited by gelse on 5 Aug 2016, 09:55)

Awesome news @gelse!

Could you please confirm what you mean by legacy-firmware? With different versions of the OEM and OpenWRT firmware, I'm a little confused.

legacy-firmware = …

the official firmware for my device (hardware-version 1)
be aware that this link points to the german tp-link website, as i am from austria - iirc the UI was english, but anyway - that should not be a big problem to change for anyone.

and the openWRT images provided by RickP three posts above. ;-)

about flashing with TFTPD - i roughly followed the video at
it's a bit long, but worth watching to understand what is going on and what is to be done.
only one thing is not explicitely explained: the TFTP method does NOT work if the router and your computer are connected via normal LAN (with a switch), it only works if you directly connect both ethernet-cards with a cable.
at least for me.

(Last edited by gelse on 5 Aug 2016, 10:04)

well, to be honest, i could need some help with the configuration... too many options where i do not have the simplest clue what it's all about.
to clarify: i am talking about menuconfig.

(Last edited by gelse on 14 Aug 2016, 10:18)

Hey @gelse I'm new to OpenWRT too. Any chance you would want to do a live chat to figure some of this out? Say on Google Hangouts or whatever?

PM me if you're interested.

(Last edited by azend on 12 Aug 2016, 08:29)

well, i would if i could, but seems as you turned off PMing. ;-)

Oops! I actually do have user to user email set up but the forum gives me a permission denied whenever I try to use it. I'm azend on Freenode in #openwrt if you want to connect there.

Gelse is wanting to run an OpenVPN server on the WR810N.  I just want to run my WR810N as a hotspot relay (for hotels) with an OpenVPN *client* on it to connect to my VPN server at home when I'm traveling.

Would that be feasible, potentially, with the image uploaded by RickP ("WR802N image with LuCI") and the OpenVPN client for OpenWRT?

I'm very new to this flashing routers thing, but I'm relatively competent in Raspberry PIs.


Hello everybody!

I also use this really great Travel-Router (v1) and I'm interested in OpenWrt. The original software of the TP-Link WR802N unfortunately obviously links the SSID via the BSSID to the MAC address of the respective HotSpot. Without BSSID, no connection can be configured.
Is this restriction also with one of the two OpenWrt firmware presented here?

With the original firmware, no networks / WISP access profiles can be stored. You must restart the setup for each hotspot / access point.
Can be stored with the OpenWrt firmware several networks / WISP access profiles in the TP WR802n?

Thank you very much for your info and help



Hallo Zusammen!

Ich nutze auch diesen richtig tollen Travel-Router (v1) und interessiere mich für OpenWrt. Die Originalssoftware des TP-Link WR802N koppelt leider offensichtlich die SSID über die BSSID an die MAC Adresse des jeweiligen HotSpots. Ohne BSSID lässt sich keine Verbindung konfiguriert.
Gibt es diese Einschränkung auch mit einem der beiden hier vorgestellen OpenWrt-Firmware?

Mit der Original-Firmware lassen sich keine Netzwerke / WISP-Zugangsprofile speichern. Es muss bei jeden Wechsel Hotspots / Accesspoints manuel das Setup neu ausgeführt werden.
Lassen sich mit der OpenWrt-Firmware mehre Netzwerke / WISP-Zugangsprofile in dem TP WR802n abspeichern?

Herzlichen Dank für eure Info und Hilfe


I have not been able to flash either of the.bin's via the wr802n's web server for "firmware upgrade"
Hardware Version:    
WR802N v2 00000000

(Last edited by Ceruleancerise on 11 Apr 2017, 01:27)

I attempted to flash the firmware to the v2 eu version via TFTP. The router connected to the TFTP server and downloads the file successfully but upon rebooting it was still running the TP-Link firmware.

(Last edited by spray on 30 Jun 2017, 13:41)

I have the same issue with the v3. The hardware specification seems to be the same between the v2 and v3 however. Is there any help I can get to flash this mini-router?

The discussion might have continued from here.