OpenWrt Forum Archive

Topic: brcmsmac

The content of this topic has been archived on 20 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

How do i activate the brcmsmac in /etc/config/wireless on a asus rt-16n ?

I have installed kmod-brcmsmac ( reboot) and tried this config, it is not working ?? an i missing something =?

config wifi-device 'radio1'
        option type 'brcmsmac'
        option txpower '20'
        option country '00'
        option channel 'auto'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key '********'
        option ssid 'TMP2'
        option encryption 'none'

Anyone  ??

I too am interested in running brcmsmac on a bcm47xx router (Linksys E3000v1 running openwrt-e3000_v1-squashfs-r38898.bin). The only instructions in the wiki for brcmsmac state to enable it with opkg (and disable all other drivers). I have followed these instructions, but the result appears to be broken in the following ways:


The 2Ghz radio is still using the b43 driver, and will no longer come up. The 5Ghz radio is no longer recognized at all. iw phy doesn't even see it.

root@E3000:~#  lspci -k
00:00.0 Host bridge: Broadcom Corporation BCM47xx Sentry5 USB Host Controller (rev 01)
    Subsystem: Broadcom Corporation BCM47xx Sentry5 USB Host Controller
00:00.1 Host bridge: Broadcom Corporation Device 0000 (rev 01)
    Subsystem: Broadcom Corporation Device 4716
00:01.0 Network controller: Broadcom Corporation BCM4322 802.11bgn Wireless Network Controller (rev 01)
    Subsystem: Broadcom Corporation BCM4322 802.11bgn Wireless Network Controller
    Kernel driver in use: b43-pci-bridge

There are still many b43 files scattered all over the file system.

root@E3000:~# find / -regex '.*b43.*'
/lib/firmware/b43
/lib/firmware/b43legacy
/overlay/etc/modules.d/b43
/overlay/etc/modules.d/b43legacy
/overlay/lib/firmware/b43
/overlay/lib/firmware/b43/lp0initvals13.fw
/overlay/lib/firmware/b43/lp0initvals15.fw
/overlay/lib/firmware/b43/ucode11.fw
/overlay/lib/firmware/b43/ucode13.fw
/overlay/lib/firmware/b43/ucode15.fw
/overlay/lib/firmware/b43/ht0bsinitvals29.fw
/overlay/lib/firmware/b43/b0g0initvals5.fw
/overlay/lib/firmware/b43/ucode29_mimo.fw
/overlay/lib/firmware/b43/ucode16_mimo.fw
/overlay/lib/firmware/b43/lp0bsinitvals13.fw
/overlay/lib/firmware/b43/lp0bsinitvals15.fw
/overlay/lib/firmware/b43/n0initvals11.fw
/overlay/lib/firmware/b43/n0initvals16.fw
/overlay/lib/firmware/b43/n0bsinitvals11.fw
/overlay/lib/firmware/b43/n0bsinitvals16.fw
/overlay/lib/firmware/b43/ucode5.fw
/overlay/lib/firmware/b43/b0g0initvals13.fw
/overlay/lib/firmware/b43/pcm5.fw
/overlay/lib/firmware/b43/ht0initvals29.fw
/overlay/lib/firmware/b43/b0g0bsinitvals5.fw
/overlay/lib/firmware/b43legacy
/overlay/lib/firmware/b43legacy/b0g0initvals2.fw
/overlay/lib/firmware/b43legacy/ucode2.fw
/overlay/lib/firmware/b43legacy/ucode4.fw
/overlay/lib/firmware/b43legacy/pcm4.fw
/overlay/lib/modules/3.10.18/b43legacy.ko
/overlay/lib/modules/3.10.18/b43.ko
/overlay/usr/lib/opkg/info/kmod-b43legacy.control
/overlay/usr/lib/opkg/info/kmod-b43.list
/overlay/usr/lib/opkg/info/kmod-b43.control
/overlay/usr/lib/opkg/info/kmod-b43legacy.list
/rom/etc/modules.d/b43
/rom/etc/modules.d/b43legacy
/rom/lib/firmware/b43
/rom/lib/firmware/b43/b0g0bsinitvals5.fw
/rom/lib/firmware/b43/b0g0initvals13.fw
/rom/lib/firmware/b43/b0g0initvals5.fw
/rom/lib/firmware/b43/ht0bsinitvals29.fw
/rom/lib/firmware/b43/ht0initvals29.fw
/rom/lib/firmware/b43/lp0bsinitvals13.fw
/rom/lib/firmware/b43/lp0bsinitvals15.fw
/rom/lib/firmware/b43/lp0initvals13.fw
/rom/lib/firmware/b43/lp0initvals15.fw
/rom/lib/firmware/b43/n0bsinitvals11.fw
/rom/lib/firmware/b43/n0bsinitvals16.fw
/rom/lib/firmware/b43/n0initvals11.fw
/rom/lib/firmware/b43/n0initvals16.fw
/rom/lib/firmware/b43/pcm5.fw
/rom/lib/firmware/b43/ucode11.fw
/rom/lib/firmware/b43/ucode13.fw
/rom/lib/firmware/b43/ucode15.fw
/rom/lib/firmware/b43/ucode16_mimo.fw
/rom/lib/firmware/b43/ucode29_mimo.fw
/rom/lib/firmware/b43/ucode5.fw
/rom/lib/firmware/b43legacy
/rom/lib/firmware/b43legacy/b0g0initvals2.fw
/rom/lib/firmware/b43legacy/pcm4.fw
/rom/lib/firmware/b43legacy/ucode2.fw
/rom/lib/firmware/b43legacy/ucode4.fw
/rom/lib/modules/3.10.18/b43.ko
/rom/lib/modules/3.10.18/b43legacy.ko
/rom/usr/lib/opkg/info/kmod-b43.control
/rom/usr/lib/opkg/info/kmod-b43.list
/rom/usr/lib/opkg/info/kmod-b43legacy.control
/rom/usr/lib/opkg/info/kmod-b43legacy.list
/sys/bus/pci/drivers/b43-pci-bridge
/sys/bus/pci/drivers/b43-pci-bridge/bind
/sys/bus/pci/drivers/b43-pci-bridge/0000:00:01.0
/sys/bus/pci/drivers/b43-pci-bridge/new_id
/sys/bus/pci/drivers/b43-pci-bridge/uevent
/sys/bus/pci/drivers/b43-pci-bridge/unbind
/sys/bus/pci/drivers/b43-pci-bridge/remove_id

My config/wireless file looks like this:

config wifi-device 'radio0'
    option type 'brcmsmac'
    option channel '11'
    option hwmode '11g'
    option path 'bcma0:0'
    option disabled '0'

config wifi-iface
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid 'OpenWrt'
    option encryption 'none'

config wifi-device 'radio1'
    option type 'brcmsmac'
    option channel '11'
    option hwmode '11g'
    option path 'pci0000:00/0000:00:01.0/ssb0:0'
    option disabled '0'

config wifi-iface
    option device 'radio1'
    option network 'lan'
    option mode 'ap'
    option encryption 'none'
    option ssid 'OpenWrt5'

I would love to see more documentation on how to activate the different drivers for bcm47xx hardware. Happy to give more info about my setup.

(Last edited by wbr on 26 Nov 2013, 01:31)

Here is what I have done:

opkg update
opkg install kmod-brcmsmac
opkg install kmod-brcmutil

rmmod b43
rmmod b43legacy
rmmod wl
rmmod brcmsmac
rmmod brcmutil
modprobe brcmsmac

# make sure to delete the old config files ... you have to ...
rm -f /etc/config/wireless
wifi detect > /etc/config/wireless
vi /etc/config/wireless


Now comment out # "option disabled 1"


My configuration looks like:
root@OpenWrt:~# cat /etc/config/wireless
config wifi-device  radio0
    option type     mac80211
    option channel  11
    option hwmode    11ng
    option path    'bcma0:0'
    option htmode    HT20
    list ht_capab    GF
    list ht_capab    SHORT-GI-20
    list ht_capab    SHORT-GI-40
    # REMOVE THIS LINE TO ENABLE WIFI:
    # option disabled 1

config wifi-iface
    option device   radio0
    option network  lan
    option mode     ap
    option ssid     OpenWrt
    option encryption none
 



After this, run:
wifi



And you should see OpenWrt on your laptop ...


=======

Here is the output of  "iw phy" command

Wiphy phy2
    max # scan SSIDs: 4
    max scan IEs length: 2257 bytes
    Coverage class: 0 (up to 0m)
    Device supports RSN-IBSS.
    Supported Ciphers:
        * WEP40 (00-0f-ac:1)
        * WEP104 (00-0f-ac:5)
        * TKIP (00-0f-ac:2)
        * CCMP (00-0f-ac:4)
    Available Antennas: TX 0 RX 0
    Supported interface modes:
         * IBSS
         * managed
         * AP
         * AP/VLAN
         * monitor
    Band 1:
        Capabilities: 0x70
            HT20
            Static SM Power Save
            RX Greenfield
            RX HT20 SGI
            RX HT40 SGI
            No RX STBC
            Max AMSDU length: 3839 bytes
            No DSSS/CCK HT40
        Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
        Minimum RX AMPDU time spacing: 8 usec (0x06)
        HT TX/RX MCS rate indexes supported: 0-15
        Bitrates (non-HT):
            * 1.0 Mbps
            * 2.0 Mbps (short preamble supported)
            * 5.5 Mbps (short preamble supported)
            * 11.0 Mbps (short preamble supported)
            * 6.0 Mbps
            * 9.0 Mbps
            * 12.0 Mbps
            * 18.0 Mbps
            * 24.0 Mbps
            * 36.0 Mbps
            * 48.0 Mbps
            * 54.0 Mbps
        Frequencies:
            * 2412 MHz [1] (27.0 dBm)
            * 2417 MHz [2] (27.0 dBm)
            * 2422 MHz [3] (27.0 dBm)
            * 2427 MHz [4] (27.0 dBm)
            * 2432 MHz [5] (27.0 dBm)
            * 2437 MHz [6] (27.0 dBm)
            * 2442 MHz [7] (27.0 dBm)
            * 2447 MHz [8] (27.0 dBm)
            * 2452 MHz [9] (27.0 dBm)
            * 2457 MHz [10] (27.0 dBm)
            * 2462 MHz [11] (27.0 dBm)
            * 2467 MHz [12] (disabled)
            * 2472 MHz [13] (disabled)
            * 2484 MHz [14] (disabled)
    Supported commands:
         * new_interface
         * set_interface
         * new_key
         * start_ap
         * new_station
         * new_mpath
         * set_mesh_config
         * set_bss
         * authenticate
         * associate
         * deauthenticate
         * disassociate
         * join_ibss
         * join_mesh
         * set_tx_bitrate_mask
         * frame
         * frame_wait_cancel
         * set_wiphy_netns
         * set_channel
         * set_wds_peer
         * probe_client
         * set_noack_map
         * register_beacons
         * start_p2p_device
         * Unknown command (92)
         * testmode
         * connect
         * disconnect
    Supported TX frame types:
         * IBSS: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
         * managed: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
         * AP: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
         * AP/VLAN: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
         * mesh point: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
         * P2P-client: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
         * P2P-GO: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
         * P2P-device: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
    Supported RX frame types:
         * IBSS: 0x40 0xb0 0xc0 0xd0
         * managed: 0x40 0xd0
         * AP: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
         * AP/VLAN: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
         * mesh point: 0xb0 0xc0 0xd0
         * P2P-client: 0x40 0xd0
         * P2P-GO: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
         * P2P-device: 0x40 0xd0
    software interface modes (can always be added):
         * AP/VLAN
         * monitor
    interface combinations are not supported
    HT Capability overrides:
         * MCS: ff ff ff ff ff ff ff ff ff ff
         * maximum A-MSDU length
         * supported channel width
         * short GI for 40 MHz
         * max A-MPDU length exponent
         * min MPDU start spacing
    Device supports TX status socket option.
    Device supports HT-IBSS.
    Device supports low priority scan.
    Device supports scan flush.
    Device supports AP scan.

The discussion might have continued from here.