OpenWrt Forum Archive

Topic: TP-LINK 1043nd ver 2.1

The content of this topic has been archived on 19 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello,

I bought this router. Can i run in it openwrt ?

Thanks

i can't see any useful info on that topic..

anyway.. can you open it and post good pictures of the board?

yeah, i do not see any useful that topic.... and i think if no solution i take back this router and search another...

WR1043ND V2 is based on the QCA chip as the Archer C7 and the WDR7500.
Support should be present if someone is willing to port it.

the wr1043ndv2 is based on the ap135/136 reference board and is easy enough to support (not currently supported).
only since i don't have that router, i need someone to test stuff (and possibly brick the device a few times in the process).
So if someone is daring enough, should me an email and we can work things out. I'm a bit hesitant to put not completely functional firmware on the forum since the wr1043nd(v2) is in high demand and if something isn't working I have to go trough posts/mails and stuff that it doesn't work and I NEED to fix that.

Also what will not work is the nat acceleration chip, currently not supported.

(Last edited by FriedZombie on 19 Nov 2013, 17:03)

I have some devices of version v2.1 for testing. Please tell me what you need and what I should provide.

Thanks to Juhosg the 1043ndv2.x is now supported under openwrt as of revision R38958

I got recently WR1043NDv2 and since I got into some difficulties I noticed that while it identifies as ap135 platform

U-Boot 1.1.4 (Jun 18 2013 - 15:51:52)

ap135 - Scorpion 1.0DRAM:  
sri
Scorpion 1.0
ath_ddr_initial_config(178): (16bit) ddr2 init
tap = 0x00000003
Tap (low, high) = (0x0, 0x1c)
Tap values = (0xe, 0xe, 0xe, 0xe)
64 MB
Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x17
flash size 8MB, sector count = 128
Flash:  8 MB
Using default environment

*** Warning *** : PCIe WLAN Module not found !!!
*** Warning *** : PCIe WLAN Module not found !!!
In:    serial
Out:   serial
Err:   serial
Net:   ath_gmac_enet_initialize...
athrs_sgmii_res_cal: cal value = 0x1
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
ath_gmac_enet_initialize: reset mask:c02200 
Scorpion  ----> S17 PHY *
athrs17_reg_init: complete
: cfg1 0x80000000 cfg2 0x7114
eth0: ba:be:fa:ce:08:41
eth0 up
athrs17_reg_init_wan done
SGMII in forced mode
athr_gmac_sgmii_setup SGMII done
: cfg1 0x800c0000 cfg2 0x7214
eth1: ba:be:fa:ce:08:41
eth1 up
eth0, eth1
Setting 0x18116290 to 0x58b1a14f
Autobooting in 1 seconds
## Booting image at 9f020000 ...
   Uncompressing Kernel Image ... OK

there are some differences from Archer C7 which may be confusing.

Flashing from u-boot for example requires using different RAM address (0x80100000 instead of 0x80060000 which is used on Archer devices). This is the sequence which worked for me:

erase 0x9f020000 +0x7c0000
tftp 0x80100000 factory.bin
cp.b 0x80100000 0x9f020000 0x7c0000
boot.m 0x9f020000

Then the switch configuration differs too:

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 6'

My comments on switch configuration https://forum.openwrt.org/viewtopic.php … 38#p222938

The discussion might have continued from here.