OpenWrt Forum Archive

Topic: Firmware upgrade for TP-Link TL-WR1043ND Version 2.1

The content of this topic has been archived between 15 Apr 2018 and 29 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello I've got a question.
I used often the router "TP-Link TL-WR1043ND Version 1.9", and it was able to make a Firmwareupgrade with Openwrt.
But I cannot do the same on "TP-Link TL-WR1043ND Version 2.1".
I get the following Error message:

Error code: 18005

Upgrade unsuccessfully because the version of the upgraded file was incorrect.
Please check the file name.

Although it worked on the same Router V.1.9
Can Anyone help me?

Well I guess the routers webinterface saved you from bricking your router.
The 1043nd v1.x is very different from the version 2

But thanks to Juhosg the 1043ndv2 is now supported under Barrier breaker

But the Trunk images don't include a WebGui (luci) by default, but you can install it of course.
This also means that you initially have to use the cli

Could you send me the URL for the download please?

Thank you very much smile

Execuse me please but I have a another question.
The upgrade was successfully, but I cannot connect me with the router via the Linux Terminal.
I didn't change the password, and it is usual that the password is admin.
How can I find out what's my password is?

If there isn't a password set yet, you have to login via telnet.
After setting the password, you can login with the username root via ssh. (also telnet will not work anymore).

(Last edited by FriedZombie on 4 Dec 2013, 17:18)

I also can't login, telnet are closed and i haven't credentical for the ssh login.
Ports open: 22, 111, 443, 902
The reset button didn't helped

updated wrote:

I also can't login, telnet are closed and i haven't credentical for the ssh login.
Ports open: 22, 111, 443, 902
The reset button didn't helped

443 port is for https - try web browser with https://<ip>:443

wiki:failsafe mode

I got me a few of these v2's too last week. I was somewhat disappointed after I opened the box en especially because there was no AA-firmware available.
However, the trunk version works well. And yes, you should add Luci yourself if you want a web-if. The most I had to struggle with was the different and not well described setup of the switch as I need vlan-stuff for my purposes.
This new type might even have better performance and more possibilities.

I believe that there hasn't been much discussion about this new version of the 1043 yet. I could write a small post about my way to flash and configure if someone would like.



Hi Erik and Others,

I have also got a v2 and I like to use it with OpenWrt. I'm also a little disappointed cause I haven't known that ther is a v2 of the 1043 (but thats my fault).

It would be very kind if you can post a detailled description what you did to get OpenWrt up and running, and about the difficulties or problems you had, and how you solved them

Cheers, Gerd

Hello Gerd,

I can do that. Maybe today I can give a short list of commands to do an install. The details (like changing switch-config) will take some more days.



Okay, here we go.

I suppose you know how to telnet and to use ssh. Starting-point is an original TP-Link TL-WR1043ND Ver2.1 and you get into its webinterface.
Get the trunk version of OpenWrt from  called  openwrt-ar71xx-generic-tl-wr1043nd-v2-squashfs-factory.bin
Flash your router using this file. After a while the device reboots. The router is now on . Make sure that your PC gets a new dhcp-lease or at least make it able to communicate to the router. Also have the router connected to the Internet to let it download additional packages.

Now for initial purposes you are able to telnet to the device and even get in without using a password:

First thing might be setting a new password:

While you are still connected install the packages you need. Probably it's only Luci that you miss. I like the ip-package as well:
opkg update
opkg install luci ip

To be able to use the webinterface we need to start the http-server:
/etc/init.d/uhttpd enable
/etc/init.d/uhttpd start

Now you can continue configuring by using the webinterface the way you were used to. However, the GUI is changed and you see a lot of IPv6-stuff that you did not see in the AA-releases.

Take care of the fact that you are using a development-version and things might change over night. I noticed this when I experienced package incompatibilities when I wanted to add a package a few weeks after flashing. I had to update to the current trunk version (using ...sysupgrade.bin) to install what I wanted (and I had to reinstall the additional packages).

One big difference between this version 2.1 and the previous (white-case) model is the ethernet-switching. From what I understand, the old one had only one ethernetport (eth0) connected to the switch-silicon. Separation between WAN and LAN was done by VLAN-tagging. The new one seems to have an eth0 and eth1, both connected to a VLAN-switch.
I drew a sketch of how I think the CPU and the Swich-chip are interconnected and defined by default BB:

Sketch_Switch1043v2 bbcode test

The default config does not make use of VLANs but it can be done if you need this (like I do very much). Its GUI just is not as clear as it should. Here is a part of the graphical config of the switch in which I wrote the denotiations that corespond with the labels on the outside to make it more clear.

GUI_Switch1043v2 bbcode test

One hint on adding vlan's that might save you lots of frustration: If you add a new vlan, it is presented as an eth0.xx in the GUI. So, if you choose this one when you add a new interface this is mostly not the one you meant as eth0 is used as WAN-port by default.
Under the interfaces Physical Settings, don't select the new pre-defined vlan but just fill in the Custom Interface  eth1.xx

As I'm not an OpenWrt-guru, please post your comments and corrections to this topic and I will add them to this post. Also, maybe someone might add this to the 1043's wiki-page.

Good luck!


(Last edited by Zanzani on 24 Feb 2014, 00:59)

Hi Erik,

thanks a lot for the detailled instructions. I'll perform the installation of BB soon, maybe this weekend, and with your recipe I'm in good mood that it will work well :-).

cheers, Gerd

I just extended my previous post with some pictures. Maybe it can help you.


I have a tp-link wr1043nd v2.1, and am using a macbook pro with mac os x and version 10.9.1.
I followed the instructions on:

a) Hard reset 30-30-30
b) flash … actory.bin
c) reset
d) hard reset 30-30-30

After doing this, the router does not respond via firefox or safari at

So I went searching and found this forum chain, specifically FriedZombie's comment "the Trunk images don't include a WebGui (luci) by default, but you can install it of course.
This also means that you initially have to use the cli"

So I went to the command line. The router will respond to pings with ttl=64, and it responds to ssh but I don't know the password, but does not respond to telnet (telnet just hangs). I would normally use telnet to set the default ssh password, right?

My questions:
1) Any idea why it doesn't respond to telnet but will respond to pings? Do I need a separate serial line for telnet? Is there a port I need to specify in the command line?
2) What is the default password for ssh? Is there a default password or a way to reset the router's default root password for ssh?
3) After 1&2 are solved, how do I configure the router so that I can use the web gui at

Thank you!

Hello Arincm,

After flashing you should be able to access the device using telnet. At least as long as you do not set a password. Afterwards telnet will be disabled and you cannot start a new telnet session. Only your current connection keeps up until you end it.

As you tell us that you able to ssh to the device on I'm sure that you are on the LAN-side (access from WAN is blocked by the firewall for all services).
Just to make sure that your telnet client-program is working, try telnetting to the ssh-port by:
telnet 22

You should at least see something like this:

A serial cable is always a good idea if you're in to OpenWrt. That is mostly the only way to peek in the device when it is locked for some reason or in case you don't know the password.

Good luck, keep us informed,



Do you know, how exactly is switch from (default) telnet to (secured) ssh implemented? What exactly are the conditions for having telnet available and then having only ssh available (or for having available both)?

For example, on my boxes, I always build the image with authorized_keys (in /etc/dropbear/authorized_keys) and I can connect with ssh right after I flash the image without telneting (or changing root password). In fact I never care about root password or telnet.

(Last edited by risa2000 on 9 Mar 2014, 12:57)

Hi Risa2000,

It's just experience, I did no research on this. But I just tested the procedure on some other TP-link router. I found out that the telnetd is still running after setting the root-password but it refuses to get connected the next time you try. You get disconnected immediately. No chance of entering a username:

$ telnet
Connected to
Escape character is '^]'.
Login failed.
Connection closed by foreign host.

About the authorized_key-login: I know about it but I've never used it. Sounds interesting. Can you point me to some articles where it is described?

I get new 1043 v2 and flash with BB from trunk. Im linux user and all was simple smile thanks to OpenWRT team smile
I need LAMP server and instal lighttpd + php5 and all works in minutes but then I try to instal misql-server package and ... bump - dont have space in /observer - have 2.1MB but need 2.4MB.

What can I do now?

And second - where will be stored DB files in OpenWRT filesystem structure, will be small but where smile

(Last edited by ikostadinoff on 1 Apr 2014, 19:02)


am installed BB on my new 1043v2, but problem is that on WIFI configuration i see and i can only use y 801.11b and 802.11g modes. Is current limitation of openwrt for this model, or have i something wrong?