OpenWrt Forum Archive

Topic: TG787v - KPN Experia box TG787

The content of this topic has been archived on 1 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Thomson TG787v SIP


I got one TG787v, firmware version 8.6.L.1 from KPN (dutch provider).
More details here on OpenWRT.

System Information    

Product Name:    TG787v
Serial Number:    CP0927MT3DD
Software Release:    8.6.L.1
Software Variant:    CX
Boot Loader Version:    1.0.2
Product Code:    3652398A
Board Name:    VDNT-D

System Configuration    
This page summarizes the current configuration of your Thomson Gateway.

    Service Configuration
Service Name:    KPN Experia Box, TG787v

    Time Configuration
Time Source:    Automatic
Date:    01-01-2000
Time:    02:00:55
Timezone:    (UTC+01:00)
Summer Time:    No
Time Since Power-on:    0 days, 1:00:55
Time Server 1:
Time Server 2:
Time Server 3:
Time Server 4:
Time Server 5:

    System Configuration
Web Browsing Interception:    Automatic

    Delen van spelen & toepassingen        
    Telefonie:        Ingeschakeld
    Adresboek:        Ingeschakeld
    Sip-server:        Ingeschakeld

I want to run openWRT, because i don't wanna use DSL, all i need is WiFi as AP (WAN), to 4 x 100MBps ethernet.

The current firmware on the device does not have upgrade firmware, or USB function, so i guess i need to flash the device serial (TTL).

After using a HUB (it keeps the TFTP running, while rebooting TG787v with reset button pressed until the upload starts) i could flash the box with TFTP32 from journin, with 787v_8265.bli as Boot File.
Power and Ethernet LEDs flash together about 1time each second, but not regularly.

1st try:
Took a while (3Kbps over 100Mbps line) but anyway. The device rebooted without finish correctly, so it looks broken now?

2nd try:
TFTP try went much quicker!
But still no life in the box.

Tried the following Firmware files, all without succes:
- 787v_8265.bli
- TG787_R7447_rel.bin
- TG787v-

Router now starts up, but after 25 pings the router reboots, something is wrong now smile
Time to fix it!

Found out that FW lvl is still 8.6.L.1; very fast try to get to home page before router reboots.
It looks like they build it quiet good thighten.

Waiting for my TTL Serial cable to arrive any day now, to monitor more closely whats happening.

Anyone has tried to re-flash such a device without the serial (or JTAG) cable, i.e. by TFTP new flash to this device? I am very interested. (Most probably i need the serial connection : )

I'll keep posting.

Regards, DG.

After using the TTL 3.3V RS232 converter mostly last year for ZyXEL P-2812HNU-F1 devices.
Today it died using it on the TG787v, so it's MOST probably NOT 3.3V TTL serial !!

(Last edited by DGDodo on 30 May 2015, 18:46)

I am trying to flash my TG787 into a different firmware because I am stuck with the ISP firmware without any kind of support for swapping.

Have you had any more luck trying to get OpenWRT to work on it?


I must say i did not try it anymore after frying a TTL serial device on this box smile
Have enough other devices that do work with OpenWrt, i guess i'll stay with those...
Maybe 4u better to buy another device which can run OpenWrt easier.

The discussion might have continued from here.