OpenWrt Forum Archive

Topic: Support for (RT3662 based) Edimax BR-6475nD

The content of this topic has been archived on 19 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi.

According to table of hardware, Edimax BR-6475nD is "fully or reasonably" supported by OpenWrt. There is also a patch that brings support for this device (though apparently it has never been imported). And, looking in downloads, it seems there are images missing for RT3662/RT3883 devices, either in AA or snapshots.

So the question: is this device really supported? And if so, has anyone actually succeeded in running OpenWrt on it (or any other RT3662/RT3883 based device)?

Thanks.

PS: In case OpenWrt runs on this device, AFAICT it will also run on very similar BR-6675nD. Edimax firmwares for these two devices come from the same source code, and I'm actually running v1.22 (which is for 6675) on 6475.

Hm, no reply for almost two months? Then, IMHO, those Ralink based devices really should not be mentioned as "reasonably supported" in TOH.

Hi

Try breaker trunk.
Select BR-6475nD in menuconfig.

Sorry for necroposting.
But is 6475nd supported as of now? I see br-6475nd target in BB, but there's no explanation on how to flash it to the router. Also, it is unknown if everything works fine.
Does anybody have some info?

(Last edited by acaN on 20 Aug 2014, 21:39)

Hi, sorry to bring this back,
but somebody tried flash barrier breaker to this router?

edit:
Well, i ended up trying, barrier breaker not worked too well, but lastest trunk worked perfectly, not a single issue (wifi was hard to configure, maybe some wrong default values)
I tried pppoe, client mode, 2.4 ghz, 5ghz, qos, ddns, upnp.

(Last edited by diogosena on 15 Feb 2015, 20:27)

How did you manage to install openwrt on br-6475nd?
I tried both upload using UI and tftp - and both attempts failed  - after restart, router is not responding and I have to flash stock rom back to restore it to operational mode.

just installed the easy way, flashing directly from browser.

edit: i'm using this version OpenWrt Chaos Calmer r44439 / LuCI (git-15.041.27918-86c6272)

(Last edited by diogosena on 17 Jun 2015, 13:53)

I tried with rc2 from june 15th and with several older images - and no luck. Stuck after first reboot of router and no access to router ip for first login

I just used a fixed ip address (remember that openwrt IP is different than edimax default IP), and accessed router trough ssh to install luci.

edit: I remember that i used failsafe mode one time (i thought that i did something wrong), maybe that's why it worked for me?

(Last edited by diogosena on 17 Jun 2015, 14:24)

I confirm that I am unable to access openwrt for firstlogin and router seems stuck.
I tried also with failsafe mode- according to led blinking, I was in that mode - but again, no access to router ip.

the only thing that is working after flashing openwrt image is to flash back stock image
I  thought that the configuration that is stored in router for the stock image is preventing installation of openwrt - but after reset, I am not able to boot into openwrt

Perhaps mine is different hardware version - it says V1.0B on the sticker

(Last edited by bbogus on 19 Jun 2015, 01:01)

Hi
I'm stuck into the same state: router does not configure LAN (no access whatsoever, no UDP broadcast) even in failsafe mode (LED blinking fast).
Please, how did you ("bbogus") flash back the original firmware?

the flashing steps for both openwrt and stock images are the same when done via tftp

to flash back stock image:
1. download stock image from edimax website (http://www.edimax.com/images/Image/Firm … _v1.17.zip)
2. extract the bin file from this zip
3. turn off the router, press RESET and hold, then plug in the power cord and keep holding RESET
4.wait a couple of secs - the lights on router will tun orange
5. setup a static ip address on pc lan card - 192.168.1.10, netmask 255.255.255.0
6. plug in the lan cable into router and into pc
7. push stock image to router using tftp:

tftp -i 192.168.1.6 PUT BR-6475ND_v1.17.bin

after flashing is completed, router will restart with stock image on

you can use the same approach to test if newer snapshot of openwrt is working with this router. I tried about a dozen images - and none of them was working, so I stop trying.

(Last edited by bbogus on 5 Sep 2015, 09:19)

Thanks!
The 192.168.1.6 address did the trick

@diogosena

could you please provide a download link of your working image? I am still unable to install any of the recent images to my edimax.

diogosena, thanks for the info!

I tried will all recent builds - releases, snapshots, even all rc images - I am unable to flash any of them (both using ui and tftp)
after finishing flashing the image, I get only not accessible router with no dhcp (assigning me ip like 169.254.117.254). I can not enter safemode - I had the led flashing faster, but still can not login into router

the only image that I able to write is the stock image, so I sill have running edimax router smile
Like I mention earlier, I have the feeling that my router is different hardware version sad

The discussion might have continued from here.