OpenWrt Forum Archive

Topic: wireless client bridge mode different ssid

The content of this topic has been archived on 22 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I have a mifi device that is my gateway to the internet.  I have got a TP-Link router that I would like to have as a client wireless bridge to the mifi device.
 
I think the best option for me would be to  use the Masquerade method explained here http://wiki.openwrt.org/doc/recipes/rou … asquerade, where I basically have the TP-link router with OpenWrt connect to the mifi access point wirelessly. 
 
My main issue, however, is after reading how to do the configuration I’m not sure whether or not I’m am able to have an SSID on the TP-link device that is different from the mifi device. 
 
Is it possible in any way to have the two devices have two difference SSIDS?  I would like all my devices in a particular room to connect to the TP-LINK router and having the same SSIDs might prevent me from doing that.

Thanks for the response,  but can I have 2 different WiFi-iface for one device?  it looks whenever I have 2 the bottom one overwrites the upper.

Should they both have the same network?  e.g 'lan'

iamus wrote:

Thanks for the response,  but can I have 2 different WiFi-iface for one device?  it looks whenever I have 2 the bottom one overwrites the upper.

Should they both have the same network?  e.g 'lan'

Sure you can have 2 different wifi-iface for one radio, but if you do give them both the same name the last entry is used, the previous ones will be overwritten.

ok, I'm getting closer. I have a connection to the internet from the router since I'm connected to the mifi.  And I can see the second ssid being broadcasted from the router itself. 

But the problem is I can't seem to lease dhcp addresses either by connecting directly to the router or by connecting to its wifi interface.  When I connect through the cable, I statically set the interface on the laptop to the same subnet and I can ping the router, however, I cannot do the same when I try the wireless interface. 


is there a log I can look at to troubleshoot this?  /var/log seems to be empty

thanks

maybe post your config (network and wireless, hiding passwords tongue)

Sorry it took me a while, the router was behaving weirdly and I lost access.  Had to figure out how to boot in failsafe moe and reset

/etc/config/wireless

config wifi-device  radio0
        option type     mac80211
        option channel  11
        option hwmode   11ng
        option path     'platform/ath9k'
        option htmode   HT20
        list ht_capab   SHORT-GI-40
        list ht_capab   DSSS_CCK-40
        # REMOVE THIS LINE TO ENABLE WIFI:
        option disabled 0



config wifi-iface
        option ssid 'hades'
        option encryption 'psk2'        # Set wep, psk or psk2 for WEP, WPA or WPA2
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option key 'smoker'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'poseidon'
        option encryption 'psk2'
        option key 'smoker'
        option network 'lan'




/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

#config globals 'globals'
#       option ula_prefix 'fdf9:27d8:ca6c::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        option ip6assign '60'

config interface 'wwan'
        option ifname 'eth0.2'
        option proto 'dhcp'
~


/etc/config/dhcp


config dnsmasq
        option domainneeded     1
        option boguspriv        1
        option filterwin2k      0  # enable for dial on demand
        option localise_queries 1
        option rebind_protection 1  # disable if upstream must serve RFC1918 addresses
        option rebind_localhost 1  # enable for RBL checking and similar services
        #list rebind_domain example.lan  # whitelist RFC1918 responses for domains
        option local    '/lan/'
        option domain   'lan'
        option expandhosts      1
        option nonegcache       0
        option authoritative    1
        option readethers       1
        option leasefile        '/tmp/dhcp.leases'
        option resolvfile       '/tmp/resolv.conf.auto'
        #list server            '/mycompany.local/1.2.3.4'
        #option nonwildcard     1
        #list interface         br-lan
        #list notinterface      lo
        #list bogusnxdomain     '64.94.110.11'

config dhcp lan
        option interface        lan
        option start    100
        option limit    150
        option leasetime        12h

config dhcp wwan
        option interface        wwan
        option ignore   1
~
~

/etc/config/firewall

config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
        option name 'lan'
        option network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wwan'

config forwarding
        option src 'lan'
        option dest 'wan'
~
~

cpuinfo and version

I find it weird that it says barrier breaker since I downloaded attitude adjustment




BARRIER BREAKER (Bleeding Edge, r39211)
-----------------------------------------------------
  * 1/2 oz Galliano         Pour all ingredients into
  * 4 oz cold Coffee        an irish coffee mug filled
  * 1 1/2 oz Dark Rum       with crushed ice. Stir.
  * 2 tsp. Creme de Cacao
-----------------------------------------------------

Linux version 3.10.24 (openwrt@OpenWRT) (gcc version 4.6.4 (OpenWrt/Linaro GCC 4.6-2013.05 r39211) ) #1 Thu Jan 9 09:45:20 MST 2014

root@OpenWrt:/# cat /proc/cpuinfo
system type             : Atheros AR9132 rev 2
machine                 : TP-LINK TL-WR1043ND
processor               : 0
cpu model               : MIPS 24Kc V7.4
BogoMIPS                : 265.42
wait instruction        : yes
microsecond timers      : yes
tlb_entries             : 16
extra interrupt vector  : yes
hardware watchpoint     : yes, count: 4, address/irw mask: [0x0000, 0x0ff8, 0x0ff8, 0x0ff8]
isa                     : mips1 mips2 mips32r1 mips32r2
ASEs implemented        : mips16
shadow register sets    : 1
kscratch registers      : 0
core                    : 0
VCED exceptions         : not available
VCEI exceptions         : not available

remove option ifname 'eth0.2' from wwan interface.
also you need add bssid option to

config wifi-iface
    option ssid 'hades' 

may be this also could be a problem: you selected wrong channel, change it to 'auto'.
Atheros doesn't support wireless bridge, use pseudobridge [link]http://wiki.openwrt.org/doc/recipes/relayclient[/link]

(Last edited by neryba on 10 Jan 2014, 09:50)

Think this router is just not good enough,  I can't even get dhcp when I connect to Ethernet.  Is there any recommended router with openwrt for what I need to do?

different thread an device, bassicly the same discussion: https://forum.openwrt.org/viewtopic.php?pid=221920
Also maybe gargoyle is better suited for what you expect, wifi bridging and a simpler gui: http://www.gargoyle-router.com/

Also you did install Barier breaker/trunk release and not Atitude adjustment.

Anyway, what you want to accomplis is rather simple (as well under luci).
What I recommend is reset openwrt to factory defaults first.

  1. Log into the luci webgui

  2. Click on wifi under the network tab

  3. Click on edit behind the wirless network

  4. Set all settings for your private wifi network as desired (security and ssid)

  5. Save and apply the settings

  6. Enable the wifi radio, by clicking the enable button behind the wifi network

  7. Click on the scan button

  8. In the list that appears, click on 'Join network' for the appropriate network you want to connect to

  9. Untick 'Replace wireless configuration'

  10. Fillout the WPA/WEP passphrase if that's needed

  11. Click on submit

  12. And save and apply the unsaved changes

Happy mifi internetting.

(Last edited by FriedZombie on 11 Jan 2014, 04:10)

FriedZombie,

Thanks for the input.  It works now smile  I also flashed attitude adjustment.

The discussion might have continued from here.