OpenWrt Forum Archive

Topic: USB 5GHz WiFi stick?

The content of this topic has been archived on 16 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hey there.

I have a couple of OpenWRT routers that only support 2.4GHz WiFi. Two of them are TP-Link 1043 and another one is a Netgear WNR3500.
I would like to enhance those by adding a 5GHz USB WiFi stick.

Is there a USB stick available?
I would prefere one that just works with integrated drivers. If this isn't possible, if this requires some compilation, I would need a tutorial for that since I never did it before.

Would be pretty awesom if I didn't have to throw my existing routers away just for adding 5GHz channels.

Regards,
Stephan.

[edit]

Ah. Additionally, as a first step it would be sufficient to have such a device working in client mode. That would allow me to expose 2.4GHz WiFi for my clients but use 5GHz for bridging the routers. This solves the current WDS-same-channel-issue.

(Last edited by golialive on 7 Jan 2014, 03:44)

I tested AP mode with an Ralink based RT5572 usb adapter ( Tplink Tl-WDN3200 ) in Openwrt trunk 39180.
The RT5572 is dual band. http://wikidevi.com/wiki/TP-LINK_TL-WDN3200

Just be careful about overheating the device.

Hey zhadoom.

Wooha. Thank you. Because they are pretty rare, I feared that nobody had any success at all.

Since I'm slightly impatient I just ordered that one smile

When searching for "how to install" (what I did the hour before opening this thread and about two hours after that) I find several guys compiling their drivers. Did you use the default kmod-rt2800-usb being available through opkg or did you compile something?

What do you mean by overheating? Is it going to become hot just by regular usage or only when I push heavily data through it? But in general that shouldn't be a big issue. If it really gets too hot, I could just open the cover and add some fans smile.

Because I'm "really" inpatient, I ordered several decices:
* RTL8192CU (unnamed by Amazon seller, http://wikidevi.com/wiki/TP-LINK_TL-WN8200ND)
* RT5572 (TP-Link 3200, http://wikidevi.com/wiki/TP-LINK_TL-WDN3200)
* BCM43236 (Linksys AE2500, http://wikidevi.com/wiki/Linksys_AE2500)

I basically went through this table and compared AP mode aware devices with Amazon availability and "kmod-" packages of opkg. OK, the BCM doesn't have AP mode, but because I can use client-only ones as well (at least one of them), I decided to give completely different types a try.
http://wireless.kernel.org/en/users/Drivers

I will give you my experiences after some testing.

Regards,
Stephan.

When operating in ap mode the usb device transmit data more frequently so this cause more power drain and heat. This issue can be avoided by reducing the txpower.

I ordered a TL-WDN3200 to convert a TL-WR710N into a dual-band router.  Unfortunately it claims to have RT5592 chipset rather than RT5572 and refuses to work in anything but 2.4Ghz client mode. sad 

[  722.090000] ieee80211 phy3: rt2x00_set_rt: Info - RT chipset 5592, rev 0222 detected
[  722.130000] ieee80211 phy3: rt2x00_set_rf: Info - RF chipset 000f detected
[  722.140000] ieee80211 phy3: Selected rate control algorithm 'minstrel_ht'
[  722.160000] ieee80211 phy3: rt2x00lib_request_firmware: Info - Loading firmware file 'rt2870.bin'
[  722.180000] ieee80211 phy3: rt2x00lib_request_firmware: Info - Firmware detected - version: 0.29

Googling seems to find very little information about that chipset and its only mentioned as being PCIe which is odd.

There is a suggestion that it doesn't work, that its WIP and one mention of someone who got it working.  I have no clue which patches are in the current OpenWRT build though so kinda stuck.

Even on my Fedora box with kernel 3.13.6 it only works in client mode, although it DOES at least work in 5Ghz on there.

@zhadoom
How did you get your Tplink Tl-WDN3200 working?

IMO the best solution for this is using an Atheros USB stick such as the Netgear WNDA3200.

The Ralink chips, even if you manage to get them working, often have terrible performance (maxing out at ~80Mbps on 300Mbps N) with high CPU load owing to a terrible driver.

The Atheros ones easily exceed 180Mbps without overloading the router CPU. £10 or so of Ebay.

Just a quick test. Asus RT-N13U r38451

[  171.880000] usb 1-1: new high-speed USB device number 2 using dwc_otg
[  172.130000] usb 1-1: no of_node; not parsing pinctrl DT
[  172.150000] rt2800usb 1-1:1.0: no of_node; not parsing pinctrl DT
[  172.340000] usb 1-1: reset high-speed USB device number 2 using dwc_otg
[  172.560000] ieee80211 phy1: rt2x00_set_rt: Info - RT chipset 5592, rev 0222 detected
[  172.640000] ieee80211 phy1: rt2x00_set_rf: Info - RF chipset 000f detected
[  172.660000] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'

lsusb
Bus 001 Device 002: ID 148f:5572 Ralink Technology, Corp. RT5572 Wireless Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I installed many ralink drivers in RT-N13U but I believe that is this " rt2800usb" that support RT5572 in Barrier Breaker.

Since it is detected I run in ssh shell:

cd /etc/config
wifi detect > wireless

Go to Luci interface -> Network -> Wifi
It shows two interfaces: The internal from RT3052 and the external ( usb ) detected as "802.11abgn (radio1)".

It's just that I already have the Tl-WDN3200. I'm trying to use it with the carambola2 embedded system/router and get it to function as a 5 GHz AP. I've never had to install a driver in openwrt before, so I'm not completely certain about how to do it.

When you "installed" the drivers did you build them yourself? I've tried that and I'm running into quite a few issues. Did you perform a similar build process to what's outlined here: https://forum.openwrt.org/viewtopic.php?id=38930 ?

If you use a prebuilt copy of Openwrt stable then installing drivers is the same as installing any other software package. Go to the web interface under Software, type in name of the driver you want, and click install. Under the command line it's opkg install <name of driver>

e.g.

opkg update
opkg install kmod-rt2x00-usb

You only have to build them yourself if you built Openwrt yourself or you are using an out of date trunk image.

Top-Dog wrote:

It's just that I already have the Tl-WDN3200. I'm trying to use it with the carambola2 embedded system/router and get it to function as a 5 GHz AP. I've never had to install a driver in openwrt before, so I'm not completely certain about how to do it.

When you "installed" the drivers did you build them yourself? I've tried that and I'm running into quite a few issues. Did you perform a similar build process to what's outlined here: https://forum.openwrt.org/viewtopic.php?id=38930 ?

I used a trunk release and the drivers from the packages.

Thanks that helped, but I could not get the driver to install from a package using opkg.

So, after lots of looking I manged to get it working by building it in with my system image. (FYI: the driver is the kmod-rt2800-usb (and kmod-rt2x00-lib)) and is found under Kernel modules-> Wireless Drivers in the 'make menuconfig' window.

Is anyone successfully setup AP mode with TPLINK TL-WDN3200?
I bought a TL-WDN3200 and connecting with my Raspberry Pi, but LuCI shows "Wireless is disabled or not associated".

root@OpenWrt:~# iwinfo radio0 info
radio0    ESSID: unknown
          Access Point: 00:00:00:00:00:00
          Mode: Unknown  Channel: unknown (unknown)
          Tx-Power: unknown  Link Quality: unknown/70
          Signal: unknown  Noise: unknown
          Bit Rate: unknown
          Encryption: unknown
          Type: nl80211  HW Mode(s): 802.11abgn
          Hardware: unknown [Generic MAC80211]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: yes  PHY name: phy0
BusyBox v1.22.1 (2014-08-05 03:53:48 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 BARRIER BREAKER (14.07-rc3, r42056)
 -----------------------------------------------------
  * 1/2 oz Galliano         Pour all ingredients into
  * 4 oz cold Coffee        an irish coffee mug filled
  * 1 1/2 oz Dark Rum       with crushed ice. Stir.
  * 2 tsp. Creme de Cacao
 -----------------------------------------------------
root@OpenWrt:~# iw list
Wiphy phy0
    max # scan SSIDs: 4
    max scan IEs length: 2257 bytes
    Retry short limit: 7
    Retry long limit: 4
    Coverage class: 0 (up to 0m)
    Available Antennas: TX 0 RX 0
    Supported interface modes:
         * IBSS
         * managed
         * AP
         * AP/VLAN
         * WDS
         * monitor
         * mesh point
    Band 1:
        Capabilities: 0x2f2
            HT20/HT40
            Static SM Power Save
            RX Greenfield
            RX HT20 SGI
            RX HT40 SGI
            TX STBC
            RX STBC 2-streams
            Max AMSDU length: 3839 bytes
            No DSSS/CCK HT40
        Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
        Minimum RX AMPDU time spacing: 2 usec (0x04)
        HT RX MCS rate indexes supported: 0-15, 32
        TX unequal modulation not supported
        HT TX Max spatial streams: 2
        HT TX MCS rate indexes supported may differ
        Frequencies:
            * 2412 MHz [1] (30.0 dBm)
            * 2417 MHz [2] (30.0 dBm)
            * 2422 MHz [3] (30.0 dBm)
            * 2427 MHz [4] (30.0 dBm)
            * 2432 MHz [5] (30.0 dBm)
            * 2437 MHz [6] (30.0 dBm)
            * 2442 MHz [7] (30.0 dBm)
            * 2447 MHz [8] (30.0 dBm)
            * 2452 MHz [9] (30.0 dBm)
            * 2457 MHz [10] (30.0 dBm)
            * 2462 MHz [11] (30.0 dBm)
            * 2467 MHz [12] (disabled)
            * 2472 MHz [13] (disabled)
            * 2484 MHz [14] (disabled)
    Band 2:
        Capabilities: 0x2f2
            HT20/HT40
            Static SM Power Save
            RX Greenfield
            RX HT20 SGI
            RX HT40 SGI
            TX STBC
            RX STBC 2-streams
            Max AMSDU length: 3839 bytes
            No DSSS/CCK HT40
        Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
        Minimum RX AMPDU time spacing: 2 usec (0x04)
        HT RX MCS rate indexes supported: 0-15, 32
        TX unequal modulation not supported
        HT TX Max spatial streams: 2
        HT TX MCS rate indexes supported may differ
        Frequencies:
            * 5180 MHz [36] (disabled)
            * 5190 MHz [38] (disabled)
            * 5200 MHz [40] (disabled)
            * 5210 MHz [42] (disabled)
            * 5220 MHz [44] (disabled)
            * 5230 MHz [46] (disabled)
            * 5240 MHz [48] (disabled)
            * 5250 MHz [50] (disabled)
            * 5260 MHz [52] (disabled)
            * 5270 MHz [54] (disabled)
            * 5280 MHz [56] (17.0 dBm) (radar detection)
              DFS state: usable (for 2151414 sec)
              DFS CAC time: 60000 ms
            * 5290 MHz [58] (17.0 dBm) (radar detection)
              DFS state: usable (for 2151414 sec)
              DFS CAC time: 60000 ms
            * 5300 MHz [60] (17.0 dBm) (radar detection)
              DFS state: usable (for 2151414 sec)
              DFS CAC time: 60000 ms
            * 5310 MHz [62] (17.0 dBm) (radar detection)
              DFS state: usable (for 2151414 sec)
              DFS CAC time: 60000 ms
            * 5320 MHz [64] (17.0 dBm) (radar detection)
              DFS state: usable (for 2151414 sec)
              DFS CAC time: 60000 ms
            * 5500 MHz [100] (30.0 dBm) (radar detection)
              DFS state: usable (for 2151414 sec)
              DFS CAC time: 60000 ms
            * 5510 MHz [102] (30.0 dBm) (radar detection)
              DFS state: usable (for 2151414 sec)
              DFS CAC time: 60000 ms
            * 5520 MHz [104] (30.0 dBm) (radar detection)
              DFS state: usable (for 2151414 sec)
              DFS CAC time: 60000 ms
            * 5530 MHz [106] (30.0 dBm) (radar detection)
              DFS state: usable (for 2151414 sec)
              DFS CAC time: 60000 ms
            * 5540 MHz [108] (30.0 dBm) (radar detection)
              DFS state: usable (for 2151414 sec)
              DFS CAC time: 60000 ms
            * 5550 MHz [110] (30.0 dBm) (radar detection)
              DFS state: usable (for 2151414 sec)
              DFS CAC time: 60000 ms
            * 5560 MHz [112] (30.0 dBm) (radar detection)
              DFS state: usable (for 2151414 sec)
              DFS CAC time: 60000 ms
            * 5570 MHz [114] (30.0 dBm) (radar detection)
              DFS state: usable (for 2151414 sec)
              DFS CAC time: 60000 ms
            * 5580 MHz [116] (30.0 dBm) (radar detection)
              DFS state: usable (for 2151414 sec)
              DFS CAC time: 60000 ms
            * 5590 MHz [118] (disabled)
            * 5600 MHz [120] (disabled)
            * 5610 MHz [122] (disabled)
            * 5620 MHz [124] (disabled)
            * 5630 MHz [126] (disabled)
            * 5640 MHz [128] (disabled)
            * 5650 MHz [130] (disabled)
            * 5660 MHz [132] (30.0 dBm) (radar detection)
              DFS state: usable (for 2151414 sec)
              DFS CAC time: 60000 ms
            * 5670 MHz [134] (30.0 dBm) (radar detection)
              DFS state: usable (for 2151414 sec)
              DFS CAC time: 60000 ms
            * 5680 MHz [136] (30.0 dBm) (radar detection)
              DFS state: usable (for 2151414 sec)
              DFS CAC time: 60000 ms
            * 5690 MHz [138] (30.0 dBm) (radar detection)
              DFS state: usable (for 2151414 sec)
              DFS CAC time: 60000 ms
            * 5700 MHz [140] (30.0 dBm) (radar detection)
              DFS state: usable (for 2151414 sec)
              DFS CAC time: 60000 ms
            * 5745 MHz [149] (30.0 dBm)
            * 5755 MHz [151] (30.0 dBm)
            * 5765 MHz [153] (30.0 dBm)
            * 5775 MHz [155] (30.0 dBm)
            * 5785 MHz [157] (30.0 dBm)
            * 5795 MHz [159] (30.0 dBm)
            * 5805 MHz [161] (30.0 dBm)
            * 5825 MHz [165] (30.0 dBm)
            * 4920 MHz [184] (disabled)
            * 4940 MHz [188] (disabled)
            * 4960 MHz [192] (disabled)
            * 4980 MHz [196] (disabled)
    valid interface combinations:
         * #{ managed, AP, mesh point } <= 8,
           total <= 8, #channels <= 1
    HT Capability overrides:
         * MCS: ff ff ff ff ff ff ff ff ff ff
         * maximum A-MSDU length
         * supported channel width
         * short GI for 40 MHz
         * max A-MPDU length exponent
         * min MPDU start spacing

(Last edited by WilliamTai on 3 Oct 2014, 16:37)

When I tried I ran into the same problem.  It works fine on 2.4Ghz AP mode but not 5Ghz AP mode.

I've been using an RT3573-based stick (Netgear WNDA4100) with the rt2800-usb driver. Works fairly well in AP mode both over 2.4 GHz and 5 GHz. Here's my setup on BB 14.07:

config wifi-device 'radio1'
    option type 'mac80211'
    option hwmode '11a'
    option path '101c0000.otg/usb1/1-1/1-1:1.0'
    option channel '40'
    option htmode 'HT40'
    option country 'US'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'TX-STBC'
    list ht_capab 'RX-STBC123'
Wiphy phy1
    max # scan SSIDs: 4
    max scan IEs length: 2257 bytes
    Retry short limit: 7
    Retry long limit: 4
    Coverage class: 0 (up to 0m)
    Available Antennas: TX 0 RX 0
    Supported interface modes:
         * IBSS
         * managed
         * AP
         * AP/VLAN
         * WDS
         * monitor
         * mesh point
    Band 1:
        Capabilities: 0x3f2
            HT20/HT40
            Static SM Power Save
            RX Greenfield
            RX HT20 SGI
            RX HT40 SGI
            TX STBC
            RX STBC 3-streams
            Max AMSDU length: 3839 bytes
            No DSSS/CCK HT40
        Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
        Minimum RX AMPDU time spacing: 2 usec (0x04)
        HT RX MCS rate indexes supported: 0-23, 32
        TX unequal modulation not supported
        HT TX Max spatial streams: 3
        HT TX MCS rate indexes supported may differ
        Frequencies:
            * 2412 MHz [1] (30.0 dBm)
            * 2417 MHz [2] (30.0 dBm)
            * 2422 MHz [3] (30.0 dBm)
            * 2427 MHz [4] (30.0 dBm)
            * 2432 MHz [5] (30.0 dBm)
            * 2437 MHz [6] (30.0 dBm)
            * 2442 MHz [7] (30.0 dBm)
            * 2447 MHz [8] (30.0 dBm)
            * 2452 MHz [9] (30.0 dBm)
            * 2457 MHz [10] (30.0 dBm)
            * 2462 MHz [11] (30.0 dBm)
            * 2467 MHz [12] (disabled)
            * 2472 MHz [13] (disabled)
            * 2484 MHz [14] (disabled)
    Band 2:
        Capabilities: 0x3f2
            HT20/HT40
            Static SM Power Save
            RX Greenfield
            RX HT20 SGI
            RX HT40 SGI
            TX STBC
            RX STBC 3-streams
            Max AMSDU length: 3839 bytes
            No DSSS/CCK HT40
        Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
        Minimum RX AMPDU time spacing: 2 usec (0x04)
        HT RX MCS rate indexes supported: 0-23, 32
        TX unequal modulation not supported
        HT TX Max spatial streams: 3
        HT TX MCS rate indexes supported may differ
        Frequencies:
            * 5180 MHz [36] (17.0 dBm)
            * 5190 MHz [38] (17.0 dBm)
            * 5200 MHz [40] (17.0 dBm)
            * 5220 MHz [44] (17.0 dBm)
            * 5230 MHz [46] (17.0 dBm)
            * 5240 MHz [48] (17.0 dBm)
            * 5260 MHz [52] (23.0 dBm) (radar detection)
              DFS state: usable (for 2200877 sec)
              DFS CAC time: 60000 ms
            * 5270 MHz [54] (23.0 dBm) (radar detection)
              DFS state: usable (for 2200877 sec)
              DFS CAC time: 60000 ms
            * 5280 MHz [56] (23.0 dBm) (radar detection)
              DFS state: usable (for 2200877 sec)
              DFS CAC time: 60000 ms
            * 5300 MHz [60] (23.0 dBm) (radar detection)
              DFS state: usable (for 2200877 sec)
              DFS CAC time: 60000 ms
            * 5310 MHz [62] (23.0 dBm) (radar detection)
              DFS state: usable (for 2200877 sec)
              DFS CAC time: 60000 ms
            * 5320 MHz [64] (23.0 dBm) (radar detection)
              DFS state: usable (for 2200877 sec)
              DFS CAC time: 60000 ms
            * 5500 MHz [100] (disabled)
            * 5510 MHz [102] (disabled)
            * 5520 MHz [104] (disabled)
            * 5540 MHz [108] (disabled)
            * 5550 MHz [110] (disabled)
            * 5560 MHz [112] (disabled)
            * 5580 MHz [116] (disabled)
            * 5590 MHz [118] (disabled)
            * 5600 MHz [120] (disabled)
            * 5620 MHz [124] (disabled)
            * 5630 MHz [126] (disabled)
            * 5640 MHz [128] (disabled)
            * 5660 MHz [132] (disabled)
            * 5670 MHz [134] (disabled)
            * 5680 MHz [136] (disabled)
            * 5700 MHz [140] (disabled)
            * 5745 MHz [149] (30.0 dBm)
            * 5755 MHz [151] (30.0 dBm)
            * 5765 MHz [153] (30.0 dBm)
            * 5785 MHz [157] (30.0 dBm)
            * 5795 MHz [159] (30.0 dBm)
            * 5805 MHz [161] (30.0 dBm)
            * 5825 MHz [165] (30.0 dBm)
            * 5835 MHz [167] (disabled)
            * 5845 MHz [169] (disabled)
            * 5855 MHz [171] (disabled)
            * 5865 MHz [173] (disabled)
    valid interface combinations:
         * #{ managed, AP, mesh point } <= 8,
           total <= 8, #channels <= 1
    HT Capability overrides:
         * MCS: ff ff ff ff ff ff ff ff ff ff
         * maximum A-MSDU length
         * supported channel width
         * short GI for 40 MHz
         * max A-MPDU length exponent
         * min MPDU start spacing
emacs wrote:

I've been using an RT3573-based stick (Netgear WNDA4100) with the rt2800-usb driver. Works fairly well in AP mode both over 2.4 GHz and 5 GHz.

The WDN3200 is a RT5572/5592 chipset.  I believe it is that specific chipset which does not work properly in 5Ghz AP mode.

Alex Atkin UK wrote:
emacs wrote:

I've been using an RT3573-based stick (Netgear WNDA4100) with the rt2800-usb driver. Works fairly well in AP mode both over 2.4 GHz and 5 GHz.

The WDN3200 is a RT5572/5592 chipset.  I believe it is that specific chipset which does not work properly in 5Ghz AP mode.

Believe or not, it is working (Barrier Braker, 1043nd).

Configuration is simple:
opkg install kmod-rt2x00-usb kmod-rt2x00-lib kmod-rt2800-usb kmod-rt2800-lib

And then edit /etc/config/wireless
config wifi-device 'radio0'
    option type 'mac80211'
    option macaddr 'my_routers_mac'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'DSSS_CCK-40'
    option disabled '0'
    option country 'whatever'
    option hwmode '11ng'
    option htmode 'HT20'
    option distance '6'
    option channel 'whatever'
    option txpower 'whatever'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option ssid 'my_ap_2400m'
    option encryption 'psk2'
    option key 'my_secret_key1'
    option network 'lan'

config wifi-device 'radio1'
    option type 'mac80211'
    option channel '11'
    #this is in my case, may different with your configuration
    option path 'platform/ehci-platform/usb1/1-1/1-1:1.0'
    option htmode 'HT20'
    option macaddr 'my_cards_mac'
    option hwmode '11n'
    option country 'whatever'
    option channel 'whatever_5g'
    option txpower 'whatever'

config wifi-iface
    option device 'radio1'
    option mode 'ap'
    option ssid 'my_ap_5g'
    option encryption 'psk2'
    option key 'my_secret_key2'
    option network 'lan'
    option disabled '0'


And it is working.
There are only two problems:
1. in my case radio0 is wlan1 and radio1 is wlan0, and luci allows me to set 5g channels on the 2.4g radio and does not allow to set the 5g channels on the 5g device
2. this stick is not designed to AP, so overheating can be a (serious) problem. I'll make efficient cooling for this stick (disassemble, a little heatsink, maybe a ventillator on USB 5V)

tbarath wrote:

Believe or not, it is working (Barrier Braker, 1043nd).

I can't get the 2nd radio to start.

This is my /etc/config/wireless:

config wifi-device 'radio0'
    option type 'mac80211'
    option channel '11'
    option hwmode '11ng'
    option path 'platform/bcm2708_usb/usb1/1-1/1-1.5/1-1.5:1.0'
    option htmode 'HT20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'DSSS_CCK-40'
    option txpower '20'
    option country '00'
    option disabled '0'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option network 'wlan'
    option ssid 'my_ssid'
    option encryption 'psk2'
    option key 'my_pass'
    option maxassoc '32'

config wifi-device 'radio1'
    option type 'mac80211'
    option channel '100'
    option hwmode '11n'
    option path 'platform/bcm2708_usb/usb1/1-1/1-1.4/1-1.4:1.0'
    option htmode 'HT20'

config wifi-iface
    option device 'radio1'
    option mode 'ap'
    option network 'wlan'
    option ssid 'my_ssid'
    option encryption 'psk2'
    option key 'my_pass'
    option maxassoc '32'
    option disabled '0'

Any idea what I'm doing wrong? I want them on the same SSID.

Your hwmode is wrong, '11n' is not valid.

It should be '11na' on older builds of OpenWRT or '11a' on newer ones (possibly only trunk right now?).

Alex Atkin UK wrote:

Your hwmode is wrong, '11n' is not valid.

It should be '11na' on older builds of OpenWRT or '11a' on newer ones (possibly only trunk right now?).

Alex,

Thanks for that additional bit of information! I set my TL-WDN3200 adapter to '11na' mode on r42625, and it's working well as an AP.
Little heads up:
- For some reason I have so far only got it to work on channel 44. Doesn't work on 42, and I haven't tried any else yet. Iw list output:

Wiphy phy0
        max # scan SSIDs: 4
        max scan IEs length: 2257 bytes
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Available Antennas: TX 0 RX 0
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * WDS
                 * monitor
                 * mesh point
        Band 1:
                Capabilities: 0x2f2
                        HT20/HT40
                        Static SM Power Save
                        RX Greenfield
                        RX HT20 SGI
                        RX HT40 SGI
                        TX STBC
                        RX STBC 2-streams
                        Max AMSDU length: 3839 bytes
                        No DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 2 usec (0x04)
                HT RX MCS rate indexes supported: 0-15, 32
                TX unequal modulation not supported
                HT TX Max spatial streams: 2
                HT TX MCS rate indexes supported may differ
                Frequencies:
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
                        * 2467 MHz [12] (20.0 dBm)
                        * 2472 MHz [13] (20.0 dBm)
                        * 2484 MHz [14] (disabled)
        Band 2:
                Capabilities: 0x2f2
                        HT20/HT40
                        Static SM Power Save
                        RX Greenfield
                        RX HT20 SGI
                        RX HT40 SGI
                        TX STBC
                        RX STBC 2-streams
                        Max AMSDU length: 3839 bytes
                        No DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 2 usec (0x04)
                HT RX MCS rate indexes supported: 0-15, 32
                TX unequal modulation not supported
                HT TX Max spatial streams: 2
                HT TX MCS rate indexes supported may differ
                Frequencies:
                        * 5180 MHz [36] (20.0 dBm)
                        * 5190 MHz [38] (20.0 dBm)
                        * 5200 MHz [40] (20.0 dBm)
                        * 5210 MHz [42] (20.0 dBm)
                        * 5220 MHz [44] (20.0 dBm)
                        * 5230 MHz [46] (20.0 dBm)
                        * 5240 MHz [48] (20.0 dBm)
                        * 5250 MHz [50] (disabled)
                        * 5260 MHz [52] (20.0 dBm) (radar detection)
                          DFS state: usable (for 2147782 sec)
                          DFS CAC time: 60000 ms
                        * 5270 MHz [54] (20.0 dBm) (radar detection)
                          DFS state: usable (for 2147782 sec)
                          DFS CAC time: 60000 ms
                        * 5280 MHz [56] (20.0 dBm) (radar detection)
                          DFS state: usable (for 2147782 sec)
                          DFS CAC time: 60000 ms
                        * 5290 MHz [58] (20.0 dBm) (radar detection)
                          DFS state: usable (for 2147782 sec)
                          DFS CAC time: 60000 ms
                        * 5300 MHz [60] (20.0 dBm) (radar detection)
                          DFS state: usable (for 2147782 sec)
                          DFS CAC time: 60000 ms
                        * 5310 MHz [62] (20.0 dBm) (radar detection)
                          DFS state: usable (for 2147782 sec)
                          DFS CAC time: 60000 ms
                        * 5320 MHz [64] (20.0 dBm) (radar detection)
                          DFS state: usable (for 2147782 sec)
                          DFS CAC time: 60000 ms
                        * 5500 MHz [100] (disabled)
                        * 5510 MHz [102] (disabled)
                        * 5520 MHz [104] (disabled)
                        * 5530 MHz [106] (disabled)
                        * 5540 MHz [108] (disabled)
                        * 5550 MHz [110] (disabled)
                        * 5560 MHz [112] (disabled)
                        * 5570 MHz [114] (disabled)
                        * 5580 MHz [116] (disabled)
                        * 5590 MHz [118] (disabled)
                        * 5600 MHz [120] (disabled)
                        * 5610 MHz [122] (disabled)
                        * 5620 MHz [124] (disabled)
                        * 5630 MHz [126] (disabled)
                        * 5640 MHz [128] (disabled)
                        * 5650 MHz [130] (disabled)
                        * 5660 MHz [132] (disabled)
                        * 5670 MHz [134] (disabled)
                        * 5680 MHz [136] (disabled)
                        * 5690 MHz [138] (disabled)
                        * 5700 MHz [140] (disabled)
                        * 5745 MHz [149] (disabled)
                        * 5755 MHz [151] (disabled)
                        * 5765 MHz [153] (disabled)
                        * 5775 MHz [155] (disabled)
                        * 5785 MHz [157] (disabled)
                        * 5795 MHz [159] (disabled)
                        * 5805 MHz [161] (disabled)
                        * 5825 MHz [165] (disabled)
                        * 4920 MHz [184] (disabled)
                        * 4940 MHz [188] (disabled)
                        * 4960 MHz [192] (disabled)
                        * 4980 MHz [196] (disabled)
        valid interface combinations:
                 * #{ managed, AP, mesh point } <= 8,
                   total <= 8, #channels <= 1
        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing

- Extra trick:
In response to the issues tbarath was having:

[...]1. in my case radio0 is wlan1 and radio1 is wlan0, and luci allows me to set 5g channels on the 2.4g radio and does not allow to set the 5g channels on the 5g device[...]

You just need to reverse everything in /etc/config/wireless, so all options related to radio1 become radio0, and vice versa. Restart afterwards. Now my USB stick is showing as radio0, and both bands are selectable.

I'll post any other interesting findings, if I have any.

nutter wrote:

- Extra trick:
In response to the issues tbarath was having:

[...]1. in my case radio0 is wlan1 and radio1 is wlan0, and luci allows me to set 5g channels on the 2.4g radio and does not allow to set the 5g channels on the 5g device[...]

You just need to reverse everything in /etc/config/wireless, so all options related to radio1 become radio0, and vice versa. Restart afterwards. Now my USB stick is showing as radio0, and both bands are selectable.

I'll post any other interesting findings, if I have any.


Would you mind posting your /etc/config/wireless ?

I got it 5GHz working with these settings:

It worked when I enabled and set it in Luci. In luci I had to set channel, auto mode didn't work. (Chaos Calmer 15.05)

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path 'platform/qca955x_wmac'
    option country 'EE'
    option txpower '20'
    option htmode 'HT40'
    option channel '1'

config wifi-iface
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid 'mySSID2.4ghz'
    option encryption 'psk-mixed'
    option key 'password'
    option wds '1'

config wifi-device 'radio1'
    option type 'mac80211'
    option path 'platform/ehci-platform.0/usb1/1-1/1-1:1.0'
    option htmode 'HT20'
    option txpower '20'
    option country 'EE'
    option hwmode '11a'
    option channel '44'

config wifi-iface
    option device 'radio1'
    option network 'lan'
    option mode 'ap'
    option ssid 'mySSID5GHz'
    option encryption 'psk-mixed'
    option key 'password'
    option disabled '0'

More or less the same as mine except I even have dual-SSID and HT40 working on mine.  The signal range even though its a USB adapter with dual external antenna is still much shorter than any of the routers I have with built-in 5Ghz though.

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/ehci-platform/usb1/1-1/1-1:1.0'
        option hwmode '11a'
        option htmode 'HT40'
        option txpower '20'
        option country 'GB'
        option channel '40'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'USS Voyager NCC-74656'
        option encryption 'psk2+ccmp'
        option key '***'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'USS Defiant NX-74205'
        option encryption 'psk2+ccmp'
        option key '***'

Can you please cite the specific device and packages you needed?

I got it working with:
opkg install kmod-rt2x00-usb kmod-rt2x00-lib kmod-rt2800-usb kmod-rt2800-lib
I also installed usbutils and wireless-tools, but I am not sure these are needed.

Device that I bought:
http://www.ebay.co.uk/itm/111185190378

Changed it to HT40, working fine. smile Thanks!

(Last edited by Kaar3l on 3 Feb 2016, 22:29)

The discussion might have continued from here.