OpenWrt Forum Archive

Topic: WiFi for Actiontec GT784WNV

The content of this topic has been archived on 28 Mar 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hey all,

I have an unused GT784WNV that I would like to put into service as a wireless extender.  But before I get that far, I am attempting to take baby steps as, even though I have a decent background in computers in general, I get stupid real fast when it comes to networking.

According to this...

http://wiki.openwrt.org/toh/actiontec/gt784wnv

"The MAC address is initialized to all zeroes, which prevents normal config. It can be set manually, after which wireless works."

I've been reading posts and trying all kinds of config changes for 3 days and I'm ready to wave the white flag.

I have flashed the OpenWrt firmware (many, many times actually) but I cannot seem to get wifi working!!!

I say that based on the fact that the ifconfig command does not show a wireless network and when I "scan" for wireless networks in the luci gui I see nothing.

I am working under the assumption that wifi will work based on the wiki.  But I really, REALLY need help with manually setting the MAC address.  I think this is where I am getting hung up.

I've put "option macaddr" and "option disabled '0'" in the /etc/config/wireless file but nothing is working.  I'll gladly post my network and wireless files but they are basically right out of the fresh install with the changes I mention above.

If anyone is king enough to assist it would be *greatly* appreciated.

Thanks.

(Last edited by bad81637 on 21 Jan 2014, 05:23)

Doing some more digging, here is a snip from the output of the logread command.  Definitely some stuff not right for wifi.  Hopefully someone can tell me if it is possible to get wifi working on this device.  Maybe I'm working toward something that is not possible.

Could someone please confirm that the number I should be trying to set for the MAC address for the wifi is the one listed on the bottom of the router and labeled as the "WAN MAC"?

Thu Jan  1 00:00:27 1970 daemon.info dnsmasq[665]: read /etc/hosts - 1 addresses
Thu Jan  1 00:00:20 1970 daemon.notice netifd: Interface 'loopback' is now up
Thu Jan  1 00:00:20 1970 daemon.warn odhcpd[419]: Failed to send to ff02::1%br-lan (Cannot assign requested address)
Thu Jan  1 00:00:20 1970 daemon.warn odhcpd[419]: Failed to send to ff02::1%br-lan (Cannot assign requested address)
Thu Jan  1 00:00:21 1970 daemon.notice odhcpd[419]: Got a NS for fd95:ec41:d7c9::1
Thu Jan  1 00:00:21 1970 kern.info kernel: [   21.596000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
Thu Jan  1 00:00:21 1970 daemon.notice netifd: radio0 (515): command failed: Operation not supported (-122)
Thu Jan  1 00:00:21 1970 user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
Thu Jan  1 00:00:22 1970 kern.info kernel: [   22.592000] br-lan: port 1(eth0.1) entered forwarding state
Thu Jan  1 00:00:23 1970 daemon.notice netifd: radio0 (515): Configuration file: /var/run/hostapd-phy0.conf
Thu Jan  1 00:00:23 1970 daemon.notice netifd: radio0 (515): Could not set interface wlan0 flags (UP): Cannot assign requested address
Thu Jan  1 00:00:23 1970 daemon.notice netifd: radio0 (515): nl80211: Could not set interface 'wlan0' UP
Thu Jan  1 00:00:23 1970 daemon.notice netifd: radio0 (515): nl80211 driver initialization failed.
Thu Jan  1 00:00:23 1970 daemon.notice netifd: radio0 (515): hostapd_free_hapd_data: Interface wlan0 wasn't started
Thu Jan  1 00:00:23 1970 daemon.notice netifd: radio0 (515): cat: can't open '/var/run/wifi-phy0.pid': No such file or directory
Thu Jan  1 00:00:23 1970 daemon.notice netifd: radio0 (515): Command failed: Invalid argument
Thu Jan  1 00:00:23 1970 daemon.notice netifd: radio0 (515): Device setup failed: HOSTAPD_START_FAILED
Thu Jan  1 00:00:23 1970 daemon.notice odhcpd[419]: Got DHCPv6 request
Thu Jan  1 00:00:24 1970 daemon.notice odhcpd[419]: Got a NS for fd95:ec41:d7c9:0:6029:a77a:1e1d:b9d5

(Last edited by bad81637 on 21 Jan 2014, 05:31)

You can use a random MAC address if none is detected. Put this in your /etc/config wireless and try it again.

option phy phy0
option macaddr 00:11:22:33:44:55 

If your /etc/config/wireless file is empty, then this won't solve anything.

Thanks for the response.  That change didn't appear to have any effect.  Here are my config files.  Any more ideas? 

 
root@OpenWrt:/etc/config# cat wireless

config wifi-device  radio0
        option type     mac80211
        option channel  11
        option hwmode   11g
        option path     'pci0000:00/0000:00:00.0/0000:01:00.0/bcma0:0'  ## I tried both with and without this line.
        option macaddr  '00:11:23:33:44:55'
        option phy      'phy0'
        option disabled '0'

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option encryption none

root@OpenWrt:/etc/config# cat network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd95:ec41:d7c9::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0 1 2 3 8t'

(Last edited by bad81637 on 21 Jan 2014, 13:37)

Here is a thread where it looks like the person was having the same issue as me.  In the final post, he mentions that he solved the problem by downloading some firmware from a website.  Sounds promising, right?  Well, the website is in Spanish and the thread is 27 pages long.  Would anyone happen to know which link on the website points to the f/w that would help me?

Link to forum entry...
https://forum.openwrt.org/viewtopic.php?id=42800

Link to website that contains the fix...
http://foro.seguridadwireless.net/openw … 118fbcab7f

Looks like the kernel needs to be patched for these particular routers, otherwise the wifi won't work. You can use a git created by people at the forum you mention.

git clone git://github.com/openwrt-es/barrier-breaker-openwrt.git -b barrier-breaker_13.12

It contains the fixes for the wifi.

BTW, the patches will be integrated (maybe soon) in next OpenWrt trunk revisions.

(Last edited by danitool on 21 Jan 2014, 21:11)

I updated my firmware from the forum and wifi now works.  I'm not familiar with git so I'll need to check that out.  As I'm still learning about this, it seems like I can't do what I really wanted, which is to have wifi into the OpenWrt router from my main router and then have OpenWrt as a wireless AP.  But it does work with an ethernet cable between routers.

Speed is slower than I expected.  I disabled the firewall on the OpenWrt.  Any suggestions to get better performance?  Or is it normal to be slower.  My speedtest.net speeds are about 50% slower through the OpenWrt vs. my main router.

Thanks for the help so far.

About the wifi performance. Broadcom still didn't bring any FLOSS quality drivers for the comunity, until this happens the wifi performance always will be poor. Atheros wifis are the way to have an excelent wifi performance.

Sadly you cannot replace your onboard wifi at your router.

How would something like a TP-Link TL-WR841N work?  These are pretty inexpensive and I may be able to get a used one for cheap.

Could this be used as both a wireless client and a wireless access point?  That's really were I would like to be.  I understand I may have some degraded performance, as long as it's not unacceptably slow.

Thanks again.

@bad81637, 

I'm about to start playing with openwrt on a GT784WN.  I thought I'd save myself some time and ask if you could list which build you were loading onto the modem and what patches you needed to get wifi working.

Thanks,

Hans

I have just flashed my GT784WNV with OpenWRT and I have problem with WiFi too.
Can't use it because of "Wireless is disabled or not associated"
And also is has only b and g modes, on wiki page (http://wiki.openwrt.org/toh/actiontec/gt784wnv#info) it says that it has 802.11bgN - what happened to n mode?

(Last edited by gike.ol on 12 Feb 2015, 06:21)

gike.ol wrote:

I have just flashed my GT784WNV with OpenWRT and I have problem with WiFi too.
Can't use it because of "Wireless is disabled or not associated"
And also is has only b and g modes, on wiki page (http://wiki.openwrt.org/toh/actiontec/gt784wnv#info) it says that it has 802.11bgN - what happened to n mode?

First of all you should use trunk version for this router (bcm6328).
Second, which drivers are using your wifi, if b43, uninstall them and install kmod-brcmsmac.

In theory brcmsmac is able to manage the broadcom N mode.

thanks for fast reply
I've uninstalled  b43 and installed  kmod-brcmsmac (with dependencies kmod-lib-cordic, kmod-lib-crc8 and kmod-brcmutil)
Wireless is still disabled or not associated and in b/g/n modes now is only auto mode in dropdown menu.

About trunk version, are you talking about this one?
https://downloads.openwrt.org/snapshots … fs-cfe.bin
Is it OK that folder name is bRcm63xx, not bcm63xx?

How should I use it now? Simply "Flash new firmware" from WebUI?

Have the same problem here. Wifi not working.
What is the latest solution?
Should I try to install some other drives or just flash the other image? But isn't the other image from the Spanish website for another model?

I am totally lost.
Any help would be appreciated.

markwithk wrote:

Have the same problem here. Wifi not working.
What is the latest solution?
Should I try to install some other drives or just flash the other image? But isn't the other image from the Spanish website for another model?

I am totally lost.
Any help would be appreciated.

AFAIK in latest trunk versions the OpenWrt firmware comes without wifi drivers. You must install it.

- First configure the router to bring it internet access (edit /etc/config/network). Then install the drivers

opkg update
opkg install kmod-brcmsmac

- you may also want to install luci web interface

opkg install luci
/etc/init.d/uhttpd enable
danitool wrote:
markwithk wrote:

Have the same problem here. Wifi not working.
What is the latest solution?
Should I try to install some other drives or just flash the other image? But isn't the other image from the Spanish website for another model?

I am totally lost.
Any help would be appreciated.

AFAIK in latest trunk versions the OpenWrt firmware comes without wifi drivers. You must install it.

- First configure the router to bring it internet access (edit /etc/config/network). Then install the drivers

opkg update
opkg install kmod-brcmsmac

- you may also want to install luci web interface

opkg install luci
/etc/init.d/uhttpd enable

Thank you very much for the reply.

This device works with DSL so I do not know how to make it connect to the Internet.  I plugged the phone cable in but no connection appeared.
Is the DSL function supposed to work with openwrt? Here in my case, it didn't.

I do get kmod-brcmsmac installed by downloading the packages to my computer and then transferring them to the device. But after this, wifi still won't work.

Now I want to flash it back to the original Verizon firmware, but I could not find the image file anywhere.
I did find the source code, but no image files.

Sigh...

The internal xDSL modem is absolutely not supported by OpenWrt, and never will

The wifi is to be supposed to work in latest trunks

If you don't find the original firmware anywhere, then there is only one way to get it. Get a fresh device with the original firmware, and make a backup of the flash. The firmware can be exgracted from the backup.

The discussion might have continued from here.