OpenWrt Forum Archive

Topic: nc = boot. no nc = no boot

The content of this topic has been archived on 16 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi everyone
I've compiled openwrt for bt home hub 2.0 type B, r34686.
During the procedure to install it I need to use netconsole (nc) to make my rooter load openwrt.
I installed it without problem but when I reboot my router it doesn't work. It has a slow flashing orange led, wich means it is not loading. But if I run netconsole in my computer the the orange led starts to flash faster and finally it turns to blue and the router works.
If i don't use netconsole the led remains flashing slowly.

And I now this revision is compatible with my router model.

Could you please help me?

I don't know why netconsole affects the booting process because I only run it, but I don't press any button.

Thank you

(Last edited by Reflected_God on 3 Feb 2014, 01:47)

This is a uboot settings issue.

Booting problems without LAN. These seem to be solved by using:
fw_setenv preboot "setenv stdin nc; setenv stdout serial; setenv stderr serial"

The default for stdout is nc. When you boot without lan, nc waits forever.

This means you won't see boot logs via nc, but CAN interrupt the boot process by running nc and hitting a key. You can then type 'setenv stdout nc' to get a prompt.

This hardware is now somewhat dated.

(Last edited by dmcdonnell on 1 Feb 2014, 15:29)

You're absolutely right.
I read that command was optional but now I see I must use it.
Thank you.

Problem solved.  smile

The discussion might have continued from here.