OpenWrt Forum Archive

Topic: D-Link DCS-930/932 IP Camera

The content of this topic has been archived between 19 Apr 2018 and 28 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi,

I recently purchased a D-Link DCS-930L and a D-Link DCS-932L IP camera and found out that there is an OpenWrt image for the DCS-930 available. However, I couldn't find any documentation or any post regarding this camera and didn't succeed in uploading the factory image via the web interface.

Does anybody know if there are any differences between the DCS-930 and the DCS-930L?
What steps do I have to take to install OpenWrt on my camera? I disassembled mine in the hope of a serial console, but couldn't find any marked pins, just some solder pads.

Thanks

(Last edited by mauritzius on 25 Feb 2014, 21:37)

As far as I know, the L means that the OEM firmware supports the storage on the Dlink server. ("mydlink", or whatever was that functionality's name...)

hnyman wrote:

As far as I know, the L means that the OEM firmware supports the storage on the Dlink server. ("mydlink", or whatever was that functionality's name...)

Yeah, one of the "features" I want to get rid of smile

But does anybody know if the difference is only in software or also in hardware?

Interesting. I got a DCS-930. Not sure what version exactly.

Where is the OpenWRT flashing instructions?

Just curious what the use case is for putting OpenWRT on this? How much memory/ram does it even have? Thanks

I wondered about the same.

My 932 has one ethernet port, so in theory it might maybe be used as a lan-to-wifi repeater, but I really wonder if any camera functionality would be left. And what would then be the point, as much cheaper repeaters can be found.

King0fK0ng wrote:

Just curious what the use case is for putting OpenWRT on this? How much memory/ram does it even have?

AFAIK, they have 4 MB Flash and 32 MB RAM.
Some other IP cameras I read about have their camera connected via USB, so together with motion or mjpg-streamer the camera functionalities should remain about the same if this is valid, too.

In my case I run LAN cables to the cameras, so I could have them act as an access point. Plus there are some limitations in the D-Link web interface that I would like to overcome this way.

Success!

Although I added serial console, it should work without by following the emergency recovery procedure (you cannot flash from the D-Link firmware):

  • Disconnect power

  • Connect via a LAN cable to your PC

  • Set your PC to 192.168.0.x

  • Press the Reset Button, keep it pressed and plug in power

  • Keep the reset button pressed for 5-10 seconds

  • Release reset

  • Connect with a browser to 192.168.0.20

  • You should be prompted with an upload form, upload firmware there

After installation, I had to manually run the firstboot script, becuase the JFFS2 partition was not correctly generated by the image. Your new OpenWrt is at 192.168.1.1 via LAN.

I installed "motion", so far motion detection works but I have yet to figure out a good configruation. LAN and WiFi work, as does the camera. The camera module itself is really connected via USB. I haven't tested Audio.

I tried these instructions on the DCS-932L, which is bacially the same board, but with added IR diodes and an IR filter. I can read the light sensor and toggle the IR LEDs and IR filter, but I have yet to automate this. For now, it's just setting GPIOs.

I will probably add the relevant information to the Wiki later this week.

Hi from a Noob to OpenWrt, and nice work to Mauritzius on this project!

My question is whether the DCS 930/932 camera with OpenWrt would be able to wirelessly connect (bridge or client mode??) to an existing WAN connected wifi router, and have the DCS camera's Ethernet port connected to another device (an Arduino with Ethernet board) to access the internet through the wifi bridge to the WAN connected router so that both the camera and the Arduino could be accessed from the internet (port forwarded)?

Please keep explanation not too technical… I've not yet used OpenWrt, and have only a little experience with web accessing my arduino so far through no-ip.com redirect to a simple test HTML page.

I am trying to decide whether the DCS 930/932 could do what the TP-Link WRT703 has been able to do to connect MCU to internet for projects, but with the added benefit of a camera to monitor your project in a web browser.

Thank you.

lat50, it should be able to do exactly the same things as the WRT703, as long as you don't run out of space on the flash.
An alternative would be to get a cheap webcam and connect that to the USB port of the WRT703, which is pretty much what the dcs930l does internally. I noticed too late that the included camera is rather low quality, which makes it rather more expensive than combination, but it does have a nicer form factor with the camera included.

Can anyone point me to a binary image (with mjpg_streamer) that I can download?  I can't find it anywhere.  I'm learning how to compile openwrt, but it's a lot of reading to get to the finish line and I'm not a Linux expert.

I have both 930 and 932 cameras.

(Last edited by nguoidien on 15 Aug 2014, 04:05)

There are so many interchanging "930" and "930L" in the discussion, that I am confused. Please, explain to me, is it indeed safe to flash DCS-930 (model without 'L' suffix) with OpenWRT guide for DCS-930L model or not?

My cam is DCS-930, H/W A1, S/W 1.03.

Hi,
Thanks for this discussion.
I was trying to put on this cam last version of OpenWRT (14.07) but while first initial start after upload firmware (until this everything goes smooth and simple) I'm having:

## Booting image at bf050000 ...
   Image Name:   MIPS OpenWrt Linux-3.10.49
   Created:      2014-10-02   7:20:59 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    3331330 Bytes =  3.2 MB
   Load Address: 80000000
   Entry Point:  80000000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... LZMA ERROR 1 - must RESET board to recover

Then cam has bootloop because I can't stop auto boot countdown and I can't input any option (1,2,4...). I'm sure my RS console is fine and no matter if I use putty, screen, minicom or whatever terminal I will have - always can't enter any input.

I was also trying to update to OpenWRT from different manufacturer firmware - no luck.

Does anyone has idea what could be wrong?

Hi,
did you build the image yourself or download it from the OpenWrt site?

I may have never used U-Boot on this device, but on others you usually need to press certain keys to acutally enter the U-Boot command line.

Hi,

Thank for all the information. I was able to flash without difficulties but the camera keeps power cycling. The blue and red LEDs turn on a few seconds, then turn off a moment and turn on again. It cannot be reached over network.

I have tried with the Barrier Breaker 14.07 release and also with the current snapshot. I was told on the IRC channel to try building my own image with a minimal system, but then the LEDs blink a bit then switch off, and i cannot reach the camera on 192.168.1.1 per ping or telnet.

Can you please provide more information about the exact version which has been used on the wiki page? Thanks!

maclord wrote:

Can you please provide more information about the exact version which has been used on the wiki page?

The OpenWrt bootlog on the Wiki page is from Barrier Breaker r39948.

Which camera model are you working with? The wiki page suggests that 933L B1 is not yet supported.

(Last edited by mauritzius on 16 Feb 2015, 08:20)

Hi mauritzius,

According to the sticker at the back of the camera, the model is DCS-930L.

I have tried with an image build from Barrier Breaker r39948, so exactly the version from the wiki. Again, the LEDs blink for a moment then switch off, and i cannot reach the camera on 192.168.1.1 per ping or telnet.

Any hint?

Hi,

I have tried flashing the stock firmware from the D-Link website:
www.dlink.com/uk/en/support/product/dcs-930l-wireless-n-network-camera

By mistake, i first flashed the firmware for the hardware revision A. The camera had the exact same symptoms - the LEDs blink for a moment then switch off - as when i tried to flash OpenWRT. After flashing the stock firmware for the hardware revision B, the camera is working fine.

Could it be that the OpenWRT image is only intended for the hardware revision A? If so, how can i get or produce an image for the hardware revision B?

At the back of the camera, the label says:
H/W Ver.: B1 F/W Ver.: 2.00

Thanks for your help.

14.07 does not work on a 933 A1.  Same as other people. So don't waste your time with 14.07.

## Booting image at bc050000 ...
raspi_read: from:50000 len:40
.   Image Name:   MIPS OpenWrt Linux-3.10.49
   Created:      2014-10-02   7:20:59 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    3331330 Bytes =  3.2 MB
   Load Address: 80000000
   Entry Point:  80000000
raspi_read: from:50040 len:32d502
...................................................   Verifying Checksum ... OK
   Uncompressing Kernel Image ... LZMA ERROR 1 - must RESET board to recover


U-Boot 1.1.3

Board: Ralink APSoC DRAM:  64 MB
relocate_code Pointer at: 83fac000
******************************
Software System Reset Occurred
******************************
spi_wait_nsec: 1e
spi device id: ef 40 17 0 0 (40170000)
find flash: W25Q64BV
raspi_read: from:30000 len:1000
.*** Warning - bad CRC, using default environment

============================================
Ralink UBoot Version: 3.5.2.0
--------------------------------------------
ASIC 3352_MP (Port5<->None)
DRAM_CONF_FROM: Boot-Strapping
DRAM_TYPE: DDR2
DRAM_SIZE: 512 Mbits
DRAM_WIDTH: 16 bits
DRAM_TOTAL_WIDTH: 16 bits
TOTAL_MEMORY_SIZE: 64 MBytes
Flash component: SPI Flash
============================================
icache: sets:256, ways:4, linesz:32 ,total:32768
dcache: sets:128, ways:4, linesz:32 ,total:16384

##### The CPU freq = 400 MHZ ####
estimate memory size =64 Mbytes

Signature: DCS-940            932L  Release 1.01 (2012-07-12)

Ok, if you tftp the image to the device it boots.  It's just writing it to flash that doesn't work.  Interesting.

I am a newbie at openwrt and just bought a 930L(B1). I have read the wiki but couldn't find openwrt-ramips-rt305x-dcs-930-initramfs-uImage.bin in the repo, just openwrt-ramips-rt305x-dcs-930-squashfs-factory and openwrt-ramips-rt305x-dcs-930-squashfs-sysupgrade. can someone help me out?

also if I botched up, how do I return to factory image? I've got the original firmware but would I be able to go to the emergency web interface mentioned in the wiki?

right now I have designed a set of restful api to better control the device. see paste.ee/p/peozH. I'm thinking nginx+server side javascript. plus a customized web interface to go along with. if anyone is interested in this project pls pm me smile

It should be the squashfs one that you should use, that one has the exactly same size as the standard firmware. Trying one of the others probably just wont work. If it fails it's indeed possible to revert back to the original firmware, look at the D-Link support site for it and flash it the same way. I've done that a couple of time on an A09 DCS-930L and also on a A03 DCS-930 as neither would work after i flashed OpenWrt :(

Is anyone having any luck flashing any of the cameras mentioned above? I've tried both a couple of different snapshot versions and also the official Barrier Breaker one and even some of the older RC's, without any luck. No complaints from the emergency interface when flashing, but the red LED on the front never changes colour, feels like the flash process fails somehow. Powercycling the camera does not help, I've tried tcpdump'ing and looking for any signs of it being alive after flashing but without any luck. For the record the older DCS-930 (not the 930L then) fails in the exactly same way. Is there any way one can trigger the TFTP upload without having to open the case and get a serial console?

I tried to install OpenWRT 14.07 on my DCS-933L (rev.A) last night, through the dlink recovery-mode as advised on the wiki and the camera wouldn't boot. I ended up putting the dlink firmware back on it and left it for the night.

I was under the impression that flashing through the recovery-mode was working is there anything im doing wrong, I don't feel too comfortable about opening it up and getting a serial connection but is that the only way?!

OK, so I just checked what I have here:

DCS-930L, H/W A2, FW: 1.08
DCS-932L, H/W A1, FW: 1.08

I'm running on both of them a self-compiled OpenWrt Barrier Breaker r39854 image. I attached serial console, but I think I only ever flashed via the instructions I posted earlier on (Emergency Web Interface).

(Last edited by mauritzius on 13 Apr 2015, 19:48)