OpenWrt Forum Archive

Topic: Update on Linksys WRT1900AC support

The content of this topic has been archived between 16 Sep 2014 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Is there a way to get the Switch page enabled in LuCI?  The option is not available to me at the moment.

Edit: Did some more digging and I guess I need to ask if switching is yet supported on the 1900AC?

Thanks!

(Last edited by hacksaw on 27 Feb 2015, 17:36)

hacksaw wrote:

Is there a way to get the Switch page enabled in LuCI?  The option is not available to me at the moment.

Edit: Did some more digging and I guess I need to ask if switching is yet supported on the 1900AC?

Thanks!

After I enable de vlan option on network config, the switch page apears in LuCI.

my configuration:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '7'
    option vid '7'
    option ports '1 3 5t'

config switch_vlan
    option device 'switch0'
    option vlan '8'
    option vid '8'
    option ports '0 5t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option vid '2'
    option ports '4 6t'

config interface 'eth0_7'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.0.254'
    option netmask '255.255.255.0'
    option _orig_ifname 'eth0.7'
    option _orig_bridge 'true'
    option mtu '1500'
    option metric '0'
    option ifname 'eth0 eth0.7'

config interface 'eth0_8'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option ipaddr '192.168.1.100'
    option _orig_ifname 'eth0.8'
    option _orig_bridge 'true'
    option ifname 'eth0 eth0.8'

config interface 'wan'
    option _orig_ifname 'eth1.1'
    option _orig_bridge 'false'
    option proto 'pppoe'
    option username 'omited'
    option password 'omited'
    option ifname 'eth1.2'

Yeah, the switch is supported but wasn't configured by default until recently. The relevant changes are r44508 and r44509. I would upgrade to the latest snapshot. I ran into some issues when configuring the switch because eth0 and eth1 had the same MAC address. That is the main reason for r44509 and thus why I recommend upgrading before trying to configure it.

So, yes, as Carlos said if it's configured in /etc/config/network it will show up in LuCI. This is the default now:

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6'

@leitec

Funny it worked for you and it hung on me... Did you compile with WiFi enabled? If so, can you please put up online the image and the sysupgrade tarball? Thanks. I'm putting up a virtual machine right now to try one last time to compile it. I only want to test the NAT speeds and use it for a while on my second unit, called "Testy" smile

nitroshift

(Last edited by nitroshift on 27 Feb 2015, 18:35)

nitroshift wrote:

@leitec

Funny it worked for you and it hung on me... Did you compile with WiFi enabled? If so, can you please put up online the image and the sysupgrade tarball? Thanks. I'm putting up a virtual machine right now to try one last time to compile it. I only want to test the NAT speeds and use it for a while on my second unit, called "Testy" smile

nitroshift

Try

http://staticky.com/wrt1900ac-4.0-early … pgrade.tar

It's the default configuration so it should have WiFi, if the existing code is working with this newer kernel.

(Last edited by leitec on 27 Feb 2015, 18:41)

@leitec

Thanks. Flashed it OK, router rebooted, speed seems to have grown quite a bit. As you suggested, the mvneta switch driver is not to blame as much as the underlying engine in trunk and kernel at the moment. Wifi works better too speedwise. I'm gonna keep an eye on Testy for a couple of days then update my main router if everything's OK. If anything bad happens in the meantime, I will let you know.

nitroshift

(Last edited by nitroshift on 27 Feb 2015, 18:56)

Any harm in the average person(like me), trying this sysupgrade? I presume perhaps more risky then usual?

Yes, but I suppose it's really not that much riskier than the daily snapshots. I can at least say nitroshift and I have loaded it without problems (as in, it boots and you can sysupgrade to another build if necessary). I haven't really tested it beyond running some routing benchmarks. I did not test WiFi at all, but nitroshift says it's working.

All that said, no guarantees of anything! There are a lot of OpenWrt-specific patches that haven't been thoroughly tested with this new kernel.

(Last edited by leitec on 27 Feb 2015, 20:20)

I might be starting to have too much faith in you guys.......... smile

sooooooooooooo tempted to pull the trigger...............................

I have also discovered a lot of errors in dmesg:

[  373.104850] mvneta f1074000.ethernet eth1: bad rx status 0f810000 (crc error), size=1512
[  385.232830] mvneta f1074000.ethernet eth1: bad rx status 0f810000 (crc error), size=947
[  410.449674] mvneta f1074000.ethernet eth1: bad rx status 0f810000 (crc error), size=1197
[  500.741130] mvneta f1074000.ethernet eth1: bad rx status 0f810000 (crc error), size=1146
[  517.378288] mvneta f1074000.ethernet eth1: bad rx status 0f810000 (crc error), size=1186
[  519.598396] mvneta f1074000.ethernet eth1: bad rx status 0f810000 (crc error), size=1231
          RX packets:23099 errors:62 dropped:0 overruns:0 frame:0
          TX packets:17803 errors:0 dropped:0 overruns:0 carrier:0

(Last edited by belliash on 27 Feb 2015, 21:56)

mojolacerator wrote:

I might be starting to have too much faith in you guys.......... smile

sooooooooooooo tempted to pull the trigger...............................

I've lost track here.
What's wrong with the latest trunk image?

r44532 / Feb25
48+ hours without a burp.

Nothing at all for me, but the thought that this router could be faster with
leitec's sysupgrade is almost too tempting to resist.

So if I copy and paste that into /etc/config/network and reload I will be able to connect to the router as if nothing was changed?  I started testing what Carlos provided and killed all traffic :-)

On the bright side, I had to reset to factory defaults and my Internet light started working again (pun intended).

I am sure I will have more questions once I try to configure the static IP address mappings to the VLAN.

leitec wrote:

Yeah, the switch is supported but wasn't configured by default until recently. The relevant changes are r44508 and r44509. I would upgrade to the latest snapshot. I ran into some issues when configuring the switch because eth0 and eth1 had the same MAC address. That is the main reason for r44509 and thus why I recommend upgrading before trying to configure it.

So, yes, as Carlos said if it's configured in /etc/config/network it will show up in LuCI. This is the default now:

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6'

I looked back and saw your comment about running r44455 -- Kaloz's Feb 14 build? If so, you'll want to upgrade to the latest snapshot. If you take the config as I pasted and enable it now, you'll likely encounter the same problem I did: massive packet loss.

leitec wrote:

I looked back and saw your comment about running r44455 -- Kaloz's Feb 14 build? If so, you'll want to upgrade to the latest snapshot. If you take the config as I pasted and enable it now, you'll likely encounter the same problem I did: massive packet loss.

Yes I am running  r44455 -- Kaloz's Feb 14 build.  Is this the link I an looking for?  If not can you point me to the correct image?

https://downloads.openwrt.org/snapshots … actory.img

Thanks!

leitec wrote:

Yeah, the switch is supported but wasn't configured by default until recently. The relevant changes are r44508 and r44509. I would upgrade to the latest snapshot. I ran into some issues when configuring the switch because eth0 and eth1 had the same MAC address. That is the main reason for r44509 and thus why I recommend upgrading before trying to configure it.

So, yes, as Carlos said if it's configured in /etc/config/network it will show up in LuCI. This is the default now:

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6'

r44509 is supposed to make the wan eth1 mac different with lan eth0, but in my latest trunk build, the MAC address of eth1 and eth0 are still same.
@leitec, am I right?

(Last edited by tangsoft on 28 Feb 2015, 06:58)

hacksaw wrote:
leitec wrote:

I looked back and saw your comment about running r44455 -- Kaloz's Feb 14 build? If so, you'll want to upgrade to the latest snapshot. If you take the config as I pasted and enable it now, you'll likely encounter the same problem I did: massive packet loss.

Yes I am running  r44455 -- Kaloz's Feb 14 build.  Is this the link I an looking for?  If not can you point me to the correct image?

https://downloads.openwrt.org/snapshots … actory.img

Thanks!

Use the sysupgrade tar file:

https://downloads.openwrt.org/snapshots … pgrade.tar

@hacksaw sorry about that. my config was for my requirements. you need to adjust to your needs. If you have only one network you don't need to configure vlans.
In my case the connection to ISP is in PPPoE (ADSL), and that it depends on the ISP you are using.

tangsoft wrote:

r44509 is supposed to make the wan eth1 mac different with lan eth0, but in my latest trunk build, the MAC address of eth1 and eth0 are still same.
@leitec, am I right?

The difference is easy to miss: the first octet is different, but the rest is the same. Could you double check?

leitec wrote:
tangsoft wrote:

r44509 is supposed to make the wan eth1 mac different with lan eth0, but in my latest trunk build, the MAC address of eth1 and eth0 are still same.
@leitec, am I right?

The difference is easy to miss: the first octet is different, but the rest is the same. Could you double check?

yes, you are right, thanks.
I am trying to host my pppoe internet access, IPTV unicast and multicast through different VLAN tagging in a single fiber, and thought the same MACs bring some problem. thank you very much for clarifying this.

Mine is:
eth0      Link encap:Ethernet  HWaddr B4:75:0E:F9:52:11 
eth1      Link encap:Ethernet  HWaddr B6:75:0E:F9:52:11

leitec wrote:

Yes, but I suppose it's really not that much riskier than the daily snapshots. I can at least say nitroshift and I have loaded it without problems (as in, it boots and you can sysupgrade to another build if necessary). I haven't really tested it beyond running some routing benchmarks. I did not test WiFi at all, but nitroshift says it's working.

All that said, no guarantees of anything! There are a lot of OpenWrt-specific patches that haven't been thoroughly tested with this new kernel.

quick question............

?
after opkg install luci

e.g. opkg info 'libstd*' or opkg search '*libop*' or opkg remove 'libncur*'
-ash: luci: not found

@mojolacerator

JFYI, I have flashed a test router with leitec's firmware, as it is intended ONLY for testing! I sysupgraded from a custom firmware based on kernel 3.19 with "Keep settings" enabled. YMMV...

nitroshift

(Last edited by nitroshift on 28 Feb 2015, 19:26)

mojolacerator wrote:
leitec wrote:

Yes, but I suppose it's really not that much riskier than the daily snapshots. I can at least say nitroshift and I have loaded it without problems (as in, it boots and you can sysupgrade to another build if necessary). I haven't really tested it beyond running some routing benchmarks. I did not test WiFi at all, but nitroshift says it's working.

All that said, no guarantees of anything! There are a lot of OpenWrt-specific patches that haven't been thoroughly tested with this new kernel.

quick question............

?
after opkg install luci

e.g. opkg info 'libstd*' or opkg search '*libop*' or opkg remove 'libncur*'
-ash: luci: not found

Sorry, no idea hmm I couldn't duplicate it. It loads and installs just fine here, as do any operations after that.

@leitec

So far Testy has been behaving itself, no reboots, no hangs. I'm going to keep testing it until tomorrow evening and if everything stays OK I will flash my main router with it. Once again, thanks for your help.

nitroshift

leitec wrote:
mojolacerator wrote:
leitec wrote:

Yes, but I suppose it's really not that much riskier than the daily snapshots. I can at least say nitroshift and I have loaded it without problems (as in, it boots and you can sysupgrade to another build if necessary). I haven't really tested it beyond running some routing benchmarks. I did not test WiFi at all, but nitroshift says it's working.

All that said, no guarantees of anything! There are a lot of OpenWrt-specific patches that haven't been thoroughly tested with this new kernel.


quick question............

?
after opkg install luci

e.g. opkg info 'libstd*' or opkg search '*libop*' or opkg remove 'libncur*'
-ash: luci: not found

Sorry, no idea hmm I couldn't duplicate it. It loads and installs just fine here, as do any operations after that.

Ok, does anyone have a step by step of how to flash firmware from Openwrt failsafe mode?