OpenWrt Forum Archive

Topic: Update on Linksys WRT1900AC support

The content of this topic has been archived between 16 Sep 2014 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

alirz wrote:

dhcp-option=252,"\n"

Web Proxy Auto-Discovery Protocol

Learned something new today smile

CC 15.05

Using username "root".
Authenticating with public key "rsa-key-20120810"


BusyBox v1.23.2 (2015-07-24 23:41:29 CEST) built-in shell (ash)

Linksys WRT1900AC (Mamba)
Security is enabled, and your IP address has been logged.

root@AC1900M:~# strings /usr/lib/libssl.so.1.0.0 | grep OpenSSL
OpenSSLDie
SSLv3 part of OpenSSL 1.0.2d 9 Jul 2015
TLSv1 part of OpenSSL 1.0.2d 9 Jul 2015
DTLSv1 part of OpenSSL 1.0.2d 9 Jul 2015
OpenSSL 1.0.2d 9 Jul 2015
root@AC1900M:~#

gufus wrote:

CC 15.05

Using username "root".
Authenticating with public key "rsa-key-20120810"


BusyBox v1.23.2 (2015-07-24 23:41:29 CEST) built-in shell (ash)

Linksys WRT1900AC (Mamba)
Security is enabled, and your IP address has been logged.

root@AC1900M:~# strings /usr/lib/libssl.so.1.0.0 | grep OpenSSL
OpenSSLDie
SSLv3 part of OpenSSL 1.0.2d 9 Jul 2015
TLSv1 part of OpenSSL 1.0.2d 9 Jul 2015
DTLSv1 part of OpenSSL 1.0.2d 9 Jul 2015
OpenSSL 1.0.2d 9 Jul 2015
root@AC1900M:~#

@gufus

May I ask how you get the "Security is enabled, and your IP address has been logged"?

Also doesnt luci use polar ssl? I know openssl is better but how do you use it on openwrt? like the exchange key?

Thank you

Happy to see the final release is out. I have been following this forum for about a year waiting for CC.

I just installed it on my V1 router yesterday and have been happy with it so far. I have a Netflow server setup and softflowd sending traffic info to it from the router. Works well.

The only thing I have noticed that I wanted to get input on was my wifi speeds (2.4GHz). When doing an internet speed test it shows at 40Mbps however when on stock it was at 50Mbps. I have a 50Mbps connection. When I plug into the OpenWRT router with a cable I get the 50Mbps. Is there some form of QoS for the wifi that I am unaware of? I remember having a similar problem on stock but that was because I set my QoS download limit too low.

Any thoughts are welcome.

Thanks!

(Last edited by DeaDraug on 15 Sep 2015, 00:41)

DeaDraug wrote:

Happy to see the final release is out. I have been following this forum for about a year waiting for CC.

I just installed it on my V1 router yesterday and have been happy with it so far. I have a Netflow server setup and softflowd sending traffic info to it from the router. Works well.

The only thing I have noticed that I wanted to get input on was my wifi speeds (2.4GHz). When doing an internet speed test it shows at 40Mbps however when on stock it was at 50Mbps. I have a 50Mbps connection. When I plug into the OpenWRT router with a cable I get the 50Mbps. Is there some form of QoS for the wifi that I am unaware of? I remember having a similar problem on stock but that was because I set my QoS download limit too low.

Any thoughts are welcome.

Thanks!

Many variables with wifi....  What day of the week is it? Is it raining? Standing on 1 foot helps... silly stuff like that smile  I wouldn't worry about it.

lifehacksback wrote:
gufus wrote:

CC 15.05

Using username "root".
Authenticating with public key "rsa-key-20120810"


BusyBox v1.23.2 (2015-07-24 23:41:29 CEST) built-in shell (ash)

Linksys WRT1900AC (Mamba)
Security is enabled, and your IP address has been logged.

root@AC1900M:~# strings /usr/lib/libssl.so.1.0.0 | grep OpenSSL
OpenSSLDie
SSLv3 part of OpenSSL 1.0.2d 9 Jul 2015
TLSv1 part of OpenSSL 1.0.2d 9 Jul 2015
DTLSv1 part of OpenSSL 1.0.2d 9 Jul 2015
OpenSSL 1.0.2d 9 Jul 2015
root@AC1900M:~#

@gufus

May I ask how you get the "Security is enabled, and your IP address has been logged"?

iptables

If I had port 23 open, It' logged.

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
iptables -N rate_limit
iptables -A rate_limit -p tcp --dport 22 -m limit --limit 3/min --limit-burst 3 -j DROP
iptables -A rate_limit -p tcp --dport 23 -m limit --limit 3/min --limit-burst 3 -j DROP
iptables -A rate_limit -p tcp -j REJECT --reject-with tcp-reset
iptables -A rate_limit -j DROP
#
iptables -I rate_limit -j LOG --log-prefix " Connection dropped "
iptables -I delegate_input -p tcp --dport 22 -m state --state NEW -j rate_limit
iptables -I delegate_input -p tcp --dport 23 -m state --state NEW -j rate_limit
lifehacksback wrote:

Also doesnt luci use polar ssl? I know openssl is better but how do you use it on openwrt? like the exchange key?

I use OpenSSL with OpenVPN, I'm not sure if https uses OpenSSL now.

davidc502 wrote:
DeaDraug wrote:

Happy to see the final release is out. I have been following this forum for about a year waiting for CC.

I just installed it on my V1 router yesterday and have been happy with it so far. I have a Netflow server setup and softflowd sending traffic info to it from the router. Works well.

The only thing I have noticed that I wanted to get input on was my wifi speeds (2.4GHz). When doing an internet speed test it shows at 40Mbps however when on stock it was at 50Mbps. I have a 50Mbps connection. When I plug into the OpenWRT router with a cable I get the 50Mbps. Is there some form of QoS for the wifi that I am unaware of? I remember having a similar problem on stock but that was because I set my QoS download limit too low.

Any thoughts are welcome.

Thanks!

Many variables with wifi....  What day of the week is it? Is it raining? Standing on 1 foot helps... silly stuff like that smile  I wouldn't worry about it.

My 5GHz client is getting 50Mbps so I guess I won't stress over this too much. Wifi is most definitely a finicky thing to work with.

(Last edited by DeaDraug on 15 Sep 2015, 02:21)

I've installed 15.05 final and so far so good, everything is back up, and so far working well.  Been running for 23 hours so far.
Somethings I have observed, just wondering if these are known, or am I missing something.

1 - Although the gui says 2.4Gig is at 40MHz width, (and the etc/config/wireless file says the same), when using wifiexplorer it says the wifi is only 20Mhz.  I see other people in my area using 40Mhz so I believe the app is reporting it properly, so not sure what I have wrong?  I know 5G cant do 160Mhz width, is this a similar problem?

2 - I have updated the power for 2.4G to 30dBm, but when I try to set 5G to more than 17dBm it stays at 17.  Even changing the etc/config/wireless file directly to 30 cant do it?  I can only drop it from 17 not increase it?  Is this another static limitation?

3 - someone had mentioned that collectd was not working for 15.05, is that still the case?

IvanRaide wrote:

I've installed 15.05 final and so far so good, everything is back up, and so far working well.  Been running for 23 hours so far.
Somethings I have observed, just wondering if these are known, or am I missing something.

1 - Although the gui says 2.4Gig is at 40MHz width, (and the etc/config/wireless file says the same), when using wifiexplorer it says the wifi is only 20Mhz.  I see other people in my area using 40Mhz so I believe the app is reporting it properly, so not sure what I have wrong?  I know 5G cant do 160Mhz width, is this a similar problem?

2 - I have updated the power for 2.4G to 30dBm, but when I try to set 5G to more than 17dBm it stays at 17.  Even changing the etc/config/wireless file directly to 30 cant do it?  I can only drop it from 17 not increase it?  Is this another static limitation?

3 - someone had mentioned that collectd was not working for 15.05, is that still the case?

If in the US you have to be on channel 149 +
iw phy1 info
shows this

IvanRaide wrote:

I've installed 15.05 final and so far so good, everything is back up, and so far working well.  Been running for 23 hours so far.
Somethings I have observed, just wondering if these are known, or am I missing something.

1 - Although the gui says 2.4Gig is at 40MHz width, (and the etc/config/wireless file says the same), when using wifiexplorer it says the wifi is only 20Mhz.  I see other people in my area using 40Mhz so I believe the app is reporting it properly, so not sure what I have wrong?  I know 5G cant do 160Mhz width, is this a similar problem?

2 - I have updated the power for 2.4G to 30dBm, but when I try to set 5G to more than 17dBm it stays at 17.  Even changing the etc/config/wireless file directly to 30 cant do it?  I can only drop it from 17 not increase it?  Is this another static limitation?

3 - someone had mentioned that collectd was not working for 15.05, is that still the case?

For question #2. This is set according to FCC rules on 5Ghz -- Channel 149 and higher you can select 30dBm, but not lower.

Thanks for the replies, you're right, moving it to channel 149 allowed 30dBm.  Thinking it might be something similar for question #1 (2.4Ghz Wifi) I tried moving the channel around but it still reports only 20Mhz?  These are the current settings, is something blocking it?

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path 'soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
    option country 'CA'
    option htmode 'HT40'
    option txpower '30'
    option channel '11'

config wifi-iface
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid 'OffLoadB'
    option encryption 'psk2+ccmp'
IvanRaide wrote:

I've installed 15.05 final and so far so good, everything is back up, and so far working well.  Been running for 23 hours so far.
Somethings I have observed, just wondering if these are known, or am I missing something.

1 - Although the gui says 2.4Gig is at 40MHz width, (and the etc/config/wireless file says the same), when using wifiexplorer it says the wifi is only 20Mhz.  I see other people in my area using 40Mhz so I believe the app is reporting it properly, so not sure what I have wrong?  I know 5G cant do 160Mhz width, is this a similar problem?

To check if driver reported correct rate information. If no, please report this bug in LuCI.

I opened a issue a long time ago (got no reply)


root@AC1900M:~# iw wlan0 station dump
Station be:a3:86:4b:61:ee (on wlan0)
        inactive time:  304650 ms
        rx bytes:       284
        rx packets:     2
        tx bytes:       508
        tx packets:     5
        tx retries:     0
        tx failed:      0
        signal:         -42 dBm
        signal avg:     -45 dBm
        tx bitrate:     130.0 MBit/s MCS 15
        rx bitrate:     36.0 MBit/s
        authorized:     yes
        authenticated:  yes
        preamble:       short
        WMM/WME:        yes
        MFP:            no
        TDLS peer:      no
Station 20:aa:4b:3e:5e:39 (on wlan0)
        inactive time:  23140 ms
        rx bytes:       17366
        rx packets:     2968
        tx bytes:       1173
        tx packets:     11
        tx retries:     0
        tx failed:      0
        signal:         -47 dBm
        signal avg:     -47 dBm
        tx bitrate:     54.0 MBit/s
        rx bitrate:     54.0 MBit/s
        authorized:     yes
        authenticated:  yes
        preamble:       long
        WMM/WME:        yes
        MFP:            no
        TDLS peer:      no
Station e0:ca:94:c7:c1:43 (on wlan0)
        inactive time:  2890 ms
        rx bytes:       189767
        rx packets:     1173
        tx bytes:       854068
        tx packets:     1212
        tx retries:     0
        tx failed:      0
        signal:         -63 dBm
        signal avg:     -60 dBm
        tx bitrate:     65.0 MBit/s MCS 7
        rx bitrate:     39.0 MBit/s MCS 4
        authorized:     yes
        authenticated:  yes
        preamble:       long
        WMM/WME:        yes
        MFP:            no
        TDLS peer:      no
root@AC1900M:~#

root@AC1900M:~# iw wlan1 station dump
Station 74:d0:2b:d0:1c:94 (on wlan1)
inactive time: 10 ms
rx bytes: 652149
rx packets: 2534
tx bytes: 2548312
tx packets: 2743
tx retries: 0
tx failed: 0
signal: -70 dBm
signal avg: -70 dBm
tx bitrate: 702.0 MBit/s VHT-MCS 8 80MHz VHT-NSS 2
rx bitrate: 585.0 MBit/s VHT-MCS 7 80MHz VHT-NSS 2
authorized: yes
authenticated: yes
preamble: long
WMM/WME: yes
MFP: no
TDLS peer: no
root@AC1900M:~#

(Last edited by gufus on 15 Sep 2015, 07:24)

Any clues for getting Apple mobile clients to connect to the wifi? I have chaos calmer final installed, and my other wireless clients connect just fine. Tried power cycling the router, rebooted Apple clients. No luck, just kept asking for the wifi password, and never were able to join the network.

Any suggestions, other than to wait for iOS 9? Everything else is working well, but the Apple client problem makes it unusable for me.

Thanks!

(Last edited by RogerSC on 15 Sep 2015, 07:48)

RogerSC wrote:

Any clues for getting Apple mobile clients to connect to the wifi? I have chaos calmer final installed, and my other wireless clients connect just fine. Tried power cycling the router, rebooted Apple clients. No luck, just kept asking for the wifi password, and never were able to join the network.

Any suggestions, other than to wait for iOS 9? Everything else is working well, but the Apple client problem makes it unusable for me.

Thanks!

Try

Disable Wireless Security, see if you can get a handshake first.

Hi! I'm having trouble tranfesring files over wifi (5GHz) to USB HDD.
The setup works but speeds are slow and the firmware crashes after approx 10-15m.
I had the same problem when running trunk version (from late april), figured it might have been fixed by now. I'm running lastest final version of openwrt.
I've installed the following packages:
kmod-fs-ext4
kmod-usb-storage
block-mount
samba36-server.
I'm experiencing whether i juse my windows pc or my macbook. I get somwhat around 3-5MB/s while the CPU load is constantly above 1!
Is there someone who has the same experience, am i missing something? Is there a better filesystem to use?
Thanks!

IvanRaide wrote:

Thanks for the replies, you're right, moving it to channel 149 allowed 30dBm.  Thinking it might be something similar for question #1 (2.4Ghz Wifi) I tried moving the channel around but it still reports only 20Mhz?  These are the current settings, is something blocking it?

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path 'soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
    option country 'CA'
    option htmode 'HT40'
    option txpower '30'
    option channel '11'

config wifi-iface
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid 'OffLoadB'
    option encryption 'psk2+ccmp'

You might want to look in system log I get this here when I start my 2.4 ghz I have not found a working combo.

Tue Sep 15 06:57:13 2015 daemon.notice netifd: radio0 (18208): 20/40 MHz operation not permitted on channel pri=11 sec=7 based on overlapping BSSes

Pythe1337N wrote:

Hi! I'm having trouble tranfesring files over wifi (5GHz) to USB HDD.
The setup works but speeds are slow and the firmware crashes after approx 10-15m.
I had the same problem when running trunk version (from late april), figured it might have been fixed by now. I'm running lastest final version of openwrt.
I've installed the following packages:
kmod-fs-ext4
kmod-usb-storage
block-mount
samba36-server.
I'm experiencing whether i juse my windows pc or my macbook. I get somwhat around 3-5MB/s while the CPU load is constantly above 1!
Is there someone who has the same experience, am i missing something? Is there a better filesystem to use?
Thanks!

I wish I had an answer the factory firmware seems to have no problem but openwrt eats all memory then the radio drops out I have tried ftp, samba etc. I guess this is not on the list of things to fix. I changed the disk format from ntfs to ext4 still no difference. It transfers fast until memory is used up then it bombs. If you find the solution please post it here.

RogerSC wrote:

Any clues for getting Apple mobile clients to connect to the wifi? I have chaos calmer final installed, and my other wireless clients connect just fine. Tried power cycling the router, rebooted Apple clients. No luck, just kept asking for the wifi password, and never were able to join the network.

Any suggestions, other than to wait for iOS 9? Everything else is working well, but the Apple client problem makes it unusable for me.

Thanks!

I have this problem whenever a device tries to first connect to the wifi.  I think this is related to the problem where the 5G doesn't connect/drops when there is only 1 client.  The only way I get around it, is I have 2/more devices both look for 5G at the same time that I am trying to connect, and then it connects ... is it SUPER annoying!

northbound wrote:

You might want to look in system log I get this here when I start my 2.4 ghz I have not found a working combo.
Tue Sep 15 06:57:13 2015 daemon.notice netifd: radio0 (18208): 20/40 MHz operation not permitted on channel pri=11 sec=7 based on overlapping BSSes

Thanks for the reply.  You are right, I had that in the syslog.  Googling it lead me here,
https://forum.openwrt.org/viewtopic.php?id=36530

which lead to this option:
option noscan '1'

I'm not home but remoted in, added the line, and restarted wifi and I don't see the 20/40Mhz warning in syslog now,  so maybe its working, I'll know for sure when I get home.

(Last edited by IvanRaide on 15 Sep 2015, 15:34)

IvanRaide wrote:
northbound wrote:

You might want to look in system log I get this here when I start my 2.4 ghz I have not found a working combo.
Tue Sep 15 06:57:13 2015 daemon.notice netifd: radio0 (18208): 20/40 MHz operation not permitted on channel pri=11 sec=7 based on overlapping BSSes

Thanks for the reply.  You are right, I had that in the syslog.  Googling it lead me here,
https://forum.openwrt.org/viewtopic.php?id=36530

which lead to this option:
option noscan '1'

I'm not home but remoted in, added the line, and restarted wifi and I don't see the 20/40Mhz warning in syslog now,  so maybe its working, I'll know for sure when I get home.

Just a heads up that violates FCC rules <VBG> Also it seemed to slow me down on overall transfer speed because of the interference.

northbound wrote:

Also it seemed to slow me down on overall transfer speed because of the interference.

... interesting .... I wont mind a hit in speed if it was more stable/better range.  Well do some testing...

IvanRaide wrote:
northbound wrote:

Also it seemed to slow me down on overall transfer speed because of the interference.

... interesting .... I wont mind a hit in speed if it was more stable/better range.  Well do some testing...

option noscan '1'

It works here. I'm getting 150/Mbps on 2.4ghz now, and it shows 40MHz in luci.


config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path 'soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
    option channel '6'
    option country 'CA'
    option noscan '1'
    option htmode 'HT40'
    option txpower '30'



Station e0:ca:94:c7:c1:43 (on wlan0)
        inactive time:  0 ms
        rx bytes:       151388
        rx packets:     818
        tx bytes:       225198
        tx packets:     484
        tx retries:     0
        tx failed:      0
        signal:         -66 dBm
        signal avg:     -60 dBm
        tx bitrate:     135.0 MBit/s MCS 7 40MHz
        rx bitrate:     81.0 MBit/s MCS 4 40MHz
        authorized:     yes
        authenticated:  yes
        preamble:       long
        WMM/WME:        yes
        MFP:            no
        TDLS peer:      no
root@AC1900M:~#


---------------

Before I had 20MHz at 72/Mbps on 2.4ghz


config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path 'soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
    option channel '6'
    option country 'CA'
    option noscan '1'
    option htmode 'HT20'
    option txpower '17'


Station e0:ca:94:c7:c1:43 (on wlan0)
        inactive time:  60 ms
        rx bytes:       11217770
        rx packets:     140283
        tx bytes:       414673309
        tx packets:     271635
        tx retries:     0
        tx failed:      0
        signal:         -61 dBm
        signal avg:     -60 dBm
        tx bitrate:     65.0 MBit/s MCS 7
        rx bitrate:     52.0 MBit/s MCS 5
        authorized:     yes
        authenticated:  yes
        preamble:       long
        WMM/WME:        yes
        MFP:            no
        TDLS peer:      no

(Last edited by gufus on 15 Sep 2015, 22:12)

Gents, what is different between CC final and Kaloz image from Aug. 19?

Thank you!
JM

northbound wrote:
Pythe1337N wrote:

Hi! I'm having trouble tranfesring files over wifi (5GHz) to USB HDD.
The setup works but speeds are slow and the firmware crashes after approx 10-15m.
I had the same problem when running trunk version (from late april), figured it might have been fixed by now. I'm running lastest final version of openwrt.
I've installed the following packages:
kmod-fs-ext4
kmod-usb-storage
block-mount
samba36-server.
I'm experiencing whether i juse my windows pc or my macbook. I get somwhat around 3-5MB/s while the CPU load is constantly above 1!
Is there someone who has the same experience, am i missing something? Is there a better filesystem to use?
Thanks!

I wish I had an answer the factory firmware seems to have no problem but openwrt eats all memory then the radio drops out I have tried ftp, samba etc. I guess this is not on the list of things to fix. I changed the disk format from ntfs to ext4 still no difference. It transfers fast until memory is used up then it bombs. If you find the solution please post it here.

How did you manage to make block-mount work?

I've installed it through Luci

Installing block-mount (2015-05-24-09027fc86babc3986027a0e677aca1b6999a9e14) to root...
Downloading http://downloads.openwrt.org/chaos_calm … mvebu.ipk.
this file has been obseleted. please call "/sbin/block mount" directly
Configuring block-mount.

and when I go to Mount Points I get

/usr/lib/lua/luci/dispatcher.lua:433: Failed to execute cbi dispatcher target for entry '/admin/system/fstab'.
The called action terminated with an exception:
/usr/lib/lua/luci/cbi.lua:311: Unable to read UCI data: fstab
stack traceback:
    [C]: in function 'assert'
    /usr/lib/lua/luci/dispatcher.lua:433: in function 'dispatch'
    /usr/lib/lua/luci/dispatcher.lua:168: in function </usr/lib/lua/luci/dispatcher.lua:167>

Any help is appreciated! smile

gufus wrote:
IvanRaide wrote:
northbound wrote:

Also it seemed to slow me down on overall transfer speed because of the interference.

... interesting .... I wont mind a hit in speed if it was more stable/better range.  Well do some testing...

option noscan '1'
It works here. I'm getting 150/Mbps on 2.4ghz now, and it shows 40MHz in luci.

Confirmed its working here as well; screw you neighborhood <VBG>
Haven't tried speed yet, but at least we know it works!