OpenWrt Forum Archive

Topic: Update on Linksys WRT1900AC support

The content of this topic has been archived between 16 Sep 2014 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

dansneddon wrote:

Does anyone know how to replace the fan in a WRT1900AC v1?

I've been constructing my own fan control script, and I notice that my fan is really noisy at anything less than a PWM value of 200. In fact, if I give it a value below 200 when the fan is stopped, it won't even start. If I spin the fan down from 200 to 150, there is a loud grinding sound. My fan isn't much quieter as 200 than it is at 255, just a lower pitch, but I see that people are having success with values like 150 and report that it is quiet (I assume the fan is actually spinning up at that value).

To address this, I bought two 40mm x 10mm fans: a Sunon quiet ballbearing fan that uses the same 0.8W power as the stock fan (might even be the same model), and a Sunon high-rpm fan that operates at 0.96W. When I opened up my router, though, it appears that the fan has been attached with screws from the underside of the heat sink. I tried removing all the screws on the heat sink, but I couldn't remove it, it wouldn't budge. Has anyone removed their heatsink? Is it just stuck because of thermal grease/glue? Do I need to remove the smaller, shiny heatsink first before removing the larger one?

Does anyone know how I can remove the existing fan? There doesn't seem to be a good place to mount a fan other than where the old one is, but trying to pry it off didn't work. Should I just attack the old fan with a Dremel tool?


The bolts of the fan are on the other side. To remove them you have to remove the heat sinks. They are glued to the components below with heat conducting tape. You have to be very careful and start with the heat sink on the wifi card. I used a flat screwdriver and gently removed it. Then you have to remove the second heat sink the same way starting from the other side (the side that is opposite to the WiFi card). I replaced the fan with 50x50x10mm. I  made some cuts in the sink to remove some of the ribs. I used a bigger fan, because it is a lot quieter and has a lot more CFM.

Good luck.

(Last edited by i.trankolov on 13 Oct 2015, 09:42)

@gufus

Is dd-wrt ready for daily usage on 1900ac v1 or are there any downsides?!

Id0n0tunderstand wrote:

http://s13.postimg.org/9abwzx1yf/Capture_d_e_cran_2015_10_11_a_15_14_46.png

This is how my wifi interface should show up but I do not have it any more since I started editing my wifi configuration file in vim. I know this sounds crazy but it is really gone. There is no wifi under network tab anymore.

Did you check the permissions (should be 644 [rw-r--r--])

  • ls -l /etc/config/wireless

or try restarting network

  • /etc/init.d/network restart  OR

  • /etc/init.d/network stop ; /etc/init.d/network start

Normally, you can copy over files from the /rom directory, however since wifi is disabled by default, no config exists there.  Output of my wireless config with personal info removed

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
        option channel '6'
        option country 'US'
        option txpower '17'
        option htmode 'HT40'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid ''
        option hidden '1'
        option encryption 'psk2+ccmp'
        option key ''
        option macfilter 'allow'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/soc:pcie-controller/pci0000:00/0000:00:03.0/0000:03:00.0'
        option country 'US'
        option distance '50'
        option channel '157'
        option htmode 'VHT80'
        option txpower '27'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid ''
        option hidden '1'
        option encryption 'psk2+ccmp'
        option key ''
        option macfilter 'allow'
  • You'll need to disable mac filtering, otherwise you won't be able to connect

(Last edited by JW0914 on 13 Oct 2015, 18:24)

root@OpenWrt:~# ls -l /etc/config/wireless
-rw-r--r--    1 root     root           803 Oct 12 23:56 /etc/config/wireless

I did restart the network but still there is no wireless in the network tab. However, I guess the problem is going to get solved when I am going to flash it with the final image as I am at the moment still of rc3.

Id0n0tunderstand wrote:

root@OpenWrt:~# ls -l /etc/config/wireless
-rw-r--r--    1 root     root           803 Oct 12 23:56 /etc/config/wireless

I did restart the network but still there is no wireless in the network tab. However, I guess the problem is going to get solved when I am going to flash it with the final image as I am at the moment still of rc3.

Unless you're willing to contribute to bug reporting, it's recommended to stay on RC3... out of curiosity, why were you editing your wireless config from the cli?  Everything is available from the Web GUI for wireless... work smarter, not harder =]

There are certain Web GUI features that should be configured from the cli (such as openvpn), however wireless isn't one of them.

(Last edited by JW0914 on 13 Oct 2015, 20:13)

grau wrote:

@gufus

Is dd-wrt ready for daily usage on 1900ac v1 or are there any downsides?!

Using username "root".
DD-WRT v3.0-r27944 std (c) 2015 NewMedia-NET GmbH
Release: 10/09/15
Authenticating with public key "rsa-key-20120810"
==========================================================

     ___  ___     _      _____  ______       ____  ___
    / _ \/ _ \___| | /| / / _ \/_  __/ _  __|_  / / _ \
   / // / // /___/ |/ |/ / , _/ / /   | |/ //_ <_/ // /
  /____/____/    |__/|__/_/|_| /_/    |___/____(_)___/

                       DD-WRT v3.0
                   http://www.dd-wrt.com

==========================================================


BusyBox v1.23.2 (2015-10-09 01:36:33 CEST) built-in shell (ash)

root@AC-DD-WRT:~# uptime
12:58:11 up 2 days, 22:39,  load average: 0.00, 0.02, 0.04
root@AC-DD-WRT:~#


dd-wrt uses the same wifi driver as CC 15.05 so wifi is the same.

Everything works, VPN via L2TP too, I'm stil trying to get VLAN(s) up.

BTW

this works also
http://www.dd-wrt.com/phpBB2/viewtopic. … 285#985285

(Last edited by gufus on 13 Oct 2015, 22:18)

JW0914 wrote:
Id0n0tunderstand wrote:

root@OpenWrt:~# ls -l /etc/config/wireless
-rw-r--r--    1 root     root           803 Oct 12 23:56 /etc/config/wireless

I did restart the network but still there is no wireless in the network tab. However, I guess the problem is going to get solved when I am going to flash it with the final image as I am at the moment still of rc3.

Unless you're willing to contribute to bug reporting, it's recommended to stay on RC3... out of curiosity, why were you editing your wireless config from the cli?  Everything is available from the Web GUI for wireless... work smarter, not harder =]

There are certain Web GUI features that should be configured from the cli (such as openvpn), however wireless isn't one of them.

I set up my wifi to 40 Mhz. Maybe that was not such a smart thing to do any way.

Id0n0tunderstand wrote:
JW0914 wrote:
Id0n0tunderstand wrote:

root@OpenWrt:~# ls -l /etc/config/wireless
-rw-r--r--    1 root     root           803 Oct 12 23:56 /etc/config/wireless

I did restart the network but still there is no wireless in the network tab. However, I guess the problem is going to get solved when I am going to flash it with the final image as I am at the moment still of rc3.

Unless you're willing to contribute to bug reporting, it's recommended to stay on RC3... out of curiosity, why were you editing your wireless config from the cli?  Everything is available from the Web GUI for wireless... work smarter, not harder =]

There are certain Web GUI features that should be configured from the cli (such as openvpn), however wireless isn't one of them.

I set up my wifi to 40 Mhz. Maybe that was not such a smart thing to do any way.

That option is easily managed from the Web GUI

plamka00 wrote:

I've now an other problem.
After flashing OpenWRT I'm not able set up the router in a repeater mode. No SSID is broadcasting. I want to connect the router with an other AP but I want to have my own net with a different IP. So I'm able to connect to the AP but not able to create a virtual interface. Are there some important steps for this atheros device (WRT1900AC V1)?

push

JW0914 wrote:

why were you editing your wireless config from the cli?  Everything is available from the Web GUI for wireless... work smarter, not harder =]

There are certain Web GUI features that should be configured from the cli (such as openvpn), however wireless isn't one of them.

What about  "option noscan '1' " ? It's not possible to edit from GUI.

JW0914 wrote:

That option is easily managed from the Web GUI

Are you sure ? If you about HT40, it doesn't help. But  "option noscan '1' " is not available on GUI.

I just had to...

http://s7.postimg.org/u1v5lwqaf/Screenshot_from_2015_10_14_14_00_25.jpg

nitroshift

(Last edited by nitroshift on 14 Oct 2015, 14:04)

Gufus
Hi Which of the two files need to sew? dd-wrt

(Last edited by Armik on 14 Oct 2015, 14:15)

nitroshift wrote:

I just had to...

http://s7.postimg.org/u1v5lwqaf/Screenshot_from_2015_10_14_14_00_25.jpg

nitroshift

Kernel 4.3 << Wow that's cutting edge smile

Nice

oraxanlviv wrote:
JW0914 wrote:

That option is easily managed from the Web GUI

Are you sure ? If you about HT40, it doesn't help. But  "option noscan '1' " is not available on GUI.

I stand corrected =]

Though not committed yet, we now have all 8 queues for receiving network packets working in mvneta, network buffer manager due very soon (a few days from now) with its corresponding entries as well as all the other offload engines defined in armada-xp-linksys dts and network parser and classifier still in the works. That's on the wired part. Still no word from Marvell on a fresh revision of mwlwifi, though Kaloz is constantly pushing them (latest commit is already 2 months old).

nitroshift

(Last edited by nitroshift on 14 Oct 2015, 20:34)

Armik wrote:

Gufus
Hi Which of the two files need to sew? dd-wrt

First, get the unit running linksys firmware.

This img file you flash from the linksys firmware GUI.
factory-to-ddwrt.img

This bin file is for upgrading/downgrading DD-WRT, flash this from the DD-WRT firmware GUI.
ddwrt-linksys-wrt1900ac-webflash.bin


The fliping process (factory-to-ddwrt ddwrt-to-factory) will work if you have not installed DD-WRT and then upgraded to a different version of DD-WRT. It flips partitions every time a different DD-WRT firmware is installed.

It's recommended when dealing with the wrt1900ac is to always keep partition 1 as Linksys OEM. To do this if you are running DD-WRT is to flip back to the Linksys firmware and then install the DD-WRT version you want. Then DD-WRT firmware is installed in partition 2.

Happy fliping smile

(Last edited by gufus on 14 Oct 2015, 23:06)

Hi guys,

I've bought a wrt1900AC-V2 about 2 weeks ago and installed CC-final on it. It's currently my main internet router.

My home internet connection is a FTTH connection, symmetrical 100-100mbit, pppoe based. But the provider does not cap the upload speeds.
Currently i'm puzzling with the fact that after one or two days of uptime, the downloadspeeds (via wifi!) drops to about 20mbit, while upload stays "limitless" (>250mbit/sec)
Changing from wl0 to wl1 does not have any effect, performance stays bad until i reboot the device. it seems that the issue is wifi related, but due to a lack of wired laptops, i can't check the performance via the lan ports.

Anyone have any tips to debug and fix this issue?

[edit] just did some wgets on the router of larger bin files >/dev/zero and download from the internet is indeed still ~100mbit, confirming my idea the issue is wifi related.

(Last edited by JohnnySL on 15 Oct 2015, 00:16)

JohnnySL wrote:

[edit] just did some wgets on the router of larger bin files >/dev/zero and download from the internet is indeed still ~100mbit, confirming my idea the issue is wifi related.

Ask here https://github.com/kaloz/mwlwifi

nitroshift wrote:

Though not committed yet, we now have all 8 queues for receiving network packets working in mvneta, network buffer manager due very soon (a few days from now) with its corresponding entries as well as all the other offload engines defined in armada-xp-linksys dts and network parser and classifier still in the works. That's on the wired part. Still no word from Marvell on a fresh revision of mwlwifi, though Kaloz is constantly pushing them (latest commit is already 2 months old).

nitroshift

@nitroshift
Do you have a git or mailing list that I can follow regarding this?

@Lantis

#mvlinux on Freenode and kernel.org/net-next, search tag "mvneta". Also, the guys at free electrons are working on implementing hardware crypto module too.

@gufus & Armik

Please keep the forums here clean. DD-WRT has its own site / forum. Thanks.

nitroshift

(Last edited by nitroshift on 15 Oct 2015, 06:32)

JohnnySL wrote:

My issue seems to be identical to: https://github.com/kaloz/mwlwifi/issues/34
Same errors in the logs :-(

To bad there is not much going on there, seems that the developer is on holiday or something?

We've been waiting for quite some time for a proper driver, but I highly doubt that it will happen anytime soon. I suggest that you return it, and get a ubiquiti router + access point and all your problems will vanish wink

PS: I'm not saying OpenWRT is shit, because it's not, it's just the driver that's creating so many problems..

Sorry, posts 8126 to 8125 are missing from our archive.