OpenWrt Forum Archive

Topic: Openwrt support for Huawei HG655b

The content of this topic has been archived between 12 Mar 2018 and 5 May 2018. Unfortunately there are posts – most likely complete pages – missing.

danitool wrote:

AFAIK, that's normal in openwrt. Looks like Luci didn't implement board detection for bcm63xx.

fratzicu, could execute the comand

b

at the CFE serial console, and print here the results, I just want to know the compatible boards with your CFE

Regards.

hi,
I try to do that but the console is not answering any keyboard key in the interval of 2 seconds

Board IP address                  : 192.168.1.1:ffffff00                        
Host IP address                   : 192.168.1.100                               
Gateway IP address                :                                             
Run from flash/host (f/h)         : f                                           
Default host run file name        : vmlinux                                     
Default host flash file name      : bcm963xx_fs_kernel                          
Boot delay (0-9 seconds)          : 1                                           
Boot image (0=latest, 1=previous) : 0                                           
Board Id (0-6)                    : HW65x                                       
Number of MAC Addresses (1-32)    : 11                                          
Base MAC Address                  : 02:10:18:01:00:01                           
PSI Size (1-64) KBytes            : 64                                          
Main Thread Number [0|1]          : 0                                           
                                                                                
*** Press any key to stop auto run (2 seconds) ***                              
Auto run second count down: 0                                                   
LZMA: Prossible old LZMA format, trying to decompress..                         
Decompression OK!                                         

I booted with the reset button pressed and entered the console

*** Press any key to stop auto run (2 seconds) ***                              
Auto run second count down: 2                                                   
web info: Waiting for connection on socket 0.                                   
CFE> b                                                                          
*** command status = -1                                                         
CFE> b                                                                          
*** command status = -1    
Thhi wrote:

Hello.....I want to use RDS(name of the ISP) with HG655b but I don't know how to configure openwrt to work as a dsl router, make Lan1 work as Wan port and the the rest 3 ports work normally as Lan ports. Can you help me please?

This is the content of the file "network" in / etc / config :

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '1 2 3 8t'

config switch_vlan
        option device 'eth0'
        option vlan '2'
        option ports '0 8t'

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd49:a377:3050::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option type 'bridge'
        option proto 'pppoe'
        option username 'User-Rcs-Rds_PPPOE'
        option password 'Pass-Rcs-Rds_PPPOE'
 

It will turn LAN1 port   in Wan Port ....

If you're on Windows PC, edit the file with notepad ++, and move it to the router with WinSCP in / etc / config

good luck

(Last edited by free4allandall4free on 3 Feb 2015, 14:43)

danitool wrote:

Hi again, I've made a dummy firmware for upgrading the HG655d CFE, with the one present in the HG655b. It should solve the issues for installing a new firmware. I didn't test it in a HG655d but I expect it will work.

https://drive.google.com/uc?export=down … zQ1M29BRjg

Caution: replacing the bootloader can brick the router (only recoverable via JTAG).

Remember, this is only for HG655d. Feedback is welcome.

Hi, i tried this file on my Hg655d. It's don't worked for me.

vurulkan wrote:
danitool wrote:

Hi again, I've made a dummy firmware for upgrading the HG655d CFE, with the one present in the HG655b. It should solve the issues for installing a new firmware. I didn't test it in a HG655d but I expect it will work.

https://drive.google.com/uc?export=down … zQ1M29BRjg

Caution: replacing the bootloader can brick the router (only recoverable via JTAG).

Remember, this is only for HG655d. Feedback is welcome.

Hi, i tried this file on my Hg655d. It's don't worked for me.

Can you be more specific?.

What didn't work?
- The hg655d didn't flash this dummy firmware, returning an error, and therefore no CFE upgrade was made
or
- You bricked your router

@fratzicu: Have you managed to get the wifi circuitry checked by your friend?

Hi, andoru, not yet. I don't know when I'll do it, as I have some other problems that occured, but I'll do it.
I had another experience with my TEW-632BRP that didn't work and it seemed that apower component was broken (that provided power to the chipset) and it was replaced and then it worked. Another issue that could e is for the long-hauled circuits the capacitors get wasted (they become inflated) and they need to be replaced. I don't know.
But anyway, if the chipset is not fried and if there is no problem with the circuits, then the software problem might remain (but our calib_data is ok). First, I thaught that my too big compiled image was to blame (but then I restored the calib_data and worked again). Then, because the wifi practically stopped while working (or maybe during the night in a power fluctuation) maybe the circuitry is the problem.

For me it stopped working suddenly when I started a ssh connection from my smartphone to one of my PCs connected to one of the router's ports, while using the factory-default firmware (which now doesn't work, and I suspect it might be connected to the wifi problem, as it stopped working at the same time the wifi problem arose)
I took a look inside the router and there doesn't seem to be anything suspicious, no blown up capacitors and no burnt traces/blown up circuits... so I don't know.
Which one of the chips is for wifi?

It should be the one on which it's written "Ralink" I guess. In my case also no sign of hardware defects. I have another device and I've configure it the same, so I'll wait until it crashes; let's see if the wifi problem can be reproduced.

(Last edited by fratzicu on 3 Feb 2015, 22:00)

Hi,
I try to replace minidlna icon. I know it's possible because others made icons for apple and ubuntu. I found here a script to convert images.
http://sourceforge.net/p/minidlna/discu … d/cc0ccac8

when i use this script

/* convert icon data for icons.c" */
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main(int argc, char *argv[])
{
    int i, c;
    FILE *rfp, *wfp;
    if (argc < 3) {fprintf(stderr, "Usage: %s inputfilename outputfilename\n\n", argv[0]); exit(1);}
    rfp = fopen (argv[1], "rb");
    if (rfp == NULL) {fprintf(stderr, "cannot open \"%s\"\n", argv[1]); exit(1);}
    wfp = fopen (argv[2], "wb");
    if (wfp == NULL) {fprintf(stderr, "cannot create  \"%s\"e\n", argv[2]); exit(1);}
    for (; ;) {
        fprintf(wfp, "             \"");
        for (i=0; i<24 ; i++) {
            c = fgetc(rfp); if (c == EOF) break;
            c = fprintf(wfp, "\\x%02x", c); if (c<0) goto end;
        }
        fprintf(wfp, "\"\n");
        if (c == EOF) break;
    }
end:
    fclose(rfp);
    fclose(wfp);
    exit(0);
} 

it gives an error

 sudo ./convicons.c sara1.jpg
./convicons.c: 28: ./convicons.c: Syntax error: Unterminated quoted string
-bash: ./convicons.c:: No such file or directory
 ./convicons.c sara1.jpg
./convicons.c: line 20: unexpected EOF while looking for matching `"'
./convicons.c: line 28: syntax error: unexpected end of file

anyone has an idea where is the mistake?

(Last edited by fratzicu on 7 Feb 2015, 12:15)

You are trying to execute C code as if it was a scrpit, that's the error. People usually forget to include a short instruction to compile o use his stuff.

Therefore you first need to compile:

gcc -o convicons convicons.c

and then use the convicons binary

BTW looks like your paste isn't ok. This is what I see in SF:

/* convert icon data for icons.c" */
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main(int argc, char *argv[])
{
    int i, c;
    FILE *rfp, *wfp;
    if (argc < 3) {fprintf(stderr, "Usage: %s inputfilename outputfilename\n\n", argv[0]); exit(1);}
    rfp = fopen (argv[1], "rb");
    if (rfp == NULL) {fprintf(stderr, "cannot open \"%s\"\n", argv[1]); exit(1);}
    wfp = fopen (argv[2], "wb");
    if (wfp == NULL) {fprintf(stderr, "cannot create  \"%s\"e\n", argv[2]); exit(1);}
    for (; ;) {
        fprintf(wfp, "             \"");
        for (i=0; i<24 ; i++) {
            c = fgetc(rfp); if (c == EOF) break;
            c = fprintf(wfp, "\\x%02x", c); if (c<0) goto end;
        }
        fprintf(wfp, "\"\n");
        if (c == EOF) break;
    }
end:
    fclose(rfp);
    fclose(wfp);
    exit(0);
} 

thank you. i understand now. I'll try it.

Hi,
I tried to follow the instructions

I create the four icons with gimp: jpeg_lrg.jpg, jpeg_sm.jpg, png_lrg.png, png_sm.png
If i've understand, i have to convert in data
Can you teach me how to do that ? please

I wrote a program which converts data.
use this program to convert data and replace
png_sm =
png_lrg =
jpeg_sm =
jpeg_lrg =
in "icons.c" with them, and build.
convicons.c:

Unfortunately, it didn't work and I don't understand what files to prepare and what the file does.
I prepared the 4 files, jpeg_lrg, jpeg_sm, png_lrg, png_sm, I've put them in the same folder with the convicons.c file and then gave the command

gcc -o convicons convicons.c

It resulted in a file named convicons and when I open it with the text editor it's some sort of rubbish with no hex pattern. No matter what files are in the same folder, the command outputs the same 8.8k file that looks like this

ELF\00\00\00\00\00\00\00\00\00\00>\00\00\00\00\F0@\00\00\00\00\00@\00\00\00\00\00\00\00\98\00\00\00\00\00\00\00\00\00\00@\008\00    \00@\00\00\00\00\00\00\00\00\00@\00\00\00\00\00\00\00@\00@\00\00\00\00\00@\00@\00\00\00\00\00\F8\00\00\00\00\00\00\F8\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\008\00\00\00\00\00\008@\00\00\00\00\008@\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00@\00\00\00\00\00\00\00@\00\00\00\00\00\A4
\00\00\00\00\00\00\A4
\00\00\00\00\00\00\00\00 \00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00`\00\00\00\00\00`\00\00\00\00\00X\00\00\00\00\00\00h\00\00\00\00\00\00\00\00 \00\00\00\00\00\00\00\00\00\00\00(\00\00\00\00\00\00(`\00\00\00\00\00(`\00\00\00\00\00\D0\00\00\00\00\00\00\D0\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00T\00\00\00\00\00\00T@\00\00\00\00\00T@\00\00\00\00\00D\00\00\00\00\00\00\00D\00\00\00\00\00\00\00\00\00\00\00\00\00\00P\E5td\00\00\00x    \00\00\00\00\00\00x    @\00\00\00\00\00x    @\00\00\00\00\004\00\00\00\00\00\00\004\00\00\00\00\00\00\00\00\00\00\00\00\00\00Q\E5td\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00R\E5td\00\00\00\00\00\00\00\00\00`\00\00\00\00\00`\00\00\00\00\00\F0\00\00\00\00\00\00\F0\00\00\00\00\00\00\00\00\00\00\00\00\00/lib64/ld-linux-x86-64.so.2\00\00\00\00\00\00\00\00\00\00GNU\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00GNU\00\FAc\C9\CCy\BF똧\D3\CD\FF\FD\DF\C8\EC\DC-I\00\00\00    \00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00    \00\00\009\F2\8B\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\009\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\001\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00K\00\00\00 \00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00*\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00#\00\00\00\00\00h`\00\00\00\00\00\00\00\00\00\00\00\00\00libc.so.6\00exit\00fopen\00fgetc\00fclose\00stderr\00fwrite\00fprintf\00__libc_start_main\00__gmon_start__\00GLIBC_2.2.5\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00ui    \00\00\00Z\00\00\00\00\00\00\00\F8`\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00h`\00\00\00\00\00\00\00\00    \00\00\00\00\00\00\00\00\00\00\00`\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00 `\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00(`\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\000`\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\008`\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00@`\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00H`\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00P`\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00H\83\ECH\8B\AD
 \00H\85\C0t\E8[\00\00\00H\83\C4\C3\00\00\00\00\00\00\FF5\A2
 \00\FF%\A4
 \00@\00\FF%\A2
 \00h\00\00\00\00\E9\E0\FF\FF\FF\FF%\9A
 \00h\00\00\00\E9\D0\FF\FF\FF\FF%\92
 \00h\00\00\00\E9\C0\FF\FF\FF\FF%\8A
 \00h\00\00\00\E9\B0\FF\FF\FF\FF%\82
 \00h\00\00\00\E9\A0\FF\FF\FF\FF%z
 \00h\00\00\00\E9\90\FF\FF\FF\FF%r
 \00h\00\00\00\E9\80\FF\FF\FF\FF%j
 \00h\00\00\00\E9p\FF\FF\FF1\EDI\89\D1^H\89\E2H\83\E4\F0PTI\C7\C0\F0@\00H\C7\C1\80@\00H\C7\C7\DD@\00\E8w\FF\FF\FF\F4fD\00\00\B8o`\00UH-h`\00H\83\F8H\89\E5w]ø\00\00\00\00H\85\C0t\F4]\BFh`\00\FF\E0\80\00\00\00\00\B8h`\00UH-h`\00H\C1\F8H\89\E5H\89\C2H\C1\EA?H\D0H\D1\F8u]ú\00\00\00\00H\85\D2t\F4]H\89ƿh`\00\FF\E2\80\00\00\00\00\80=\D9     \00\00uUH\89\E5\E8~\FF\FF\FF]\C6\C6     \00\F3\C3@\00H\83=h \00\00t\B8\00\00\00\00H\85\C0tU\BF `\00H\89\E5\FF\D0]\E9{\FF\FF\FF\00\E9s\FF\FF\FFUH\89\E5H\83\EC0\89}\DCH\89uЃ}\DC*H\8BE\D0H\8BH\8Bh     \00\BE    @\00H\89Ǹ\00\00\00\00\E8\8E\FE\FF\FF\BF\00\00\00\E8\B4\FE\FF\FFH\8BE\D0H\83\C0H\8B\00\BE1    @\00H\89\C7\E8\8C\FE\FF\FFH\89E\F0H\83}\F0\00u.H\8BE\D0H\83\C0H\8BH\8B     \00\BE4    @\00H\89Ǹ\00\00\00\00\E8=\FE\FF\FF\BF\00\00\00\E8c\FE\FF\FFH\8BE\D0H\83\C0H\8B\00\BEF    @\00H\89\C7\E8;\FE\FF\FFH\89E\F8H\83}\F8\00u.H\8BE\D0H\83\C0H\8BH\8B\C6 \00\BEI    @\00H\89Ǹ\00\00\00\00\E8\EC\FD\FF\FF\BF\00\00\00\E8\FE\FF\FFH\8BE\F8H\89\C1\BA\00\00\00\BE\00\00\00\BF_    @\00\E8\FE\FF\FF\C7E\E8\00\00\00\00\EB?H\8BE\F0H\89\C7\E8\92\FD\FF\FF\89E\EC\83}\EC\FFu\EB.\8BU\ECH\8BE\F8\BEn    @\00H\89Ǹ\00\00\00\00\E8\8E\FD\FF\FF\89E\EC\83}\EC\00y\EB2\83E\E8\83}\E8~\BBH\8BE\F8H\89\C1\BA\00\00\00\BE\00\00\00\BFu    @\00\E8\9E\FD\FF\FF\83}\EC\FFu\EB\E9o\FF\FF\FFH\8BE\F0H\89\C7\E8\FD\FF\FFH\8BE\F8H\89\C7\E8    \FD\FF\FF\BF\00\00\00\00\E8_\FD\FF\FFf.\84\00\00\00\00\00D\00\00AWA\89\FFAVI\89\F6AUI\89\D5ATL\8D%x \00UH\8D-x \00SL)\E51\DBH\C1\FDH\83\EC\E8\8D\FC\FF\FFH\85\EDt\84\00\00\00\00\00L\89\EAL\89\F6D\89\FFA\FF\DCH\83\C3H9\EBu\EAH\83\C4[]A\A]A^A_\C3ff.\84\00\00\00\00\00\F3\C3\00\00H\83\ECH\83\C4\C3\00\00\00\00\00\00\00\00\00Usage: %s inputfilename outputfilename

\00rb\00cannot open "%s"
\00wb\00cannot create  "%s"e
\00             "\00\x%02x\00"
\00;4\00\00\00\00\00\00\E8\FB\FF\FF\80\00\00\00x\FC\FF\FFP\00\00\00e\FD\FF\FF\A8\00\00\00\FF\FF\FF\C8\00\00\00x\FF\FF\FF\00\00\00\00\00\00\00\00\00\00\00\00\00zR\00x\90\00\00\00\00\00\00 \FC\FF\FF*\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00zR\00x\90\00\00$\00\00\00\00\00\00`\FB\FF\FF\90\00\00\00\00FJw\80\00?;*3$"\00\00\00\00\00\00\00D\00\00\00\B5\FC\FF\FF\94\00\00\00A\86C
\00\00\00\00\00\00\00D\00\00\00d\00\00\008\FE\FF\FFe\00\00\00\00B\8FE\8EE \8DE(\8CH0\86H8\83M@l8A0A(B BBB\00\00\00\00\AC\00\00\00`\FE\FF\FF\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\B0@\00\00\00\00\00\90@\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00@@\00\00\00\00\00
\00\00\00\00\00\00\00\F4@\00\00\00\00\00\00\00\00\00\00\00\00`\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00`\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\F5\FE\FFo\00\00\00\00\98@\00\00\00\00\00\00\00\00\00\00\00\00\B0@\00\00\00\00\00\00\00\00\00\00\00\00\C0@\00\00\00\00\00
\00\00\00\00\00\00\00f\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00`\00\00\00\00\00\00\00\00\00\00\00\00\C0\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\80@\00\00\00\00\00\00\00\00\00\00\00\00P@\00\00\00\00\00\00\00\00\00\00\00\000\00\00\00\00\00\00\00    \00\00\00\00\00\00\00\00\00\00\00\00\00\00\FE\FF\FFo\00\00\00\000@\00\00\00\00\00\FF\FF\FFo\00\00\00\00\00\00\00\00\00\00\00\F0\FF\FFo\00\00\00\00@\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00(`\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00v@\00\00\00\00\00\86@\00\00\00\00\00\96@\00\00\00\00\00\A6@\00\00\00\00\00\B6@\00\00\00\00\00\C6@\00\00\00\00\00\D6@\00\00\00\00\00\E6@\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00GCC: (Ubuntu 4.8.2-19ubuntu1) 4.8.2\00\00.symtab\00.strtab\00.shstrtab\00.interp\00.note.ABI-tag\00.note.gnu.build-id\00.gnu.hash\00.dynsym\00.dynstr\00.gnu.version\00.gnu.version_r\00.rela.dyn\00.rela.plt\00.init\00.text\00.fini\00.rodata\00.eh_frame_hdr\00.eh_frame\00.init_array\00.fini_array\00.jcr\00.dynamic\00.got\00.got.plt\00.data\00.bss\00.comment\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\008@\00\00\00\00\008\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00#\00\00\00\00\00\00\00\00\00\00\00\00\00T@\00\00\00\00\00T\00\00\00\00\00\00 \00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\001\00\00\00\00\00\00\00\00\00\00\00\00\00t@\00\00\00\00\00t\00\00\00\00\00\00$\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00D\00\00\00\F6\FF\FFo\00\00\00\00\00\00\00\98@\00\00\00\00\00\98\00\00\00\00\00\00$\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00N\00\00\00\00\00\00\00\00\00\00\00\00\00\C0@\00\00\00\00\00\C0\00\00\00\00\00\00\F0\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00V\00\00\00\00\00\00\00\00\00\00\00\00\00\B0@\00\00\00\00\00\B0\00\00\00\00\00\00f\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00^\00\00\00\FF\FF\FFo\00\00\00\00\00\00\00@\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00k\00\00\00\FE\FF\FFo\00\00\00\00\00\00\000@\00\00\00\00\000\00\00\00\00\00\00 \00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00z\00\00\00\00\00\00\00\00\00\00\00\00\00P@\00\00\00\00\00P\00\00\00\00\00\000\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\84\00\00\00\00\00\00\00\00\00\00\00\00\00\80@\00\00\00\00\00\80\00\00\00\00\00\00\C0\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\8E\00\00\00\00\00\00\00\00\00\00\00\00\00@@\00\00\00\00\00@\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\89\00\00\00\00\00\00\00\00\00\00\00\00\00`@\00\00\00\00\00`\00\00\00\00\00\00\90\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\94\00\00\00\00\00\00\00\00\00\00\00\00\00\F0@\00\00\00\00\00\F0\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\9A\00\00\00\00\00\00\00\00\00\00\00\00\00\F4@\00\00\00\00\00\F4\00\00\00\00\00\00    \00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\A0\00\00\00\00\00\00\00\00\00\00\00\00\00\00    @\00\00\00\00\00\00    \00\00\00\00\00\00x\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\A8\00\00\00\00\00\00\00\00\00\00\00\00\00x    @\00\00\00\00\00x    \00\00\00\00\00\004\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\B6\00\00\00\00\00\00\00\00\00\00\00\00\00\B0    @\00\00\00\00\00\B0    \00\00\00\00\00\00\F4\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\C0\00\00\00\00\00\00\00\00\00\00\00\00\00`\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\CC\00\00\00\00\00\00\00\00\00\00\00\00\00`\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\D8\00\00\00\00\00\00\00\00\00\00\00\00\00 `\00\00\00\00\00 \00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\DD\00\00\00\00\00\00\00\00\00\00\00\00\00(`\00\00\00\00\00(\00\00\00\00\00\00\D0\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\E6\00\00\00\00\00\00\00\00\00\00\00\00\00\F8`\00\00\00\00\00\F8\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\EB\00\00\00\00\00\00\00\00\00\00\00\00\00\00`\00\00\00\00\00\00\00\00\00\00\00\00X\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\F4\00\00\00\00\00\00\00\00\00\00\00\00\00X`\00\00\00\00\00X\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\FA\00\00\00\00\00\00\00\00\00\00\00\00\00h`\00\00\00\00\00h\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\FF\00\00\00\00\00\000\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00h\00\00\00\00\00\00$\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\8C\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\A8\00\00\00\00\00\00\00\00\00-\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00    \00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\C0\00\00\00\00\00\00\B2\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\008@\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00T@\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00t@\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\98@\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\C0@\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\B0@\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00@\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\000@\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00    \00P@\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00
\00\80@\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00@@\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00`@\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00
\00\F0@\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\F4@\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00    @\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00x    @\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\B0    @\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00`\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00`\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00 `\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00(`\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\F8`\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00`\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00X`\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00h`\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\F1\FF\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00 `\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00
\00 @\00\00\00\00\00\00\00\00\00\00\00\00\00.\00\00\00\00
\00P@\00\00\00\00\00\00\00\00\00\00\00\00\00A\00\00\00\00
\00\90@\00\00\00\00\00\00\00\00\00\00\00\00\00W\00\00\00\00\00p`\00\00\00\00\00\00\00\00\00\00\00\00f\00\00\00\00\00`\00\00\00\00\00\00\00\00\00\00\00\00\00\8D\00\00\00\00
\00\B0@\00\00\00\00\00\00\00\00\00\00\00\00\00\99\00\00\00\00\00`\00\00\00\00\00\00\00\00\00\00\00\00\00\B8\00\00\00\00\F1\FF\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\F1\FF\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\C4\00\00\00\00\00\A0
@\00\00\00\00\00\00\00\00\00\00\00\00\00\D2\00\00\00\00\00 `\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\F1\FF\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\DE\00\00\00\00\00\00`\00\00\00\00\00\00\00\00\00\00\00\00\00\EF\00\00\00\00\00(`\00\00\00\00\00\00\00\00\00\00\00\00\00\F8\00\00\00\00\00\00`\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00`\00\00\00\00\00\00\00\00\00\00\00\00\00!\00\00\00
\00\F0@\00\00\00\00\00\00\00\00\00\00\00\001\00\00 \00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00M\00\00 \00\00X`\00\00\00\00\00\00\00\00\00\00\00\00\00X\00\00\00\00h`\00\00\00\00\00\00\00\00\00\00\00\00\00_\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00s\00\00\00\00\F4@\00\00\00\00\00\00\00\00\00\00\00\00\00y\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\8C\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\AB\00\00\00\00X`\00\00\00\00\00\00\00\00\00\00\00\00\00\B8\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\CD\00\00 \00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\DC\00\00\00``\00\00\00\00\00\00\00\00\00\00\00\00\00\E9\00\00\00\00\00    @\00\00\00\00\00\00\00\00\00\00\00\00\F8\00\00\00
\00\80@\00\00\00\00\00e\00\00\00\00\00\00\00\00\00\00\00x`\00\00\00\00\00\00\00\00\00\00\00\00\00
\00\00\00
\00\F0@\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00h`\00\00\00\00\00\00\00\00\00\00\00\00\00 \00\00\00
\00\DD@\00\00\00\00\00\94\00\00\00\00\00\00%\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\008\00\00 \00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00L\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00^\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00r\00\00\00h`\00\00\00\00\00\00\00\00\00\00\00\00\00~\00\00 \00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\98\00\00\00\00@@\00\00\00\00\00\00\00\00\00\00\00\00\00\9E\00\00\00\00h`\00\00\00\00\00\00\00\00\00\00\00\00\00crtstuff.c\00__JCR_LIST__\00deregister_tm_clones\00register_tm_clones\00__do_global_dtors_aux\00completed.6972\00__do_global_dtors_aux_fini_array_entry\00frame_dummy\00__frame_dummy_init_array_entry\00convicons.c\00__FRAME_END__\00__JCR_END__\00__init_array_end\00_DYNAMIC\00__init_array_start\00_GLOBAL_OFFSET_TABLE_\00__libc_csu_fini\00_ITM_deregisterTMCloneTable\00data_start\00_edata\00fclose@@GLIBC_2.2.5\00_fini\00fgetc@@GLIBC_2.2.5\00__libc_start_main@@GLIBC_2.2.5\00__data_start\00fprintf@@GLIBC_2.2.5\00__gmon_start__\00__dso_handle\00_IO_stdin_used\00__libc_csu_init\00_end\00_start\00__bss_start\00main\00fopen@@GLIBC_2.2.5\00_Jv_RegisterClasses\00exit@@GLIBC_2.2.5\00fwrite@@GLIBC_2.2.5\00__TMC_END__\00_ITM_registerTMCloneTable\00_init\00stderr@@GLIBC_2.2.5\00

I don't know how to use this. I used an online tool to convert the images, but it's difficult to paste the code in icons.c because every line has " at beginning and end. I hoped this does it manually

(Last edited by fratzicu on 7 Feb 2015, 14:41)

The built convicons binary is the program you will use for whatever you want to do

./convicons sara.jpg

BTW this is offtopic, and probably not related with openwrt. There are elsewhere forums about basic scripting or programming in linux.

Regards.

You are right, a little off topic.
Thank you

About wifi problem , i havit same problem with wifi chip (rt3062f) on other board zyxel p2812hnu-f1, wifi stopped sudently work.
Solved with a infrared reflow on wifi chip, now wifi is ok.

cornelus2009 wrote:

About wifi problem , i havit same problem with wifi chip (rt3062f) on other board zyxel p2812hnu-f1, wifi stopped sudently work.
Solved with a infrared reflow on wifi chip, now wifi is ok.

That is very interesting

danitool wrote:

Hi again, I've made a dummy firmware for upgrading the HG655d CFE, with the one present in the HG655b. It should solve the issues for installing a new firmware. I didn't test it in a HG655d but I expect it will work.

Hi, in my case, flashing firmware seems restricted to the ones from my Dutch ISP 'Online'. Although I could walk to firmware's busybox' root using b023:

download & install v100r001c02b023 firmware [url]http://online.gebruikers.eu/faq.php?cat_id=15[/url]
telnet 192.168.1.1 
login: admin
pass: admin
ATP> sh
# 

The upgrade tool can be found at /bin/upg. To open the possibility to flash OpenWRT, we might try to transplant a good CFE.  Maybe the CFE from fratzicu's box is a good one? For making the dump, no JTAG is required. Simply within Busybox:

# cat /dev/mtdblock0 > /tmp/mtd0.bin 

and tftp this file to the connected PC
Edit: error: this seems does NOT to dump cfe.

I am willing to try to upload this file to my box using JTAG

(Last edited by nederfox on 20 Feb 2015, 10:41)

Hi nederfox, it's a good idea to first backup your bootloader before flashing a new one. AFAIK in these broadcom firmwares mt0 isn't the bootloader partition, but the rootfs. I'm not 100% sure since I don't have any HG655d.

Are you saying you can't flash any firmware? no CFE web interface access?

I built again the dummy firmware, this time with fake rootfs and fake kernel (zeroed), It can be flashed using the CFE web interface.( I recommend to use firefox and clean the cache before flashing)
HG655d-cfe_upgrade-dummy_firmware.bin
If all goes fine it will upgrade CFE, and after this it will restart into CFE web upgrade mode again for requesting a new firmware, since the previous one was fake.

But if you decide to flash CFE using JTAG use this file
CFE_HG655b-OEM_nvr.bin
It's the bare CFE taken from the fratzicus backups, and known to work with OpenWrt.

I can even build a CFE for this board without the Huawei's crap. But since I don't have this board I cannot test it, and without feedback there isn't much I can do.

(Last edited by danitool on 16 Feb 2015, 20:36)

Danitool, Thanks for the fast response!
I tried HG655d-cfe_upgrade-dummy_firmware.bin, which failed silently but via serial UART it shows:

pcImage is Illegal.

which should be:

RSA verified success

 crc check ok

 upgrade .bin file.

 .

 .

So my next step is making the JTAG cable and flash the SoC directly. I have to solder that thingy in the next few days and I'll be back here...

Ok, I figured out what's going on. Looks like CRC is calculated truncating the kernel by exactly 276 bytes, also the length in the header is truncated, this means the CFE expects a regular firmware plus extra 276 bytes. Or maybe I'm wrong.

I added 276 bytes to the previous firmware, uploaded to the same link
HG655d-cfe_upgrade-dummy_firmware.bin
Check again if it works.

(Last edited by danitool on 17 Feb 2015, 02:01)

Nope, again it fails silently. I tried different FW's for this specific model, and in my case only the ones from Dutch ISP 'Online' are accepted. Probably some very restricted CFE's are preventing unsigned code as described here: [link]http://wiki.openwrt.org/doc/techref/brcm63xx.imagetag[/link]:

unsigned char rsa_signature[TAGINFO_LEN];     142-161: RSA Signature (unused at present; some vendors may use this)

Jtag would be the best solution I guess.

Nope, the header is totally OK. I checked it using the firmware from this link
http://online.gebruikers.eu/faq.php?cat_id=15

In fact I separated the firmware and generated a new firmware with a new header, and they are exactly the same, no extra parameters or different calculations in the header when comparing with other regular firmwares.

If the last firmware failed this could mean these firmwares have a header but also a tail. The tail is exactly 276 bytes lenght, and probably not part of the kernel as I thought previously.

Then CFE rejects the firmware because it can't read something in the tail, some crypto stuff maybe?. I separated 2 tails from 2 firwares and have no sense for me, I cannot reproduce the data stored in the tail for other firmwares.

Regards

(Last edited by danitool on 17 Feb 2015, 01:59)

This time I repacked the dutch firmware I mentioned with CFE included
HG655dV100R001C02B050_upgrade_main-CFE.bin
It's exactly the same firmware but with CFE properly inserted. Hoping the tail doesn't contain any data related with CFE.

Give it a try. Regards

Hi.I have an HG655b with V100R001C02B025 version.I use it since last year.I've switched the 1'st LAN port in WAN and it worked perfect until two weeks ago.Now,the WLAN led is off.I have tried to reset,load another firmware version,including Openwrt,but the WLAN led is still off.I have to mention that the WAN port is working well,but I can't use it's wireless function anymore.I've read on the previous posts that something can happen' with calibration_data.bin.Could be possible to have that problem? How can i solve it? Thank you in advance !