OpenWrt Forum Archive

Topic: Revert a TP-Link WR1043ND v2 to Stock Firmware

The content of this topic has been archived on 8 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.


Below is a link to a document detailing the steps taken to successfully revert a TP-Link WR1043ND v2 Router from OpenWrt to Stock TP-Link Firmware.

Revert a TP-Link WR1043ND v2

Please note that the notes document my own experiences and I cannot be held responsible for any damage you may do to your own device by following the document.


Hi, I see you managed to flash OpenWRT to your V2.x router.

Could you let me know what I am doing wrong?

I have TL-WR1043ND v2.1
I downloaded Trunk Barrier Breaker " … actory.bin" and updated via web GUI.

I wasn't able to load the web gui page after reboot.
I was able to get DHCP IP 192.168.1.x (Gateway was
Ping was ok to router
TELNET to router was ok, I managed to passwd new root password
I managed to login via SSH.

I was still not able to get web GUI.
I tried SCP OEM firmware to /tmp and mtd -r write tplink.bin firmware
But received error unable to erase ... then finally bricked the router.

I returned the router and got a replacement.
Could someone let me know if I am doing something wrong?

Hi there,

Just reverted my own wr1043nd to stock firmware. A quick question, after this revert, when I try to upgrade to a newer stock firmware, do I need to strip the bootloader part from the new image, or is it working as is?

So basically, do we need to strip the bootloader from all images from here onwards?


The discussion might have continued from here.