OpenWrt Forum Archive

Topic: Netgear WNR2000v4

The content of this topic has been archived between 26 Apr 2018 and 6 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Okay guys,
so here is the deal. I am new to OpenWRT and tbh didnt manage to flash the sysupgrade onto my router. I tried the option 1, that Bazz mentioned earlier with his pre-made u-boot-env image but got a "Unlocking u-boot-env ...Could not open mtd device: u-boot-env" when performing "mtd -f write uboot_env_bootcmd_nocrc.backup u-boot-env". Sadly, I have also not managed to find the bootcmd section through the hexeditor.

Id be thankful for any help, preferably maybe some kind of tutorial.

Cheers

Thank you so much @bazz for your work on this! The WN2000RPTv3 utilizes similar hardware, just lacking a WAN port. I was able to flash to OpenWrt on this model by creating a custom Netgear build that automatically writes the modified u-boot-env part. I've posted instructions and files here:

https://forum.openwrt.org/viewtopic.php?id=65576

Thanks again!

Hey guys, new here but alot of information here has helped me out. I own a WNR2000v4 which i recently had OpenWRT 15.05 successfully installed upon. The information provided on this forum and the wiki were amazingly helpful.

Mind you...my road has gone a bit awry.

Ofcourse, like anyone else i was dissatisfied with the memory available on the device and figured i'd attempt my hands at a Luci-less installation with usb packages for a USB mod. Afterwards i would install luci in the expanded usb storage.

I installed the build environment and went through several configuration variations until i came up with something i was satisfied with testing.

I flashed the new sysupgrade.bin, everything went well. My router settings were saved as expected and my luci-less setup was running. My wireless came up as expected and my router functioned normally. The only caveat was that i could no longer SSH into my router. For some reason my root password had become changed/corrupted? After some intense googling i decided to tftp reset firmware back to 1.0.0.58 which went without a hitch.

I'm currently sitting here with as stock a WNR2000v4 as i could possibly ask for, running perfectly fine mind you.

The plan was to start from stock and reinstall openwrt so i could set the root password as with an initial installation..

However, now i'm stuck since UDPtelnetenable.py will not enable telnet on my device for some reason.

-- This totally worked the first time round.

So....what now? >.<

--EDIT
So i think i'll be getting a USB / TTL Serial cable, ya?

Well, i got the UDPtelnetenable.py to work, i dunno i got up this morning and tried it out again..bam it worked -shrugs- i dunno wtf i was doing wrong. Anyway...

On another note, i do own an Arduino Uno anyone done serial communication with it like the OWRT wiki says about @ http://tinyurl.com/gt99a8z?

(Last edited by fateinabox on 23 Jun 2016, 09:13)

So i managed to get serial access using my Arduino Uno and a NPN Transistor and some 1k/10k ohm resistors as a llc.. setting the root passwd from here does nothing for SSH whatsoever.

I've set the default passwd shadow files in build-root/openwrt/package/base-files/etc/ in my custom sysupgrade.bin and verified their contents through shell on serial.

Is this a jffs2 issue?

I couldn't manage to set the password from failsafe mode either.

http://i66.tinypic.com/ddi4qt.jpg

Trying to get this wnr2000v4 flashed over to openwrt...first I couldn't get telnet enabled on stock 1.0.0.58 like it says on the wiki page. I am able to get telnet with stock 1.0.0.30 though.  The issue now is I keep getting "Unlocking u-boot-env ...Could not open mtd device: u-boot-env" when performing "mtd -f write uboot_env_bootcmd_nocrc.backup u-boot-env" command. If someone can tell me how to get past this it would be appreciated. I have read everything g I can find so far but nothing about how to fix that....

also when i do "mtd unlock mtd1"
Unlocking u-boot-env ...
Could not open mtd device: u-boot-env

(Last edited by AxR on 25 Jun 2016, 03:08)

I know it might seem silly but did you try running UDPtelnetenable.py via sudo?
if your router is 192.168.1.1 and the mac is 00:AA:22:BB:33:CC ( you can get your routers mac via `sudo arp -a` ) you would execute the following...

sudo python /path/to/UDPtelnetenable.py 192.168.1.1 00AA22BB33CC admin password

make note that there are no colons ( : ) and that the alpha characters are in caps ( this is necessary )

additionally, where did you get your uboot_env_bootcmd_nocrc.backup ?? is it valid?? I can throw up a copy of my u-boot-env.bin file if you like.

can you post a copy of your stdout for review?

(Last edited by fateinabox on 25 Jun 2016, 02:29)

On a side note, anyone got any tips on removing this EMI Shielding from the board? I don't have a heat-gun handy and the nature of the shield makes it an adequate heat sink, solder and solder wick doesn't really work too well. I thought about kinda "reflowing" the board and removing it once it was up to temperature. Not sure...I also thought about just cutting it off with a dremel...I dunno though.. seems a bit barbaric and riskeh.

OK i figured it out.  Flashed to 1.0.0.58 and got telnet unlocked.  I guess I was doing the commands wrong the first time around.  Everything is all good now.

Glad you got it working!

The discussion might have continued from here.