OpenWrt Forum Archive

Topic: Support for Netgear WN2500RP Repeater

The content of this topic has been archived on 1 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hey Guys -

After switching from DD-WRT to OpenWRT 2-3 months ago, I'm beyond glad I did.  DD-WRT is excellent, but OpenWRT provides just that many more possiblities.

When moving this weekend, I ran across hardware that I really need for my new place - a Netgear WN2500RP wireless repeater.  It has the latest OEM firmware ( which works, but I'd like to apply an OpenWRT build if only for stability alone as I realize it's not a full router therefore won't be able to use many of the OpenWRT features.

After searching forums and Google, I unfortunately found no mention (or posts with replies) about the WN2500RP. 

Does anyone know of OpenWRT builds which may work with it - or if not - another open source firmware?


(Last edited by BzowK on 12 May 2014, 17:01)

Hi BzowK, I have the same router. Did you get it working on the WN2500RP? regards, Tilli

BTW: found some details here:

(Last edited by utillity on 7 Nov 2014, 11:43)

Let us know flash size. We need at least 4 MiB.

I apologize for necro-posting, but this was the only thread I was able to google about the subject.

The darkhaven wiki has very little information on this unit. I think that the flash chip is the one labelled HN4668GC, but I have been unable to find a datasheet for it.

However, Netgear's telnetEnable utility works with the Gearguy/Geardog combo, and I was able to get some info. I'm not sure whether this helps anyone, or if there's some specific commands I can use to get suitable information.

Notably, "dmesg" and "uname" don't appear to work. What I was able to get was:

# lsmod
Module                  Size  Used by
MultiSsidControl         816   0 (unused)
br_dns_hijack          11456   0 (unused)
br_dhcp_filter          1744   0 (unused)
acos_nat              428736   0 (unused)
wl_high              1178160   0 (unused)
ehci-hcd               26560   0 (unused)
usb-storage            26928   0 (unused)
usbcore                77680   1 [wl_high ehci-hcd usb-storage] 
wl                   2325344   0 (unused)
dpsta                   3616   0 [wl_high wl] 
et                     54912   0 (unused)
igs                    15648   0 [wl] 
emf                    20112   0 [wl igs] 
ctf                    12416   0 (unused)
# cat /proc/mtd 
dev:    size   erasesize  name
mtd0: 00040000 00010000 "boot"
mtd1: 00700000 00010000 "linux"
mtd2: 0065d758 00010000 "rootfs"
mtd3: 00010000 00010000 "ML1"
mtd4: 00010000 00010000 "ML2"
mtd5: 00010000 00010000 "ML3"
mtd6: 00010000 00010000 "ML4"
mtd7: 00010000 00010000 "ML5"
mtd8: 00010000 00010000 "ML6"
mtd9: 00010000 00010000 "ML7"
mtd10: 00010000 00010000 "T_Meter1"
mtd11: 00010000 00010000 "T_Meter2"
mtd12: 00010000 00010000 "POT"
mtd13: 00010000 00010000 "board_data"
mtd14: 00010000 00010000 "nvram"
# mount
rootfs on / type rootfs (rw)
/dev/root on / type squashfs (ro)
none on /dev type devfs (rw)
proc on /proc type proc (rw)
ramfs on /tmp type ramfs (rw)
none on /proc/bus/usb type usbdevfs (rw)

So, it looks like mtd2 is larger than 4MB.

If there's anything else I can do to provide useful info, please let me know. I would really love to get OpenWRT on here.

Mycohl: I missed your message.

It looks like something we could try to support, with limited WiFi of course. Can you provide output of:

nvram get board_id
nvram show | grep gpio


I'm also interested in seeing this device supported.

Here are the requested details:

✔ ~/workspace/netgear/netgear-telenetenable [master|✔]                  
11:26 $ python 4C60DE2***** Gearguy Geardog
Sent telnet enable payload to ''                         
✔ ~/workspace/netgear/netgear-telenetenable [master|✔]                  
11:26 $ telnet                                             
Connected to                                              
Escape character is '^]'.                                               
BusyBox v0.60.0 (2012.05.28-02:09+0000) Built-in shell (msh)            
Enter 'help' for a list of built-in commands.                           
# nvram get board_id                                                    
# nvram show | grep gpio                                                
size: 26735 bytes (38801 left)                                          

Here are some additional details:

# cat /proc/cpuinfo                                   
system type             : Broadcom BCM5357 chip rev 2
processor               : 0                          
cpu model               :  V4.9                      
BogoMIPS                : 264.60                     
wait instruction        : no                         
microsecond timers      : yes                        
tlb_entries             : 64                         
extra interrupt vector  : no                         
hardware watchpoint     : yes                        
VCED exceptions         : not available              
VCEI exceptions         : not available              
unaligned_instructions  : 170984                     
System clocks                                        
  (cpu/mem/si/xtal)     : 530/176/88/20 Mhz.         

# cat /proc/meminfo                                         
        total:    used:    free:  shared: buffers:  cached:
Mem:  64266240 27574272 36691968        0  3194880 11169792
Swap:        0        0        0                           
MemTotal:        62760 kB                                  
MemFree:         35832 kB                                  
MemShared:           0 kB                                  
Buffers:          3120 kB                                  
Cached:          10908 kB                                  
SwapCached:          0 kB                                  
Active:           5824 kB                                  
Inactive:        11096 kB                                  
HighTotal:           0 kB                                  
HighFree:            0 kB                                  
LowTotal:        62760 kB                                  
LowFree:         35832 kB                                  
SwapTotal:           0 kB                                  
SwapFree:            0 kB                                  

# df -h                                                           
Filesystem                Size      Used Available Use% Mounted on
rootfs                    3.4M      3.4M         0 100% /         
/dev/root                 3.4M      3.4M         0 100% /         

I would also be very interested in getting my WN2500RP changed into an OpenWRT device! :-)

Great work! I've got OpenWRT running on my WN2500RP, including Luci. But unfortunately it does not detect any WiFi device. I've tried several WiFi drivers listed here … om.bcm47xx, but all i get is either nothing or an error message in the kernel log.

Does anybody have an idea how to get WiFi work on this device?

OK, I've tried some more. According to the WN2500RPv1 has two WiFi-Chips:
- Broadcom BCM5358UB0 for 2.4 GHz
- Broadcom BCM43236 for 5 GHz … /brcm80211 tells us that the BCM43236 ref. 3 (BCM43236B) is supported by the brcmfmac kernel module. Unfortunately, we have ref. 1 or 2.

According to … 24762.html the BCM5358UB0 (N-PHY rev 9) is also not supported by the broadcom-wl driver.

So it seems that OpenWRT is running on this device, but there is no chance to get WiFi working...

I have a Netgear WN2500RPv2, and am also interested in getting OpenWRT running on this.  If a developer wants someone to work with, please get in touch with me.

Hey Guys,

Any new developments? would be awesome to get it running on wn2500rp

I'm also interested in putting some custom firmware on the WN2500RPv2. From what I've read here, it sounds like it can be a 4-port wired router with wrt but the wifi won't work? I'd be interested if it can still function as repeater of wifi with custom fw, because the default settings say that you can only map one band at a time to ethernet. I want to get 2.4ghz band from one network, and 5ghz from another, then use the internet on over ethernet basically using the WN2500RPv2 to bridge 2 wifi networks into one ethernet connection. Heck, even just having it map dual bands to ethernet from 1 network should give it much better performance and reliability that the current implementation.

The discussion might have continued from here.