OpenWrt Forum Archive

Topic: Newer Lantiq VR9 support

The content of this topic has been archived on 18 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I've been running Barrier Breaker on an ECI /r modem from Openreach.  It is running as a router and also an end point for an HE IPv6 tunnel.

Astoria Networks have released newer firmware and support software in their EasyBox 904 source.  I've updated my local Barrier Breaker to use this and it's been running well.  Has anyone else tried this newer version??

drv_dsl_cpe_api_vrx-4.11.11.tar.gz
drv_mei_cpe-1.2.1.tar.gz
dsl_cpe_control_vrx-4.11.11.tar.gz
dsl_vr9_firmware_xdsl-05.05.01.07.01.06_05.05.03.03.01.02.tar.gz

Would be good to see added to buildroot for the lantiq vr9 builds.

Could I ask how updated your build from the current:
{drv_dsl_cpe_api_vrx-4.11.4.tar.gz  drv_mei_cpe-1.2.0.tar.gz  dsl_cpe_control_vrx-4.11.4.tar.gz}

To the later EasyBox source.
drv_dsl_cpe_api_vrx-4.11.11.tar.gz  drv_mei_cpe-1.2.1.tar.gz  dsl_cpe_control_vrx-4.11.11.tar.gz

Did try replacing the files in dl and editing mei patch & make files of 4.14.4 but  failed to get sync.

Help would be most welcome!

Thanks !

(Last edited by vrx200 on 2 Jun 2014, 23:25)

Starting with the latest Barrier Breaker from GIT you can make the changes that I did with the patch at lantiq-update.patch.gz.  Then just copy the new files

drv_dsl_cpe_api_vrx-4.11.11.tar.gz
drv_mei_cpe-1.2.1.tar.gz
dsl_cpe_control_vrx-4.11.11.tar.gz

into the dl subdir.  Configure and compile.  Then get the firmware from

dsl_vr9_firmware_xdsl-05.05.01.07.01.06_05.05.03.03.01.02.tar.gz

which needs to be available as /lib/firmware/vdsl.bin.

Looks like just about what you've done.  There might be some bits in my config since I tend to enable all the available Lantiq stuff which is not the case by default.  You can get my config from openwrt.config.gz.  However since I usually prefer command line there is no web interface there.  It's a slightly oversized image too, but works OK with Asbokid's autoboot setup.

Let me know how you get on with it.

Hi
Could I ask for a little help with the network files.

All the other kernel files work and build successfully. smile

As soon as I change either  package/network/config/ltq-vdsl-app/Makefile   or the  package/network/config/ltq-vdsl-app/patches/100-compat.patch   the build fails at patch 100.

Any guidance , example or  copies of the two ltq-vdsl-app files would be very welcome.

Thanks again!

Well firstly is my patch applying OK?  In the openwrt root directory this should be done by the command

zcat lantiq-update.patch.gz | patch -p1

Once that's been done it should compile OK.  What errors are you getting?  What source are you patching?

Thanks for getting back.

Changed to the back up laptop (Ubuntu) system & manually went through each file change and it worked first time. (grrr- hence the removal of the post earlier)

Its the patch 100  {package/network/config/ltq-vdsl-app/patches/100-compat.patch} that seems to be causing the issue.

I'll jump back to main system tommorrow and  report back with the info

Thanks!

(Last edited by vrx200 on 6 Jun 2014, 03:21)

Just a quick update to say your patch works no problem on most versions of Linux.

[The issue looks like it was down to something with the cross compiler on the other system- It's working now )

Thanks again for the patch & Help smile

Appreciated!

(Last edited by vrx200 on 6 Jun 2014, 20:04)

I've been running the VG3503J-V2 with OpenWRT r40773 on Telecom Italia's ADSL2+ network. It has been running stable for 3 weeks now, much better than what I was expecting lacking 'official' OpenWRT support.

Has anybody else attempted to set the SNR margin (locs command in vdsl_cpe_control). With the default OpenWRT build it doesn't seem to work, but I'm not sure if that's a problem with the firmware or perhaps limitations of the DSLAM.

I'll try to build an image with your patches for the newer version (thanks!) and report back.

narotic wrote:

I've been running the VG3503J-V2 with OpenWRT r40773 on Telecom Italia's ADSL2+ network. It has been running stable for 3 weeks now, much better than what I was expecting lacking 'official' OpenWRT support.

Interesting to see that the code is working for you.  You can see in git that blogic has put in a lot of time on the Lantiq support.

narotic wrote:

Has anybody else attempted to set the SNR margin (locs command in vdsl_cpe_control). With the default OpenWRT build it doesn't seem to work, but I'm not sure if that's a problem with the firmware or perhaps limitations of the DSLAM.

I haven't tried setting the target noise margin with locs.  Seems the value you need to provide is a change in noise margin value, and I would guess multiplied by 10.  So to reduce target noise margin by 1.5dB would be locs 0 -15.  I'm going to try to see if BT's DLM will notice my line has become stable and see what it does.

narotic wrote:

I'll try to build an image with your patches for the newer version (thanks!) and report back.

Thanks for trying it.  It's mostly a matter of updating source code versions and hash values.  Just one thing.  Could you please run the following on you router with the current firmware?

opkg list | grep ltq-

  That would be quite helpful as I've really focused on the VDSL support side.

(Last edited by Kronos2001 on 7 Jun 2014, 23:32)

Kronos2001 wrote:

Interesting to see that the code is working for you.  You can see in git that blogic has put in a lot of time on the Lantiq support.

Absolutely, and his efforts are greatly appreciated! As well as those of others (particularly on kitz.co.uk).

Kronos2001 wrote:

I haven't tried setting the target noise margin with locs.  Seems the value you need to provide is a change in noise margin value, and I would guess multiplied by 10.  So to reduce target noise margin by 1.5dB would be locs 0 -15.  I'm going to try to see if BT's DLM will notice my line has become stable and see what it does.

I have tried various negative and positive values up to -100, but always end up with the same SNRM. Don't forget to resync after changing the value (acs 2).

Kronos2001 wrote:

Thanks for trying it.  It's mostly a matter of updating source code versions and hash values.  Just one thing.  Could you please run the following on you router with the current firmware?

opkg list | grep ltq-

  That would be quite helpful as I've really focused on the VDSL support side.

root@modem:~# opkg list | grep ltq
kmod-ltq-atm-vr9 - 3.10.36-1
kmod-ltq-ifxos - 3.10.36+1.5.14-3
kmod-ltq-ptm-vr9 - 3.10.36-1
kmod-ltq-vdsl-vr9 - 3.10.36+4.11.4-1
kmod-ltq-vdsl-vr9-mei - 3.10.36+1.2.0-1
ltq-vdsl-app - 4.11.4-1

I wouldn't really need both atm and ptm kernel modules, but I can spare a couple of bytes and will be ready when VDSL will finally arrive here (if ever). Firmware is version 5.5.2.0.1.1 by the way; the newer version linked here did not work on my device.

For completeness: I'm using it as a pure modem in bridge mode, where my OpenWRT router handles the pppoe connection. There were earlier reports that such a setup was problematic, but it works ok here.

Your patch compiles without problems on r41051 and seems to run fine. Do you plan a pull request for OpenWRT?

The new firmware (5.5.3.3.1.2) doesn't work for me however: the modem reports an exception and doesn't sync. Since the Vodafone EasyBox 904 xDSL is used in Germany, I suspect the firmware is only suited for Annex B.

Trying to make some config changes before going live on the vdsl.

Keep getting:

/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xrx200/ltq-ptm-vr9/ifxmips_ptm_vdsl.c:281:ptm_hard_start_xmit: not in showtime 

Any tips on how to stop this repeating over and over to allow some configs before connecting .
Or maybe I've got something missing in the build?

Thanks again!

(Last edited by vrx200 on 16 Jun 2014, 17:09)

I get this problem as well.  All it means is that it's trying to send data out through the VDSL connection, ptm0, before the connection is made.  showtime means that connection has been made and is ready.  It might be possible to fix this with dependencies in the init system, but I don't know what would be needed for that.

Quick update with this.

So far so good , nice  stable a joy to use...... Thanks kronos!

Run simply in bridge mode config interface 'lan'

Lan1 ------------------------> router wan
Lan2 --->5 port switch---> router lan

Is there a way to configure lan2 to aviod the 5 port switch on a router such as the hh4/hh5?

Something like the unlocked HG612 does with PTM1.301 or a 192.168.1.2 ip option like the standard unlocked eci/r patch ?

Tried various switch configs and vlans options but no joy as of yet.

Worked through http://wiki.openwrt.org/doc/uci/network  & http://wiki.openwrt.org/doc/uci/network/switch 
No luck as of yet . { Networking is not a strong point & probably doing something silly }


Any help , pointers would be most welcome!
Thank again for the help!

(Last edited by vrx200 on 9 Aug 2014, 03:14)

vrx220, I suspect we're after the same thing - I started a post below:

https://forum.openwrt.org/viewtopic.php?id=52358

The aspect that confused me, I can find OpenWRT boot logs (On the Kitz thread) that are supposedly running the same hardware version as me, and yet they see eth0 and eth1 in their boot logs?

The default ECI firmware seems to assign VLAN 102 to the bridge interface, i.e br0.102, when you activate the second port.  Need to find some time to have a play with OpenWRT using a similar concept.

Hi

First I tried this:
http://simplebeian.wordpress.com/2014/0 … rt-router/

Then I also noticed the old builds eth0/eth1 like you.

The old dts files used to have two interface options hence the etho & eth1 in earlier builds.

old lantiq .dts-files

+++@92 & 107
lan1: interface@0 
lan2: interface@1 

This seem to have caused a load of put through issues highlighted on the kitz thread.  {Maybe due to etop reisters ?}

You could try adding the oem switch_utility into the build  ifx_ethsw /switch_utility thats is in the openreach glp files.
http://www.openreach.co.uk/orpg/home/pr … andrgnu.do

Another option is to try current openwrt xway switch into the dts files.
Add lantiq,switch; on line 98 into the file.

 target/linux/lantiq/dts/VG3503J.dtsi
++98 
lantiq,switch;

Not had much luck with it yet or really the time to play around.  Also networking is not a strong point of mine.

root@OpenWrt:/# swconfig dev switch0 help
switch0: eth0(Lantiq XRX200 Switch), ports: 7 (cpu @ 6), vlans: 64
     --switch
        Attribute 1 (int): enable_vlan (Enable VLAN mode)
        Attribute 2 (none): apply (Activate changes in the hardware)
        Attribute 3 (none): reset (Reset the switch)
     --vlan
        Attribute 1 (int): vid (VLAN ID (0-4094))
        Attribute 2 (int): enable (Enable VLAN)
        Attribute 3 (ports): ports (VLAN port mapping)
     --port
        Attribute 1 (int): uvr (Unknown VLAN Rule)
        Attribute 2 (int): vsr (VLAN Security Rule)
        Attribute 3 (int): vinr (VLAN Ingress Tag Rule)
        Attribute 4 (int): tvm (Transparent VLAN Mode)
        Attribute 5 (int): pvid (Primary VLAN ID)
        Attribute 6 (string): link (Get port link information)

root@OpenWrt:/# swconfig dev switch0 show
Global attributes:
        enable_vlan: 0
Port 0:
        uvr: 0
        vsr: 0
        vinr: 0
        tvm: 0
        pvid: 1
        link: port:0 link:down
Port 1:
        uvr: 0
        vsr: 0
        vinr: 0
        tvm: 0
        pvid: 1
        link: port:1 link:down
Port 2:
        uvr: 0
        vsr: 0
        vinr: 0
        tvm: 0
        pvid: 1
        link: port:2 link:up speed:100baseT full-duplex auto
Port 3:
        uvr: 0
        vsr: 0
        vinr: 0
        tvm: 0
        pvid: 1
        link: port:3 link:down
Port 4:
        uvr: 0
        vsr: 0
        vinr: 0
        tvm: 0
        pvid: 1
        link: port:4 link:up speed:100baseT full-duplex auto
Port 5:
        uvr: 0
        vsr: 0
        vinr: 0
        tvm: 0
        pvid: 1
        link: port:5 link:down
Port 6:
        uvr: 0
        vsr: 0
        vinr: 0
        tvm: 0
        pvid: 1
        link: port:6 link:up speed:1000baseT full-duplex auto
VLAN 1:
        vid: 1
        enable: 1
        ports: 0 1 2 3 4 5 6
root@OpenWrt:/# 

Hope this helps as your scripting software would be ideal addition to these eci'r

(Last edited by vrx200 on 27 Aug 2014, 18:12)

Cool, thanks.

"Software" might be going a bit far, I hacked together a modification to the muninlite package in the OpenWRT opkg repo - from bugmancx's HG612 munin templates on github  - can now graph the basics using a munin instance elsewhere.

I just edited the munin-node script /usr/sbin/munin-node to include the below, after installing muninlite on the ECI:

fetch_dsl() {
  echo "dsl_dw_att_data_rate.value" $(grep "Attain Data Rate" /tmp/dsl.txt |cut -d:  -f2|cut -d\  -f1)
  echo "dsl_up_att_data_rate.value" $(grep "Attain Data Rate" /tmp/dsl.txt |cut -d:  -f2|cut -d\  -f4)
  echo "dsl_dw_act_data_rate.value" $(grep "Actual Data Rate" /tmp/dsl.txt |cut -d:  -f2|cut -d\  -f1)
  echo "dsl_up_act_data_rate.value" $(grep "Actual Data Rate" /tmp/dsl.txt |cut -d:  -f2|cut -d\  -f4)
}

  
config_dsl() {
  echo "graph_title Attainable vs Actual"
  echo "graph_category dsl"
  echo "graph_args --base 1000"
  echo "graph_scale yes"
  echo "graph_vlabel Actual (-) Attainable (+)"
  echo 'dsl_dw_act_data_rate.label Act. Down'
  echo 'dsl_dw_act_data_rate.draw LINE'
  echo 'dsl_dw_act_data_rate.graph no'
  echo 'dsl_up_act_data_rate.label Act. Up'
  echo 'dsl_up_act_data_rate.draw LINE'
  echo 'dsl_up_act_data_rate.graph no'
  echo 'dsl_dw_att_data_rate.label Downstream'
  echo 'dsl_dw_att_data_rate.draw AREA'
  echo 'dsl_dw_att_data_rate.negative dsl_dw_act_data_rate'
  echo 'dsl_up_att_data_rate.label Upstream'
  echo 'dsl_up_att_data_rate.draw AREA'
  echo 'dsl_up_att_data_rate.negative dsl_up_act_data_rate'
}



fetch_dsl_errors() {
  echo "dsl_dw_fec_err.value" $(grep ^"FEC Errors" /tmp/dsl.txt |cut -d:  -f2|cut -d\  -f1)
  echo "dsl_up_fec_err.value" $(grep ^"FEC Errors" /tmp/dsl.txt |cut -d:  -f2|cut -d\  -f3)
  echo "dsl_dw_crc_err.value" $(grep ^"CRC_P Errors" /tmp/dsl.txt |cut -d:  -f2|cut -d\  -f1)
  echo "dsl_up_crc_err.value" $(grep ^"CRC_P Errors" /tmp/dsl.txt |cut -d:  -f2|cut -d\  -f3)
}

config_dsl_errors() {
  echo "graph_title Errors"
  echo "graph_category dsl"
  echo "graph_args --base 1000"
  echo 'graph_vlabel errors down (-) / up (+) per ${graph_period}'
  echo "graph_scale no"
  echo "dsl_dw_crc_err.label CRC errors"
  echo "dsl_dw_crc_err.type DERIVE"
  echo "dsl_dw_crc_err.graph no"
  echo "dsl_up_crc_err.label CRC errors"
  echo "dsl_up_crc_err.type DERIVE"
  echo "dsl_up_crc_err.negative dsl_dw_crc_err"
  echo "dsl_up_crc_err.info Errors received"
  echo "dsl_dw_fec_err.label FEC errors"
  echo "dsl_dw_fec_err.type DERIVE"
  echo "dsl_dw_fec_err.graph no"
  echo "dsl_up_fec_err.label FEC errors"
  echo "dsl_up_fec_err.type DERIVE"
  echo "dsl_up_fec_err.negative dsl_dw_fec_err"
  echo "dsl_up_fec_err.info Errors received"      
}     


fetch_dsl_line_att() {
  echo "dsl_line_att.value" $(grep ^"Line Attenuation" /tmp/dsl.txt |cut -d:  -f2|cut -d\  -f1|sed "s/dB//")
}

config_dsl_line_att() {
  echo "graph_title Line Attenuation (dB)"
  echo 'graph_args --base 1000'
  echo 'graph_vlabel Line Attenuation (dB)'
  echo 'graph_category dsl'
  echo 'graph_scale no'
  echo "dsl_line_att.label Line Attenuation"
  echo "dsl_line_att.draw LINE"
}


fetch_dsl_sig_att() {
  echo "dsl_sig_att.value" $(grep ^"Signal Attenuation" /tmp/dsl.txt |cut -d:  -f2|cut -d\  -f1|sed "s/dB//")
}

config_dsl_sig_att() {
  echo "graph_title Signal Attenuation (dB)"
  echo 'graph_args --base 1000'
  echo 'graph_vlabel Signal Attenuation (dB)'
  echo 'graph_category dsl'
  echo 'graph_scale no'
  echo "dsl_sig_att.label Signal Attenuation"
  echo "dsl_sig_att.draw LINE"
}
 

fetch_dsl_int_dep() {
  echo "dsl_dw_int_dep.value" $(grep ^"Interleave Depth" /tmp/dsl.txt |cut -d:  -f2|cut -d\  -f1)
  echo "dsl_up_int_dep.value" $(grep ^"Interleave Depth" /tmp/dsl.txt |cut -d:  -f2|cut -d\  -f3)
}

config_dsl_int_dep() {  
  echo 'graph_title Interleave Depth'
  echo 'graph_args --base 1000'
  echo 'graph_vlabel Interleave Depth'
  echo 'graph_category dsl'
  echo 'graph_scale no'
  echo 'dsl_dw_int_dep.label Downstream'
  echo 'dsl_dw_int_dep.draw LINE'
  echo 'dsl_up_int_dep.label Upstream'
  echo 'dsl_up_int_dep.draw LINE'
}


fetch_dsl_noise() {
  echo "dsl_dw_noise.value" $(grep ^"Noise Margin" /tmp/dsl.txt |cut -d:  -f2|cut -d\  -f1|sed "s/dB//")
  echo "dsl_up_noise.value" $(grep ^"Noise Margin" /tmp/dsl.txt |cut -d:  -f2|cut -d\  -f3|sed "s/dB//")
}

config_dsl_noise() {  
  echo 'graph_title Noise Margin (dB)'
  echo 'graph_args --base 1000'
  echo 'graph_vlabel Noise Margin (dB)'
  echo 'graph_category dsl'
  echo 'graph_scale no'
  echo 'dsl_dw_noise.label Downstream'
  echo 'dsl_dw_noise.draw LINE'
  echo 'dsl_up_noise.label Upstream'
  echo 'dsl_up_noise.draw LINE'
} 
 
  
fetch_dsl_tran_pwr() {
  echo "dsl_dw_tran_pwr.value" $(grep ^"Transmit power" /tmp/dsl.txt |cut -d:  -f2|cut -d\  -f1|sed "s/dBm//")
  echo "dsl_up_tran_pwr.value" $(grep ^"Transmit power" /tmp/dsl.txt |cut -d:  -f2|cut -d\  -f3|sed "s/dBm//")
}

config_dsl_tran_pwr() {  
  echo 'graph_title Transmit Power (dBm)'
  echo 'graph_args --base 1000'
  echo 'graph_vlabel Transmit Power (dBm)'
  echo 'graph_category dsl'
  echo 'graph_scale no'
  echo 'dsl_dw_tran_pwr.label Downstream'
  echo 'dsl_dw_tran_pwr.draw LINE'
  echo 'dsl_up_tran_pwr.label Upstream'
  echo 'dsl_up_tran_pwr.draw LINE'
} 

Then enable cron:

/etc/init.d/cron enable
/etc/init.d/cron start

Add the following cron entry:

*/5 * * * *   /etc/init.d/dsl_control status > /tmp/dsl.txt

Then point your munin instance at the ECI's LAN IP.  Quick and very dirty, but gives me some stats.  I messed around with rebuilding OpenWRT to include busybox login, so that telnet could be enabled again, but ultimately settled on just using muninlite a) because I already have munin running b) I'd rather use something dedicated rather than running a desktop app. smile

Excellent Thanks! {off the take a look smile}

If you do {or anyone else reading}  manage  to find a  lan1 & lan2 set up  similar the hg612, could post a how to.....as it would be very welcome!

Its been niggling me for a while lan1 ptm101 &  lan2 ptm103 grrrr.

 {From asbokids hg612 work /blog}
We see there are two Ethernet VLAN’s being presented down the VDSL PTM link, one which gets bridged directly through to the internal ‘LAN1' port on the Huawei device. This is our internet connection, which gets tagged with VLAN tag 101 on the PTM link.

However, there is another connection, VLAN301, which terminates on the Huawei device itself; If you click around the Huawei web interface, you’ll find a DHCP client expects to get an IP address from this VLAN, providing a control network for the HG216 to run TR-069 autoconfiguration.

https://en.wikipedia.org/wiki/TR-069

Because the existing PTM1.301 interface isnt a bridge it’s IP terminated, I couldn’t find any way of bridging this VLAN directly to a laptop via the ‘unused’ LAN2 port (that you’ll be familiar with if you’ve updated the firmware on your Huawei device, as it’s this port that is configured on 192.168.1.1/24 for the web interface and telnet access).

However, it can be done through the CLI;

using brctl command after logging in via telnet and typing ‘shell’, you can end up with the PTM1.301 interface bridged to the physical LAN2

Thanks!

(Last edited by vrx200 on 27 Aug 2014, 20:58)

Another option could be to try two interfaces eth0 & eth1.
The phy 11g's have been patched so it might not suffer the put though issues.

Add an extra interface  eth0 & eth1 interface in the dtsi file.

 target/linux/lantiq/dts/VG3503J.dtsi
eth@E108000 {
            #address-cells = <1>;
            #size-cells = <0>;
            compatible = "lantiq,xrx200-net";
            reg = <    0xE108000 0x3000 /* switch */
                0xE10B100 0x70 /* mdio */
                0xE10B1D8 0x30 /* mii */
                0xE10B308 0x30 /* pmac */
            >;
            interrupt-parent = <&icu0>;
            interrupts = <73 72>;
                        
            lan1: interface@0 {
                compatible = "lantiq,xrx200-pdi";
                #address-cells = <1>;
                #size-cells = <0>;
                reg = <0>;
                mac-address = [ 00 11 22 33 44 55 ];
                ethernet@4 {
                    compatible = "lantiq,xrx200-pdi-port";
                    reg = <4>;
                    phy-mode = "mii";
                    phy-handle = <&phy13>;
                };
            };
                       
                        lan2: interface@1 {
                    compatible = "lantiq,xrx200-pdi";
                #address-cells = <1>;
                #size-cells = <0>;
                reg = <1>;
                mac-address = [ 00 11 22 33 44 56 ];
                          
                                ethernet@2 {
                        compatible = "lantiq,xrx200-pdi-port";
                        reg = <2>;
                        phy-mode = "mii";
                        phy-handle = <&phy11>;
                             };
            };
 

(Last edited by vrx200 on 29 Aug 2014, 22:47)

could any1 give info step by step how turn on VDSL (RJ11)  on tplink 8970
on ATM mode...i get synchro but cant connect...nothin happen

on PTM no synchro my config is:

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd1d:62de:db00::/48'

config interface 'lan'
option ifname 'eth0'
option force_link '1'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option macaddr 'e8:de:27:bc:d0:ba'
option ipaddr '192.168.1.2'
option gateway '192.168.1.1'

config interface 'wan'
option _orig_bridge 'false'
option ifname 'ptm0.35'
option proto 'pppoe'
option username 'neostrada.pl'
option password 'a'

config interface 'wan6'
option ifname '@wan'
option proto 'dhcpv6'

config vdsl 'dsl'
option annex 'a'
option firmware '/lib/firmware/vdsl.bin'
option tone 'av'
option xfer_mode 'ptm'

patch który dałes: root@OpenWrt:/tmp# zcat lantiq-update.patch.gz | patch -p1
-ash: patch: not found
root@OpenWrt:/tmp#

after delete kmod-adsl
Tue Sep 9 17:53:42 2014 user.emerg syslog: Failed to find ltq_ptm_vr9. Maybe it is a built in module ?

(Last edited by deckso on 9 Sep 2014, 22:12)

You need to manually add the lantiq vdsl driver into the /lib/firmware either at build stage or via scp (Secure Copy)  if openwrt is already installed  on the modem.

Also make sure to  install  the correct vdsl firmware for your providers band plan profiles:

The following shows the band profile and band plan compatibility:
Band Profile List Band Plan List
0 VDSL2 Profile8a 0 Annex A M1_EU32
1 VDSL2 Profile8b 1 Annex A M9_EU64
2 VDSL2 Profile8c 2 Annex A EU128
3 VDSL2 Profile8d 3 Annex B 997-M1c-A-7
4 VDSL2 Profile12a 4 Annex B 997-M2x-A
5 VDSL2 Profile12b 5 Annex B 997-M2x-M
6 VDSL2 Profile17a 6 Annex B 998-M1x-A
7 VDSL2 Profile30a 7 Annex B 998-M1x-B
8 VDSL2 Profile17b 8 Annex B 998-M2x-A
                   9 Annex B 998-M2x-M
                   10 Annex B 998-M2x-B
                   11 Annex B 998-M2x-NUS0
                   12 Annex B 998e17-M2x-NUS0
                   13 Annex B 998ADE17-M2x-A
                   14 Annex B 998ADE30-M2x-JUS0
                   15 Annex C_A
                   16 Annex C_M
                   17 Annex C_8K

In Kronos's first post example  dsl_vr9_firmware  is  _xdsl-05.05.01.07.01.06 <-vdsl part| _ | adsl part ->05.05.03.03.01.02
The last digit in the first number string represents the profile & plan, which in this case  is : 17a  Annex B 998-M1x-A.

(Last edited by vrx200 on 10 Sep 2014, 02:00)

i found how to make it work on different router  (there is all info about config)
ftp://ftp.draytek.pl/POMOC/Gotowe_przyk … aFiber.pdf


i have it - lib/firmware/vdsl.bin
my profile is:  VDSL2 Profile17a 6 Annex B 998-M1x-A
file name: dsl_vr9_firmware_xdsl-05.06.00.08.01.06_05.05.02.00.01.01 it should be ok ?
i dont get synchro on PTM moze.... but on ATM mode... i have synchro... but cant connect...cant do nothin...
Status: UP
Line State: showtime_tc_sync [0x801]
Line Speed: 66.112 Mb/s / 8.568 Mb/s
Line Attenuation: 18.2 dB / 0 dB
Noise Margin: 9 dB / 8.3 dB


i read that i need VLAN ID : 35.... how to make it work ?

Has kmod-ltq-ptm-vr9 been definitenly ticked in the build root?

root@modem:~# opkg list | grep ltq-

If everything is installed as it should be try the double check the firewall settings for the vlan.

http://openrouter.info/forum/viewtopic. … d1582c4744

(Last edited by vrx200 on 10 Sep 2014, 20:47)

root@OpenWrt:~# opkg list | grep ltq-
kmod-ltq-atm-vr9 - 3.10.49-1
kmod-ltq-deu-vr9 - 3.10.49-1
kmod-ltq-hcd-vr9 - 3.10.49-1
kmod-ltq-ifxos - 3.10.49+1.5.14-3
kmod-ltq-vdsl-vr9 - 3.10.49+4.11.4-1
kmod-ltq-vdsl-vr9-mei - 3.10.49+1.2.0-1
ltq-vdsl-app - 4.11.4-1
ltq-vdsl-vr9-fw-installer - 1-1

im newbe please give command and i will g0ive answer


on this site guys dont know yet whats up sad

(Last edited by deckso on 10 Sep 2014, 20:53)