OpenWrt Forum Archive

Topic: Broadcom 963168VX_P400 network configuration

The content of this topic has been archived on 25 Mar 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi all,

I have managed to flash OpenWRT to my 963168VX_P400 board, however I can't seem to ping 192.168.1.1 and access the control panel.
I'm using a serial cable to flash/observe.

This is the bootlog:

*** Press any key to stop auto run (1 seconds) ***
Auto run second count down: 0
Booting from latest image (0xb8010000) ...
Code Address: 0x80010000, Entry Address: 0x80010000
LZMA: Prossible old LZMA format, trying to decompress..
Decompression OK!
Entry at 0x80010000
Starting program at 0x80010000
[    0.000000] Linux version 3.10.36 (thom@thom-laptop) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r41006) ) #13 Thu Jun 5 15:10:25 BST4
[    0.000000] Detected Broadcom 0x63268 CPU revision d0
[    0.000000] CPU frequency is 400 MHz
[    0.000000] 128MB of RAM installed
[    0.000000] registering 52 GPIOs
[    0.000000] board_bcm963xx: Boot address 0xb8000000
[    0.000000] board_bcm963xx: CFE version: 1.0.38-116.17
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 0002a080 (Broadcom BMIPS4350)
[    0.000000] board_bcm963xx: board name: 963168VX_P400
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 08000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x07ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x07ffffff]
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 16 bytes.
[    0.000000] Primary data cache 32kB, 2-way, VIPT, cache aliases, linesize 16 bytes
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 32512
[    0.000000] Kernel command line:  root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200
[    0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
[    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
[    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Memory: 126344k/131072k available (2346k kernel code, 4728k reserved, 618k data, 296k init, 0k highmem)
[    0.000000] NR_IRQS:256
[    0.000000] Calibrating delay loop... 397.82 BogoMIPS (lpj=795648)
[    0.032000] pid_max: default: 32768 minimum: 301
[    0.036000] Mount-cache hash table entries: 512
[    0.044000] NET: Registered protocol family 16
[    0.056000] bio: create slab <bio-0> at 0
[    0.060000] Switching to clocksource MIPS
[    0.068000] NET: Registered protocol family 2
[    0.072000] TCP established hash table entries: 1024 (order: 1, 8192 bytes)
[    0.080000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.084000] TCP: Hash tables configured (established 1024 bind 1024)
[    0.092000] TCP: reno registered
[    0.096000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.100000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.108000] NET: Registered protocol family 1
[    0.116000] audit: initializing netlink socket (disabled)
[    0.120000] type=2000 audit(0.120:1): initialized
[    0.124000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.132000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.144000] msgmni has been set to 246
[    0.148000] io scheduler noop registered
[    0.152000] io scheduler deadline registered (default)
�[    0.164000] console [ttyS0] enabled, bootconsole disabled= 13) is a bcm63xx_uart
[    0.164000] console [ttyS0] enabled, bootconsole disabled
[    0.180000] bcm63xx-spi bcm63xx-spi: at 0xb0000800 (irq 88, FIFOs size 542)
[    0.188000] m25p80 spi1.0: found mx25l25635e, expected m25p80
[    0.196000] m25p80 spi1.0: mx25l25635e (32768 Kbytes)
[    0.200000] bcm63xxpart: CFE boot tag found with version 6 and board type 963268BU_P300
[    0.208000] bcm63xxpart: Partition 0 is CFE offset 0 and length 10000
[    0.216000] bcm63xxpart: Partition 1 is kernel offset 10100 and length 10ff00
[    0.224000] bcm63xxpart: Partition 2 is rootfs offset 120000 and length 1ed0000
[    0.228000] bcm63xxpart: Partition 3 is nvram offset 1ff0000 and length 10000
[    0.236000] bcm63xxpart: Partition 4 is linux offset 10000 and length 1fe0000
[    0.244000] bcm63xxpart: Spare partition is offset 310004 and length 1cdfffc
[    0.252000] 5 bcm63xxpart partitions found on MTD device spi1.0
[    0.256000] Creating 5 MTD partitions on "spi1.0":
[    0.264000] 0x000000000000-0x000000010000 : "CFE"
[    0.268000] 0x000000010100-0x000000120000 : "kernel"
[    0.276000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.288000] 0x000000120000-0x000001ff0000 : "rootfs"
[    0.296000] mtd: device 2 (rootfs) set to be root filesystem
[    0.300000] mtd: partition "rootfs_data" created automatically, ofs=0x310000, len=0x1ce0000
[    0.312000] 0x000000310000-0x000001ff0000 : "rootfs_data"
[    0.316000] 0x000001ff0000-0x000002000000 : "nvram"
[    0.324000] 0x000000010000-0x000001ff0000 : "linux"
[    0.368000] bcm63xx-wdt bcm63xx-wdt:  started, timer margin: 30 sec
[    0.376000] TCP: cubic registered
[    0.380000] NET: Registered protocol family 17
[    0.384000] 8021q: 802.1Q VLAN Support v1.8
[    0.400000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[    0.412000] Freeing unused kernel memory: 296K (802f6000 - 80340000)
procd: Console is alive
procd: - watchdog -
procd: - preinit -
ifconfig: SIOCGIFFLAGS: No such device
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[    3.268000] Button Hotplug driver version 0.4.1
jffs2 is not ready - marker found
ifconfig: SIOCGIFFLAGS: No such device
procd: - early -
procd: - watchdog -
procd: - ubus -
procd: - init -
Please press Enter to activate this console.
[    8.392000] NET: Registered protocol family 10
[    8.416000] nf_conntrack version 0.5.0 (1978 buckets, 7912 max)
[    8.432000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[    8.448000] ip_tables: (C) 2000-2006 Netfilter Core Team
[    8.508000] xt_time: kernel timezone is -0000
[    8.524000] PPP generic driver version 2.4.2
[    8.532000] NET: Registered protocol family 24
[   16.372000] jffs2_scan_eraseblock(): End of filesystem marker found at 0x0
[   16.388000] jffs2_build_filesystem(): unlocking the mtd device... done.
[   16.392000] jffs2_build_filesystem(): erasing all blocks after the end marker... 


BusyBox v1.22.1 (2014-06-05 12:31:30 BST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

Ping to 192.168.1.1:

root@OpenWrt:/# ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1): 56 data bytes
ping: sendto: Network is unreachable

/etc/config/network

root@OpenWrt:/# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd01:e58b:ddcc::/48'

config interface 'lan'
        option ifname 'eth1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

root@OpenWrt:/# 

ifconfig -a

root@OpenWrt:/# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 02:10:18:78:54:01  
          inet6 addr: fe80::10:18ff:fe78:5401/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:8314 (8.1 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

root@OpenWrt:/# 

My Ubuntu uses a static IP of 192.168.1.100, netmask of 255.255.255.0 and gateway of 192.168.1.1

Another problem I have is that occasionally when I flash it gives me the following error when I boot:

[   11.300000] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00fe0000: 0x8936 instead
[   11.308000] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00fe0004: 0x2728 instead
[   11.320000] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00fe0008: 0x5b5d instead
[   11.328000] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00fe000c: 0xe19f instead
[   11.340000] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00fe0010: 0x2fd2 instead
[   11.348000] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00fe0014: 0x5647 instead
[   11.360000] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00fe0018: 0x308d instead
[   11.368000] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00fe001c: 0xd118 instead
[   11.380000] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00fe0020: 0x6e75 instead
[   11.388000] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00fe0024: 0xad68 instead
[   11.396000] jffs2: Further such events for this erase block will not be printed
[   11.428000] jffs2: Old JFFS2 bitmask found at 0x00fee908
[   11.436000] jffs2: You cannot use older JFFS2 filesystems with newer kernels
[   11.444000] jffs2_scan_eraseblock(): End of filesystem marker found at 0xff0000
[   11.452000] jffs2_build_filesystem(): unlocking the mtd device... done.
[   11.456000] jffs2_build_filesystem(): erasing all blocks after the end marker... 

When I reflash it the error goes away.

cat /proc/mtd (reflashed):

root@OpenWrt:/# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00010000 00010000 "CFE"
mtd1: 0010ff00 00010000 "kernel"
mtd2: 01ed0000 00010000 "rootfs"
mtd3: 01ce0000 00010000 "rootfs_data"
mtd4: 00010000 00010000 "nvram"
mtd5: 01fe0000 00010000 "linux"

Any help/advice/comments/questions are much appreciated!

Thank you!

From the bootlog:

ifconfig: SIOCGIFFLAGS: No such device

Seems to indicate it is failing to detect/probe the eth1 interface, to which your 192.168.1.1/LAN IP is assigned.

I can't find any info on 96318VX_P400 specifically but the closest I found was this:
http://wiki.openwrt.org/toh/zyxel/vmg1312-b30a
Supposedly it has 4 LAN ports and no WAN port (but some 2-port "LAN Transformer"?)

Given that you have an eth port assigned as WAN in your configuration I would suspect the default switch/interface configuration is not correct for your device. What is the actual (true) port configuration on your device?

qasdfdsaq wrote:

From the bootlog:

ifconfig: SIOCGIFFLAGS: No such device

Seems to indicate it is failing to detect/probe the eth1 interface, to which your 192.168.1.1/LAN IP is assigned.

I can't find any info on 96318VX_P400 specifically but the closest I found was this:
http://wiki.openwrt.org/toh/zyxel/vmg1312-b30a
Supposedly it has 4 LAN ports and no WAN port (but some 2-port "LAN Transformer"?)

Given that you have an eth port assigned as WAN in your configuration I would suspect the default switch/interface configuration is not correct for your device. What is the actual (true) port configuration on your device?

There is no WAN port, I'll try to assign the WAN to one of the Ethernet ports now, which might take me a while to do.
These are the ports on the router:
http://maarseveent.com/private/20140605_174504.jpg

It shouldn't take too long. If there is no WAN port then the default two-interface config is the problem. Presumably the four RJ45 ports in your picture are all on one ethernet switch, which goes by the interface of eth0, and eth1 does not exist.

Just change eth1 to eth0 in the lan section and remove the wan section completely.

(Last edited by qasdfdsaq on 6 Jun 2014, 00:13)

qasdfdsaq wrote:

It shouldn't take too long. If there is no WAN port then the default two-interface config is the problem. Presumably the four RJ45 ports in your picture are all on one ethernet switch, which goes by the interface of eth0, and eth1 does not exist.

Just change eth1 to eth0 in the lan section and remove the wan section completely.

Thanks for the help. I tried doing so, I can now ping 192.168.1.1 internally (through serial) but I can't ping it from my computer. (With a static IP of 192.168.1.100, gateway 192.168.1.1)

(Last edited by thom1337 on 13 Jun 2014, 03:48)

Did you try all the ethernet ports or just one? I do suspect that, given the default interface configuration is wrong, the switch configuration may also need tweaking, as, so far, it seems there is no switch config at all. However the bootlog doesn't indicate any detection of a separate switch.

Are you able to do, e.g. wireshark on another machine connected to the router, while pinging anything (e.g. 192.168.1.255) from the serial interface? Does anything come up? Do the network LEDs blink at all?

qasdfdsaq wrote:

Did you try all the ethernet ports or just one? I do suspect that, given the default interface configuration is wrong, the switch configuration may also need tweaking, as, so far, it seems there is no switch config at all. However the bootlog doesn't indicate any detection of a separate switch.

Are you able to do, e.g. wireshark on another machine connected to the router, while pinging anything (e.g. 192.168.1.255) from the serial interface? Does anything come up? Do the network LEDs blink at all?

All of the ethernet ports give the same message:

From 192.168.1.100 icmp_seq=35 Destination Host Unreachable

... and none of the network LEDs come up.

I'm going to give wireshark/switch configuration a try now, thank you!

If the network LEDs don't light up Wireshark is unlikely to help, I'm guessing the switch/ports haven't been initialised properly. Though most routers have a default switch config that just forwards everything out on every port if there is no switch driver installed.

qasdfdsaq wrote:

If the network LEDs don't light up Wireshark is unlikely to help, I'm guessing the switch/ports haven't been initialised properly. Though most routers have a default switch config that just forwards everything out on every port if there is no switch driver installed.

Thanks a lot for all the help, I managed to figure out the problem. I disabled the firewall and everything started working! Going to read the instructions on how to configure it properly tomorrow.

(Last edited by thom1337 on 14 Jun 2014, 02:00)

thom1337 wrote:

Hi all,

I have managed to flash OpenWRT to my 963168VX_P400 board..........

I wonder how you built the image to flash? I have a similar board and have unlocked the CFE. My board id 963268VX. I would like to try building an image from Trunk - openwrt-963168VX-squashfs-cfe.bin

Thank you in anticipation.

The discussion might have continued from here.