OpenWrt Forum Archive

Topic: TP-LINK WDR7500V3 Disassembly

The content of this topic has been archived on 13 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Here's pictures of 7500V3 PCB,

QCA9880-BR4A     AR8372N-BL1A    QCA9558-AT4A 

01
02
03
04
05
06

Download pictures here: http://url.cn/Q1oS26 (weiyun.com)

I have tried to modify a wdr7500v3 firmware as the info blow:

7500v3 firmware info

But it doen't work...
7500v2 openwrt firmware modified

Is there any 7500v3 openwrt firmware available?

can you post a link to a tplink firmware that is (hopefully) accepted by your gui?

nebbia88 wrote:

can you post a link to a tplink firmware that is (hopefully) accepted by your gui?

http://url.cn/O14Lhr

This firmware is accepted by 7500v3. It is downloaded from third party forum, don't know whether it is original from the factory.

I also have this router v3.

I have connected up a TTL cable and have access to the serial console.

I have booted the openwrt ram image from here http://nosferatu.g0x.ru/pub/wdr7500/fir … _ramimage/

which boots successfully. If you need any outputs or diagnosis let me know and I can retrieve them for you.

I managed to flash openwrt archer c7v1 from the 16th to the wdr7500 v3. I preformed the flash from uboot serial console.

The v3 only has 8mb flash

Iamstuck wrote:

I managed to flash openwrt archer c7v1 from the 16th to the wdr7500 v3. I preformed the flash from uboot serial console.

The v3 only has 8mb flash

7500v2 (Chinese version) is 8M flash therefore its firmware possible could be flashed on 7500v3.

I have used serial connection to try a 7500v2 OP firmware on my 7500v3.

ttl fail

uboot seems to be erased.. when flash completed and 7500v3 robooted there was no output in serial connection anymore.

I think I need a ttl tutorial.. or someone please tell me the right command..

tak

(Last edited by auwhere on 24 Jun 2014, 05:53)

auwhere wrote:

http://url.cn/O14Lhr

Can you re-upload this file, plz. Currently it's expired or deleted.

already posted on another thread, but no reply
I try to connect serial console to my 7500 v3, but the console is read-only
R251,R86 and R96 are missing on the PCB. Do I have to solder shortcut or resistor to get the serial working?


[Edit:  problem solved with an external pullup resistor]

(Last edited by sz22 on 15 Sep 2014, 09:44)

auwhere wrote:

uboot seems to be erased.. when flash completed and 7500v3 robooted there was no output in serial connection anymore.

I think I need a ttl tutorial.. or someone please tell me the right command..

tak

With uboot erased, I think the only way to debrick is to directly reflash the SPI flash.
This can be useful:
FlashcatUSB Universal Memory Programmer

watch this thread

i have a idea have WDR7500v3 work with ARCHER C7 v2 openwrt firmware.

Replace a 16MB flash chip and flash a full C7 v2 firmware image. the Question is the *factory.bin image doesn't include some important imformation from oringal image (probebly).

Can any one have a try?

Uboot would also be missing, so you wouldn't be able to boot the router. ART partition would also be missing, which includes wireless calibration data (and I think MAC addresses, amongst other things). You can back up those partitions and include it in the new flash. seems like a lot of work...

(Last edited by drawz on 1 Oct 2014, 05:01)

support is in trunk, regular 15.05 image is on the wiki. Flash through web ui or through tftp.

The discussion might have continued from here.