OpenWrt Forum Archive

Topic: Issues on Barrier Breaker 14.07 RC2 on Asus RT-N56U

The content of this topic has been archived on 16 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello,

I just downloaded and installed Barrier Breaker 14.07 RC2 on Asus RT-N56U after often getting disconnections when using the latest stock firmware that Asus has on its site and also after using Padavan's firmware at https://code.google.com/p/rt-n56u/ .

I downloaded and installed Barrier Breaker from http://downloads.openwrt.org/barrier_br … ps/rt3883/

My issue is that, on 5GHz WIFI, according to http://en.wikipedia.org/wiki/List_of_WL … 29.5B16.5D I can't seem to get 5GHz to run in the regulatory domain for Singapore.

According to the above URL, I should be able to operate on channel 36-64 and 149-165 on 5GHz.
I should be able to use 24dBm for channel 52-64 and for channels 149-165, use 30dBm.

However, LuCI, the web interface, is limiting me to 17dBm.

Is there any legal workaround I can use?

(Last edited by chuacw on 3 Aug 2014, 04:36)

Ok, I've managed to get my 5GHz and 2.4GHz wireless up on my Asus RT-N56U.

Here's the configuration file (/etc/config/wireless):

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:01.0/0000:01:00.0'
        option htmode 'HT20'
        option channel 'auto'
        option txpower '20'
        option country 'SG'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'buffalo'
        option encryption 'psk2'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '10180000.wmac'
        option country 'SG'
        option hwmode '11na'
        option channel 'auto'
        option noscan '1'
        option txpower '17'
        option log_level '0'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'buffalo5G'
        option encryption 'psk2'
        option wmm '0'

Hi, I'm currently running Padavan's firmware, how to flash OpenWRT to RT-N56U?

5GHz support is completed, actually. I've both 2.4GHz and 5GHz enabled on OpenWrt running on my RT-N56U.

For steps on installing OpenWRT on RT-N56U, see Custom Asus RT-N56U firmware.

chuacw wrote:

5GHz support is completed, actually. I've both 2.4GHz and 5GHz enabled on OpenWrt running on my RT-N56U.

For steps on installing OpenWRT on RT-N56U, see Custom Asus RT-N56U firmware.

You should update the wiki.

Actually I tested RC3 and 5GHz radio does NOT work, no matter what I tried.

This is what I get in logs all the time:

Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): Configuration file: /var/run/hostapd-phy1.conf
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): wlan1: interface state UNINITIALIZED->COUNTRY_UPDATE
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): ACS: Automatic channel selection started, this may take a bit
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): wlan1: interface state COUNTRY_UPDATE->ACS
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): wlan1: ACS-STARTED 
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): ACS: Unable to collect survey data
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): ACS: All study options have failed
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): Interface initialization failed
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): wlan1: interface state ACS->DISABLED
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): wlan1: AP-DISABLED 
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): ACS: Possibly channel configuration is invalid, please report this along with your config file.
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): cat: can't open '/var/run/wifi-phy1.pid': No such file or directory
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): Command failed: Invalid argument
Wed Aug 20 11:40:42 2014 kern.info kernel: [   49.850000] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready

Unless there is a simple fix for this, I think a bug report needs to be filed.

(Last edited by moonman on 20 Aug 2014, 15:01)

moonman wrote:

Actually I tested RC3 and 5GHz radio does NOT work, no matter what I tried.
...
Unless there is a simple fix for this, I think a bug report needs to be filed.

Feel free. Go to http://dev.openwrt.org

chuacw wrote:

5GHz support is completed, actually. I've both 2.4GHz and 5GHz enabled on OpenWrt running on my RT-N56U.

For steps on installing OpenWRT on RT-N56U, see Custom Asus RT-N56U firmware.

Got it, thank you so much

So RT-N56U is fully supported now? Can set up both wifi radios via LuCi?

kalpik: the 5Ghz works by editing the wifi cfg file. It cant be started via LuCi.

Tried the RC3. I have some issues with the LAN performance and function. Tried to flash the latest stock firmware and padavans custom fw over LuCi and the Asus recovery utility with no luck. The LEDs are on but no wifi visible and no IP via LAN.

How can i delete Openwrt completly to flash a stock firmware?

You should have been able to flash back to Padavan from the LuCi web ui itself. Also, if all else fails, Asus recovery utility should work.

No im not. Thats the problem. Flashed the original asus fw and padavans with luci, asus recovery and mtd -r write with linux and firmware option. no function.

The discussion might have continued from here.