OpenWrt Forum Archive

Topic: TL-WDR3600 Youview Multicast?

The content of this topic has been archived on 1 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi,

I am a bit green when it comes to the configuration of OpenWRT and could really use some help. I have got a TP Link TL-WDR3600 which I have installed OpenWRT Barrier Breaker 14.07 RC3.

For the most part it seems OK, but I am trying to get my Humax Youview internet channels working. I understand it uses Multicasting, and it appeared to work fine with the Stock TP-Link Firmware. However the stock firmware didn't have proper DNS support for local devices, which was why I swapped it out.

I know I am being a bit vague, but I am really not sure as to what I need to configure. I have seen that kmod-bridge should be installed and igmpproxy but then it seems to vary a lot as to the actual configuration.

Anyone with experience into this kind of configuration would be appreciated.

Regards

SONiQz

(Last edited by SONiQz on 26 Aug 2014, 17:11)

Hi,
Thanks for that, I should have said I had looked through that previously. Unfortunately I can't seem to get it to work using the  kmod-bridge and igmp proxy method given. I really could use the help of someone who has it setup and running with either BT Vision or similar.

Thanks

SONiQz

So no-one here uses UK based Youview/BT Vision/Talk Talk TV/similar service with an OpenWRT router?!

Any help would be appreciated!

-SONiQz

I too am struggling to get my YouView box working with BT's multicast internet channels. Just bought a TP-Link Archer C7 and immediately updated the firmware to OpenWrt.

Followed the instructions at http://wiki.openwrt.org/doc/howto/udp_multicast (excluding the udpxy section, because from my understanding, the YouView box doesn't do that and I don't need multicast over wireless). The main stumbling block is in revealing the source address as used by my ISP (BT). All I'm getting is different LAN-range IP's e.g.:

The source address 192.168.3.7 for group 239.255.255.250, is not in any valid net for upstream VIF.

Have read in a couple places that these sorts of IPTV implementations involve broadcasting TV outside of the PPPoE layer and that a secondary WAN interface should be added. Unfortunately, I don't know enough about OpenWrt to try this.

Anyone shed some light on how we might get this working? Cheers!

Edit: Combined my previous posts into one and tweaked things a bit.

This is for Barrier Breaker and i've no idea if it'll work for Attitude Adjustment.

I don't have a BT Vision/Youview/TV box and don't use BT as my ISP, but i've got this working in that i can access the BT multicast test channel using VLC ( rtp://234.81.130.4:5802 ), so it should also work for the Youview box.

Here's how i did this on my TP-Link WDR4900, but the process should be the same on the WDR3600 (and maybe Archer C7).

Because the IPTV traffic isn't sent across your ISP's PPPoE connection (it's injected from the fibre cabinet) you need to add an IP address to your WAN port underneath the PPP connection.

Edit /etc/config/network and add a new interface:

config interface 'iptv'
    option ifname 'eth0.2'
    option proto 'static'
    option ipaddr '10.22.22.1'
    option netmask '255.255.255.0'

While you're editing /etc/config/network enable IGMP Snooping for your "lan" interface:

config interface 'lan'
    ...
    option igmp_snooping '1'

Install the igmpproxy package and edit /etc/config/igmpproxy:

config igmpproxy
    option quickleave 1

config phyint
    option network iptv
    option direction upstream
    list altnet 109.159.247.0/24

config phyint
    option network lan
    option direction downstream

Edit /etc/config/firewall and add the new "iptv" interface to your existing "wan" zone:

config zone
    option name 'wan'
    ...
    option network 'wan wan6 iptv'

Also add new firewall rules to the end of /etc/config/firewall to allow the multicast traffic:

config rule
    option src 'wan'
    option proto 'igmp'
    option target 'ACCEPT'
    option name 'IGMP (IPTV)'
    option enabled '1'

config rule
    option src 'wan'
    option proto 'udp'
    option dest 'lan'
    option dest_ip '224.0.0.0/4'
    option target 'ACCEPT'
    option family 'ipv4'
    option name 'Multicast'
    option enabled '1'

Run:

/etc/init.d/network restart
/etc/init.d/igmpproxy start
/etc/init.d/igmpproxy enable

Try opening a network stream to rtp://234.81.130.4:5802 in VLC or using your Youview box.

If you have the capability of capturing the multicast addresses of the various Youview channels i'd appreciate a list.  I haven't found a list anywhere and they're probably all encrypted anyway but a list would be nice to have.

(Last edited by Middling on 5 Sep 2014, 13:49)

Excellent, that did the trick for me! A massive thank you.

For reference, there were some minor differences in my config on the Archer C7 v2 with Barrier Break 14.07-rc3. i.e. Instead of eth0.2 for the physical wan port, I used eth0. And for the 'iptv' zone in /etc/config/firewall it looked like this:

config zone
    option name 'wan'
    list network 'wan'
    list network 'wan6'
    list network 'iptv'
...

Finally, I had to remove the existing altnet 192.168.3.0/24 line in /etc/config/igmpproxy and just use 109.159.247.0/24, which is key for BT's YouView it seems.

Hopefully this will help OP as well!


Regarding the multicast addresses...

Sadly I didn't keep note but did attempt to connect VLC to a few, only showing a blob of green (likely that encryption you mentioned). The test stream worked fine, though.

Can't be 100% certain, but I don't think the IP's correspond to channels on a one-to-one basis - sometimes it didn't change on channel switch and the same IP was seen for different channels. One thing I did notice was the (Humax) YouView+ box connecting to port 80 on 213.120.177.227. I wonder if it's issuing commands to the cabinet to change channels that way.

This worked for me as well with Barrier Breaker. I had to restart the router before the changes took hold - merely running the 3 /etc/init.d commands wasn't enough. I wonder if doing something with /etc/init.d/firewall would have helped.

The discussion might have continued from here.