OpenWrt Forum Archive

Topic: ath79: SD-card on SPI-bus

The content of this topic has been archived between 6 Feb 2018 and 18 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello Deoptim,

Thank you for the reply.

I undid the changes made by the 3 patches mentioned in r47045, and everything works perfectly now.

Deoptim wrote:
crashprone wrote:

Can I blacklist the kmod-mmc-spi and kmod-mmc so that they do not load during boot?

I do not see the point in this, because, the conflict is with the ath79-spi driver.

It is really weird that the mod still works on Chaos Calmer after booting, but just not during the boot process.

If I remove the card while booting, the device boots succesfully.

Then I do

$rmmod mmc_spi
$modprobe mmc_spi

This leads to the card being successfully detected and I was even able to write and read a test file.

I'm unable to figure out what makes the difference during boot and not after boot.

Thanks again for your Deep MMC Hack!

crashprone wrote:

Hello Deoptim,

Thank you for the reply.

I undid the changes made by the 3 patches mentioned in r47045, and everything works perfectly now.

Please, write the instruction (step by step) how you did it.
This would be useful for other people facing the same problem.
You can edit the Wiki page yourself or write the instructions here.
Thank you!

Added New method with used common CS0 with NOR flash memory - only CS0 in reverse polarity.
Now NO need to use and find GPIOs  smile
Connection scheme:
https://wiki.openwrt.org/_media/media/tplink/tl-mr3420/tl-mr3420-v1_common_cs_line.png
But using this method, you need to purchase a Single Inverter Gate (or Single Schmitt-Trigger Inverter) (which operates on voltage >=3.3V).
https://wiki.openwrt.org/toh/tp-link/tl … p.mmc.hack

(Last edited by Deoptim on 28 Aug 2017, 16:07)

The discussion might have continued from here.