OpenWrt Forum Archive

Topic: WiP: TL-WA7210Nv2 support

The content of this topic has been archived between 18 Apr 2018 and 5 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.


during the last few weeks nicoo and I have been working on OpenWRT support for the TP-Link TL-WA7210Nv2.

The WiP feature branch can be found here: … 0n-support

When trying to boot OpenWRT, the board is not detected:

We probably have a small typo somewhere - if you find it, we owe you a beer wink

We've also prepped a wiki page including photos for the ToH, I'll put that live today but it's still WiP as well.



You need a MIPS machine Id in the startup code.
See in


thank you for giving your time to the project.

in the wiki you mentioned the firmware image openwrt-ar71xx-generic-tl-wa7210n-v2-squashfs-factory.bin
Where can I download it?

I would like to the test your firmware on mine WA7210N v2 device.


Any news about this firmware?

I'm also interested in this.
Any updates?


Great. Thanks.
I'm looking forward to it.

It was accepted and it works.
But sadly the internal antenna doesn't.

hi ı can help me 7210n   firmware  need
share please stable version

ı have 7210n     use
[] wa7210n <3KM> wa7210n  []   not stable 10mbps max 

internal antenna possible  and wrt firmware stable ?

please firmware setup video


luci install problems please help me

Snapshots don't come with luci preinstalled and the device doesn't have enough space to install it manually.
You have to build your own image.
The built in packages are better compressed so it will fit.

Hi every body,
Please I'm looking for a suitable OpenWrt image for ACME-Aria G25 Hardware.
How can I get the most close version to this Hardware ?
Who can I ask about that and where to put question ..

Thanks for your time ..

load.runner wrote:

Snapshots don't come with luci preinstalled and the device doesn't have enough space to install it manually.
You have to build your own image.
The built in packages are better compressed so it will fit.

please share build image or example


Hi everybody, i managed to install the snapshot build on my TL-WA7210N v2,1 and it works just fine, i was able to configure it as client via ssh, but the reception was weak, i also need to install luci, thus i built some custom image and removed packages i don't need to make room for luci, failed many times with [error image too big].
installed luci via feeds and included it via make menuconfig,
only succeed when i removed ppp, usb , dhcp, dns, ipv6, uci, iwconfig, ipv6, ip6tables,
i also removed wpad-mini and replaced with the full wpad

the compiled image bricked the thing, error [unreachable host] fortunately the bootloader is detected but i can't access failsafe , reset button not working,  tomorrow i will try to debrick it with tftp server, and build another image, so MY QUESTION do i need to put some configuration before compile like uttpd config i don't know !??

please give advice, and wish me luck, thank you very very much Alex and nicoo

Enable the power amplified by running this:

echo 28 > /sys/class/gpio/export
echo "out" > /sys/class/gpio/gpio28/direction
echo 1 > /sys/class/gpio/gpio28/value

It doesn't need any configuration. Worked for me right out of the box. Just followed the buildroot tutorial, selected this device in menuconfig, and make.
Also, I was able to install luci without removing anything, as long it's selected as built in.

(Last edited by load.runner on 6 Apr 2015, 11:41)

hi load.runner, good job installing luci, i had no luck, can you please  share with me the build image you made

Sorry for the late response.

My image is heavily customized so I can't share it, as it wouldn't help you.
But if you still need one, I will build a fresh one for you from trunk.

Can any body send full dump of flash (original or with openwrt) to  ?

Hi,  im installed OpenWrt Chaos Calmer 15.05-rc1 on Wa7210n, Luci is included, no need to install, works really stable, antenna working is the external so need to re solder to use the internal , LNA is disable so need to doo this :

1   create file /etc/init.d/gpio

#!/bin/sh /etc/rc.common
# Copyright (C) 2015

boot() {

        [ -d /sys/class/gpio ] && {
                echo 28 > /sys/class/gpio/export
                echo "out" > /sys/class/gpio/gpio28/direction
                echo 1 > /sys/class/gpio/gpio28/value

2  to enable make sure this script is executable and enabled :

chmod +x /etc/init.d/gpio
/etc/init.d/gpio enable

if set reg domain japan ,all 14 channel are working.
Led's ,,no one works .. irrelevant,no lan no signal streng .

(Last edited by NEURUS on 5 Jun 2015, 06:26)

OpenWrt Chaos Calmer 15.05-rc2 not working sad
obtaining ip ( but not open luci web page doesnt it sad
Anyone attempting to running?

OpenWrt Chaos Calmer 15.05-rc3 working smile
but not stable, Transmission Power: 19mw ( How up to 27mw)
need a very lack of development like this.
who has tried?

Atheros Ar9330 / Atheros AR9331 SOC Wireless diversity option does not work!
And then txpower option max value 26 dbm (Just only channel 12 and 13), Why txpower up to 27 dbm?
My device is TP-Link TL-WA7210N V2.1(V2)
I have tested on trunk(snapshots) OpenWrt Designated Driver r49390
What's news?
Thank you for your development

Is this still alive? roll

I see very different results.
Did anyone tried to make it work recently?