OpenWrt Forum Archive

Topic: can't load library '

The content of this topic has been archived on 18 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.


I am relatively new to linux and so to openwrt. I managed cross compiling a package that we developed for openwrt. However I get the following error when I start the program after successfully installing it with ipkg:

can't load library '

I would appreciate any help

many thanks

Burak Simsek

You should link your executable against uclibc++. Take a look at other c++ source-based packages like nmap or kismet to see how you can achieve this.

Many thanks Nico ! This worked... Now our package is running over openwrt...

Also remember to install the package: libstdcpp.

Just for clarity:

you can either install libstdcpp with

opkg update
opkg install libstdcpp

or link your executable agains uclibc++

Right? I just installed libstdcpp and it worked fine, i just wonder if that's the most efficient way.

The discussion might have continued from here.