OpenWrt Forum Archive

Topic: Support for TP-Link Archer C2600

The content of this topic has been archived between 29 Mar 2018 and 6 May 2018. Unfortunately there are posts – most likely complete pages – missing.

With all the new items popping up at CES, seems TP-Link has announced the release of an upcoming model seemingly based on the trusted QCA Atheros platform.

Wondering if OpenWRT is aware of the new models coming out and had plans to support them? Archer C2600 looks very nice for myself.

(Last edited by cybrnook2002 on 12 Apr 2016, 17:48)

Seems that AC2600 is Qualcom-Atheros, while the AC3200 is Broadcom. The AC2600 is more likely to get support, but biggest factor in terms of timing will be whether it can be supported with ath10k or if a new driver is needed.

Looks like several manufacturers are announcing support at CES for the QCA9980 chipset, which is used in the AC2600. Hopefully they are in conjunction with an IPQ806x SoC (dual core Krait/ARM).

(Last edited by drawz on 24 Jul 2015, 02:34)

Thanks for the reply! It must have been an oversight on my part that the C3200 is on Broadcom (Granted I was much more excited for the C2600, so really focused on that one). The C2600 looks quite nice in my opinion, styling and hardware. I have implemented a few of the older v2 archer C7's, and outside of the weaker range, they work great. The C2600 seems to be the successor to that with a more robust set of internals and more powerful antenna amplifiers, if so, this will be my next router. Of course, all dependent if OpenWRT will support it.

And yes, Krait CPU looks very promising as well.

(Last edited by cybrnook2002 on 8 Jan 2015, 15:18)

Anyone got their hands on a C2600 yet? The WRT1900AC v2 has great hardware but looks fugly. Being a QCA998x should mean it's supported by ath10k, right? This is definitely my next router if it gets OpenWrt support.

Haven't seen it for sale anywhere, but it's at least listed on the TP-Link website (beyond a press release). It's been to the FCC according to wikidevi, so hopefully available soon. Agree that it could be a good one for OpenWrt, although ath10k isn't as open as ath9k, which has slowed development a bit.

There's been lots of development on ipq806x in trunk lately. If the qca wireless is supported by ath10k this will be an awesome OpenWrt router smile

Awesome, thanks for the tidbit. Very much looking forward to see how this develops, as I have my heart set on this guy if it get's some good support.

Really looking for some more features for my C3200. Anyone got something they could point me at?

There is no support yet. Hardware wise it's identical to the Netgear R8000 which is fully supported. Hopefully one of the devs will get their hands on one of these babies soon and add support for them.

Is there a driver for the QCA8337 switch?

EDIT: Yes, it's supported by the ar8216 driver

(Last edited by arokh on 12 Nov 2015, 10:24)

I recently brought the c2600 based on the SNB review of its MU-MIMO performance and the potential for OpenWRT support in the future. Currently using it as an AP but somewhat disappointed with its performance on stock firmware (in comparison to my old WZR-HP-AG300H on 15.05). Hoping development kicks off soon.

Have you tried opening it up to see if there's a way to connect serial?

I will take a look at it this weekend. I do feel it is time I contributed to the OpenWRT effort.

Looking at the TP-Link board images it looks like there is a serial on the RHS on the board. … rd_top.jpg

(Last edited by pdsmith on 12 Nov 2015, 10:56)

I have located the (unpopulated) serial header. Pin 3 (from left) is ground, Pin 4 is VCC (constant 3.3V). I am struggling to determine TX/RX. Might be too fast for my multimeter. Suggestions? I have a CP2102 serial to usb adapter. … NDUVE/view

Couldn't you try both the remaining pins? Don't think that will cause any harm.

(Last edited by arokh on 14 Nov 2015, 04:28)

After many hours of trying with the serial adapter I am unable to get any sign that the TX/RX pins (if they are that) are live.

Edit: I shorted the TX and VCC pins on my USB connector while running putty and received garbled output confirming it works. This gives me confidence the problem lies at the router end.

(Last edited by pdsmith on 14 Nov 2015, 08:36)

Did you experiment with the baud rate? My TP-Link WDR4900 is 115200.

I tried 9600 and 115200, but since I never saw any feedback (just blank screen) I don't think that is that is the problem. So far I haven't seen any voltage on pins 1 and 2 - I will try again.

I will see if I can get hold of an oscilloscope.

(Last edited by pdsmith on 15 Nov 2015, 09:01)

Unfortunately no working oscilloscope available. I can't proceed any further until the Tx/Rx are identified. It could well be my equipment/soldering that is the problem. Need someone else with a C2600 to help with serial.


If you look at the FCC images submitted by TP-Link you can see populated pins where the serial port is and two small chips to the left of the port. On the release board (see my image above) one of these chips is missing (U25). I wonder if some pins need shorting (as with other TP-Link boards) or connections need to be made to enable serial. … rd_top.jpg

(Last edited by pdsmith on 17 Nov 2015, 09:52)

Some maybe useful information.  Similar to previous tp-link models, if you power on the device while holding down the "reset" button on the side, it will boot to recovery mode.  It looks for a tftp server on and for a recovery file ArcherC2600_1.0_tp_recovery.bin

Like this (with my computer connected to LAN 1) I was able to successfully flash an updated stock firmware (updated from Rel 32140 which the unit shipped with, to rel 66045 which is what is currently on tp-link global website).

Now if anyone wants to try blind development... (I suspect it should be REALLY similar to the AP148 or R7500 aside from the pcie-connected wireless chips)

The stock firmware also runs an ssh server on port 22 with login "root" and password "admin" though I'm not able to allocate a terminal nor execute any commands, so this may not be of any use in the end.

Good info.

"Now if anyone wants to try blind development... "

Without serial this seems very risky. Can you try to establish a serial connection?

I don't have the necessary hardware for a serial connection for the moment (and I would expect to encounter the same issues as pdsmith anyways)

What are the possible mechanisms by which I could break the tftp recovery mode?