OpenWrt Forum Archive

Topic: Support for TP-Link Archer C2600

The content of this topic has been archived between 29 Mar 2018 and 6 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Some of the partition code is in

GPL dump/openwrt/qca/src/u-boot/include/linux

When booting from the GPL build image, does it load all of the partitions correctly, or is the dump missing that functionality as well?

If you mean the build from the GPL tarball from tp-link, I'm not sure I ever got that booting on my router.

The stock firmware only mounts ART and rootfs partitions though.  (Which perhaps suggests that the MAC addresses are also present in the ART partition)

Ok, no, the stock firmware does read from default-mac, just not through the mtd layer.

One other interesting point.  For the stock firmware, eth1 (LAN) and wifi1(2.4ghz) have the same MAC address.  eth0 and wifi0 have unique MAC addresses.

Any reason why it would be set up this way?  (And will this cause any problems if the same scheme is used for openwrt with the same mac address for lan and 2.4ghz wireless?)

Hi I dump full flash (with factory firmware):
http://tplink-forum.pl/wsady-pamieci-fl … 00v1-5487/

My MAC: EC 08 6B 2C A0 4C, PIN 69842276
MAC location on flash: 0x1EF0008-0x1EF000D
Pin location: 0x1EF0208-0x1EF020F
Device info: 0x1EF0400



Log:

(IPQ) # setenv ipaddr 192.168.0.88
(IPQ) # setenv serverip 192.168.0.66
(IPQ) # setenv netmask 255.255.255.0
(IPQ) # sf probe
SF: Detected MX25U25635F with page size 4 KiB, total 32 MiB
(IPQ) # sf read 45000000 0 2000000
(IPQ) # tftpput 0x45000000 2000000 dump.bin
Using eth0 device
TFTP to server 192.168.0.66; our IP address is 192.168.0.88
Filename 'dump.bin'.
Save address: 0x45000000
Save size:    0x2000000
Saving: ################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         ###########
done
Bytes transferred = 33554432 (2000000 hex)
(IPQ) #
Heinz wrote:

Hi I dump full flash (with factory firmware):
http://tplink-forum.pl/wsady-pamieci-fl … 00v1-5487/

Thanks, this is consistent with what I found by dumping the individual partitions (8 bytes from the start of the default-mac partition which starts at 1ef0000)

bendavid wrote:

If you mean the build from the GPL tarball from tp-link, I'm not sure I ever got that booting on my router.

The stock firmware only mounts ART and rootfs partitions though.  (Which perhaps suggests that the MAC addresses are also present in the ART partition)

I think it might be in ART as well, since some of the MAC code I could fine in the tarball was related to ART, rather than MTD.

So, maybe it loads it from default-mac as some point (like maybe in uboot) and copies it to the ART partition?

I'm surprised the stock one doesn't mount all those partitions (of course, it would have to mount it if it just did a raw read of the flash, since it knows where the values will be stored.

HomerSp wrote:
buz2 wrote:

Love the feature set but it does seem to have stability issues, roughly twice or three times per day my wifi briefly goes down and the router seems to reboot itself (at least uptime gets reset). Am I the only one experiencing this?

I have an uptime of more than 7 days, so I definitely can't say that I have had any stability problems - it's been working really, really well.

It's a bit funny actually, I had a Linksys WRT1900AC (then an ACS due to problems with the AC) which has advertised openwrt support, but I had nothing with problems with that one, with the wifi randomly not working, reboots etc. The C2600 has been much more stable so far.

@HomerSp is WRT1900ACS full openwrt supported? Wifi ac rock stable? Does it use proprieatey drivers or openwrt ac wifi driver? What about hw nat?
Thnx.

@Heinz

Did you ever get write access to uboot via serial or still read only access?

Heinz wrote:

@arokh Thank You. Firmware run on V1.1

@bendavid. Yes i have serial. if You compile firmwaer i can test it.

The above seems to indicate you can TX to uboot, yes?

I have a C2600 which I am debating whether to keep or return. If I can get full serial access I would likely just keep it around. I see your photos of how to access serial on the C2600, but without TX I may just return this unit.

bendavid wrote:

One other interesting point.  For the stock firmware, eth1 (LAN) and wifi1(2.4ghz) have the same MAC address.  eth0 and wifi0 have unique MAC addresses.

Any reason why it would be set up this way?  (And will this cause any problems if the same scheme is used for openwrt with the same mac address for lan and 2.4ghz wireless?)

Anyone have any further thoughts on this?  (Aside from this, I otherwise have a fix for the mac addresses more or less ready.)

bendavid wrote:
bendavid wrote:

One other interesting point.  For the stock firmware, eth1 (LAN) and wifi1(2.4ghz) have the same MAC address.  eth0 and wifi0 have unique MAC addresses.

Any reason why it would be set up this way?  (And will this cause any problems if the same scheme is used for openwrt with the same mac address for lan and 2.4ghz wireless?)

Anyone have any further thoughts on this?  (Aside from this, I otherwise have a fix for the mac addresses more or less ready.)

That's typical for most TP-links I've seen. A lot of shared MAC's. Is this the same on the stock firmware? eth0 is typically the same as the 2.4GHz address.

I am very interested to get hold of your patch for the fix to the MAC addresses. Could you post it for me to test?

Thanks again!

James

Yes, it's the stock firmware which I'm referring to that has the duplicate MAC addresses.

I'm concerned that this arrangement with duplicate mac's will cause problems for openwrt when lan and wlan are part of the same kernel bridge device.

Is that device already locked? I am playing with my mind to buy one^^

so long

I have not seen any evidence that any version of this router is locked so far, beyond the MD5 hash which is already properly handled by the tplinksafeloader.

The latest US firmware on the website is still Archer_C2600_V1_150924_US

Has anyone seen a newer US firmware or had problems flashing to openwrt from the above stock firmware?

I have arokh r48744 build and router restarts randomly when I download and upload with max speed (FTTH pppoe 200/20).

@arokh would you be so kind and make a clean build with USB Modem Support, luci, ddns, luci ssl and luci ddns? wink

(Last edited by trustno1foxm on 27 Feb 2016, 14:35)

Sometimes router restarts but sometimes write to log something that (current download circle about 200Mb/s, upload 20Mb/s):

Sat Feb 27 15:14:06 2016 daemon.notice netifd: Interface 'wan' is now down
Sat Feb 27 15:14:06 2016 daemon.notice netifd: Interface 'wan' is setting up now
Sat Feb 27 15:14:06 2016 daemon.info pppd[20474]: Plugin rp-pppoe.so loaded.
Sat Feb 27 15:14:06 2016 daemon.info pppd[20474]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Sat Feb 27 15:14:06 2016 daemon.notice pppd[20474]: pppd 2.4.7 started by root, uid 0
Sat Feb 27 15:14:21 2016 daemon.warn pppd[20474]: Timeout waiting for PADO packets
Sat Feb 27 15:14:21 2016 daemon.err pppd[20474]: Unable to complete PPPoE Discovery
Sat Feb 27 15:14:21 2016 daemon.info pppd[20474]: Exit.
Sat Feb 27 15:14:21 2016 daemon.notice netifd: Interface 'wan' is now down
Sat Feb 27 15:14:21 2016 daemon.notice netifd: Interface 'wan' is setting up now
Sat Feb 27 15:14:21 2016 daemon.info pppd[20493]: Plugin rp-pppoe.so loaded.
Sat Feb 27 15:14:21 2016 daemon.info pppd[20493]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Sat Feb 27 15:14:21 2016 daemon.notice pppd[20493]: pppd 2.4.7 started by root, uid 0
Sat Feb 27 15:14:36 2016 daemon.warn pppd[20493]: Timeout waiting for PADO packets
Sat Feb 27 15:14:37 2016 daemon.err pppd[20493]: Unable to complete PPPoE Discovery
Sat Feb 27 15:14:37 2016 daemon.info pppd[20493]: Exit.
Sat Feb 27 15:14:37 2016 daemon.notice netifd: Interface 'wan' is now down
Sat Feb 27 15:14:37 2016 daemon.notice netifd: Interface 'wan' is setting up now
Sat Feb 27 15:14:37 2016 daemon.info pppd[20512]: Plugin rp-pppoe.so loaded.
Sat Feb 27 15:14:37 2016 daemon.info pppd[20512]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Sat Feb 27 15:14:37 2016 daemon.notice pppd[20512]: pppd 2.4.7 started by root, uid 0
Sat Feb 27 15:14:52 2016 daemon.warn pppd[20512]: Timeout waiting for PADO packets
Sat Feb 27 15:14:52 2016 daemon.err pppd[20512]: Unable to complete PPPoE Discovery
Sat Feb 27 15:14:52 2016 daemon.info pppd[20512]: Exit.

[..]

and I have to restart it manually.

@trustno1foxm

Source is available, please help yourself smile

I am a noob^^ I will use better yours wink

One questions, how to get rid of adblock? I can't find that package. thx!

(Last edited by trustno1foxm on 27 Feb 2016, 20:55)

back again^^

1.) how to reset the device? the reset button is not working?
2.) [solved] i Need usb-modeswitch on the device, but i can't find the correct package (architecture)? any ideas/help? thx!

(Last edited by trustno1foxm on 28 Feb 2016, 08:22)

can anyone help me with vlan tagging? It's not working like on my 3420v2 or linksys wrt1200ac hmm

I have one cable attached (LAN), with default vlan 1 and vlan 10. vlan1 is untagged on the switch and vlan10 is tagged.
every interface has it's own dhcp server.

so my config looks like:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd31:15a3:558c::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.0.1'
        option delegate '0'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'
        option metric '10'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 1 2 3 4 6'

config switch_vlan
        option device 'switch0'
        option vlan '10'
        option vid '10'
        option ports '0t 4t 5'

config interface 'usb'
        option ifname 'usb0'
        option proto 'dhcp'
        option metric '20'

config interface 'ovpnudp'
        option proto 'none'
        option ifname 'tun0'

config interface 'ovpntcp'
        option proto 'none'
        option ifname 'tun1'

config interface 'guest_wifi'
        option proto 'static'
        option delegate '0'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option _orig_ifname 'guest_wifi wlan1-1'
        option _orig_bridge 'true'

config interface 'guest_lan'
        option proto 'static'
        option ifname 'eth1.10'
        option delegate '0'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'

config interface 'hilink'
        option proto 'dhcp'
        option ifname 'eth2'
        option delegate '0'
        option peerdns '0'
        option dns '8.8.8.8'

no device with vlan 10 is getting an ip address hmm

thx!

(Last edited by trustno1foxm on 28 Feb 2016, 08:17)

Try this:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd31:15a3:558c::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.0.1'
        option delegate '0'

#config interface 'wan'
#        option ifname 'eth0.1'
#        option proto 'dhcp'
#        option metric '10'
#
#config interface 'wan6'
#        option ifname 'eth0.1'
#        option proto 'dhcpv6'
#
config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 1 2 3 4 5 6t'

config switch_vlan
        option device 'switch0'
        option vlan '10'
        option vid '10'
        option ports '0t'

config interface 'usb'
        option ifname 'usb0'
        option proto 'dhcp'
        option metric '20'

config interface 'ovpnudp'
        option proto 'none'
        option ifname 'tun0'

config interface 'ovpntcp'
        option proto 'none'
        option ifname 'tun1'

config interface 'guest_wifi'
        option proto 'static'
        option delegate '0'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option _orig_ifname 'guest_wifi wlan1-1'
        option _orig_bridge 'true'

config interface 'guest_lan'
        option proto 'static'
        option ifname 'eth0.10'
        option delegate '0'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'

config interface 'hilink'
        option proto 'dhcp'
        option ifname 'eth2'
        option delegate '0'
        option peerdns '0'
        option dns '8.8.8.8'

thx! the only difference is, that on lan interface it looks like this:

option ifname 'eth1'

Should I rewrite it to 'eth1.1'? I am afraid that the device gets unresponsable again. It's working with 'eth1', but I don't think it's correct.

Sorry, posts 276 to 275 are missing from our archive.