OpenWrt Forum Archive

Topic: Support for TP-Link Archer C2600

The content of this topic has been archived between 29 Mar 2018 and 6 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Thanks for the work @arokh and @bendavid, C2600 will likely be my next router thanks to you :-)

(Last edited by cybrnook2002 on 9 Jan 2016, 23:03)

buz2 wrote:

Love the feature set but it does seem to have stability issues, roughly twice or three times per day my wifi briefly goes down and the router seems to reboot itself (at least uptime gets reset). Am I the only one experiencing this?

I have an uptime of more than 7 days, so I definitely can't say that I have had any stability problems - it's been working really, really well.

It's a bit funny actually, I had a Linksys WRT1900AC (then an ACS due to problems with the AC) which has advertised openwrt support, but I had nothing with problems with that one, with the wifi randomly not working, reboots etc. The C2600 has been much more stable so far.

(Last edited by HomerSp on 5 Jan 2016, 18:49)

@cybrnook2002

You should thank bendavid who did all the work, I just run "make" smile

Rocket wrote:

For me it is working very good.
My setup is a 5 ghz bridge to the main router and it is sending a new 2.4ghz wlan network to expand the range...
I have a updtime of over 4 days. And the restarts before that are just because I played with the config and reboted it myself...

Could you tell us about your setup? Which software did you install? Maybe you could give us a log or something to work on?


Fairly standard. C2600 as only router (no WDS or any weird things, one wired client), no special software, one guest network configured. But right now it has an uptime of 2d 9h, so looks like it may have caught itself *knockonwood*.

In fairness, it had a lot less traffic now that I have to work again, maybe it was overheating (or power was flaky though in general that is rock solid here)?

In case I catch it rebooting again, what logs would be helpful?

(Last edited by buz2 on 5 Jan 2016, 20:06)

The system log would be helpful, but it's only written to RAM and lost on reboot. I suggest keeping logread -f running in a terminal to see if you can catch anything if it happens again. Also you could set up something like collectd to graph your system. Could also be some kind of kernel crash, which would probably show up in the log. Graphing would catch something like memory usage spiking.

The router seems very stable and fast (9 days uptime), with the exception of the 2G WIFI that would not initially start. Also my log has recently been flooded with the following error.

ath10k_pci 0000:01:00.0: failed to transmit packet, dropping: -16

Nice work @BenDavid.

HomerSp wrote:
Rocket wrote:

I'm running the build from arokh.
I don't have much experience with compiling it myself, so maybe you could upload your build?

Try this: https://drive.google.com/file/d/0B4FOzj … sp=sharing

Thx for your ROM, its a sysupgrade, which base rom should be used?
thx!

thx a lot! is the vlan switch useable?

Rocket wrote:

This is an old rom...
Just install the current build from arokh:
http://luci.subsignal.org/~trondah/c2600/

lost 5ghz with the latest update...had to roll back

For me the Build r48132 is working perfectly. 5Ghz in client mode is running smooth.
Just upgraded to r48147, the new build is working fine for me as well. wink

(Last edited by Rocket on 8 Jan 2016, 12:45)

OK, thanks for the update. @blackwellops must be user error then wink

Had it stable for a week now, so decided to go to r48147 which seems to have worked just fine for 2.4G but 5G does seem to have somehow been disabled too. I shall investigate.

Needless to say that system and kernel logs would be useful in case of problems with the wireless.

My router (C2600) got stuck and received only today. Just flashed with r48147 and everything seems to be working fine!

Not sure whether it's intended or not, but when I put a cable to LAN 1 (according to the router naming), switch shows active Port 4, LAN 2 - Port 3, LAN 3 - Port 2, LAN 4 - Port 1, WAN - Port 5. Isn't it supposed to be LAN 1 - Port 1 etc?

Thanks, bendavid  and arokh for your work!

bendavid wrote:

Needless to say that system and kernel logs would be useful in case of problems with the wireless.

Was about to procure those and decided after a clean reboot they might be less cluttered. Lo and behold, 5G is running now smile

I checked my NAT throughput and it's very slow. The max download speed is only 370Mbps, upload 530Mbps. Meanwhile, on my less powerful R8000 the speed is better than that. Due to the more powerful CPU on C2600 I expected to reach my max ISP speed which is 600Mbps.

On a side note, usually when I used BB or CC builds on my old WDR4300 routers, it was pretty straightforward to get IPTV (which comes from my ISP as a tagged vlan6 packet) on my whole network. I had to add some firewall rules:

config rule
option src wan
option proto igmp
option target ACCEPT

config rule
option src wan
option proto udp
option dest_ip 224.0.0.0/4
option target ACCEPT

Then install and launch udpyx with these parameters:

udpxy -p 4022 -m 10.10.99.1 -B 4Kb -c 10

And finally use ifconfig:

ifconfig eth0.6 10.10.99.1 up

I could access IPTV using such links:
http://10.10.99.1:4022/udp/239.2.3.12:1234

When I tried using ifconfig on arokhs build, I've got this:

root@OpenWrt ~# ifconfig eth0.6 10.10.99.1 up
ifconfig: SIOCSIFADDR: No such device

So I created VLAN6 interface

config interface 'vlan6'
        option ifname 'eth0.6'
        option proto 'static'
        option defaultroute '0'
        option peerdns '0'
        option ipaddr '10.10.99.1'
        option netmask '255.0.0.0'

But I still can't access IPTV using links like this (http://10.10.99.1:4022/udp/239.2.3.12:1234)... I would very appreciate if someone could help me how to fix that or how I can troubleshoot this.

(Last edited by visata on 9 Jan 2016, 17:18)

Are there any vlans at all? Can you post output of 'ip a'?

(Last edited by arokh on 9 Jan 2016, 17:23)

Here is the output:

root@OpenWrt ~# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN group default qlen 1000
    link/ether 00:03:7f:ba:db:01 brd ff:ff:ff:ff:ff:ff
    inet [removed]/18 brd [removed] scope global eth0
       valid_lft forever preferred_lft forever
    inet6 [removed]/64 scope link
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-lan state UNKNOWN group default qlen 1000
    link/ether 00:03:7f:ba:db:02 brd ff:ff:ff:ff:ff:ff
4: sit0@NONE: <NOARP> mtu 1480 qdisc noop state DOWN group default
    link/sit 0.0.0.0 brd 0.0.0.0
5: ifb0: <BROADCAST,NOARP> mtu 1500 qdisc noop state DOWN group default qlen 32
    link/ether 66:18:35:1f:38:0a brd ff:ff:ff:ff:ff:ff
6: ifb1: <BROADCAST,NOARP> mtu 1500 qdisc noop state DOWN group default qlen 32
    link/ether b6:00:a3:bf:44:d6 brd ff:ff:ff:ff:ff:ff
9: teql0: <NOARP> mtu 1500 qdisc noop state DOWN group default qlen 100
    link/void
10: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default
    link/ether 00:03:7f:12:da:da brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fd7c:f95f:6b12::1/60 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::203:7fff:feba:db02/64 scope link
       valid_lft forever preferred_lft forever
11: eth0.6@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default
    link/ether 00:03:7f:ba:db:01 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::203:7fff:feba:db01/64 scope link
       valid_lft forever preferred_lft forever
19: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-lan state UP group default qlen 1000
    link/ether 00:03:7f:12:da:da brd ff:ff:ff:ff:ff:ff
    inet6 fe80::203:7fff:fe12:dada/64 scope link
       valid_lft forever preferred_lft forever
24: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-lan state UP group default qlen 1000
    link/ether 00:34:56:78:f8:f8 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::234:56ff:fe78:f8f8/64 scope link
       valid_lft forever preferred_lft forever
25: wlan0-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 02:34:56:78:f8:f8 brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.1/24 brd 192.168.2.255 scope global wlan0-1
       valid_lft forever preferred_lft forever
    inet6 fe80::34:56ff:fe78:f8f8/64 scope link
       valid_lft forever preferred_lft forever

I guess either the switch or the driver doesn't support vlans. Maybe bendavid can comment on that.

I'm using a tagged vlan on my WAN port (since it's required by my ISP) and it's working fine.

Have you properly configured the switch for your desired vlan tagging?

What I did was leave the wan interface config as it is (untagged) and add the necessary vlan tagging purely at the switch level.

If you need to have two different vlan tags on your wan port (or a mix of tagged and untagged) then you may indeed also need to configure the vlan at the interface level.

My config looks as follows (with pppoe with vid 11 tagging for the wan)

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdbf:1c4e:8341::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0'
        option _orig_ifname 'eth0'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option username '*******'
        option password '*******'
        option ipv6 'auto'

config interface 'wan6'
        option ifname 'eth0'
        option _orig_ifname 'eth0'
        option _orig_bridge 'false'
        option proto 'none'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 5t'
        option vid '11'

For the NAT throughput, can you copy and paste the output of "top" while running at max throughput?

buz2 wrote:
bendavid wrote:

Needless to say that system and kernel logs would be useful in case of problems with the wireless.

Was about to procure those and decided after a clean reboot they might be less cluttered. Lo and behold, 5G is running now smile

If someone has a similar problem, would be useful to have the logs from a boot in which the wireless is not working.  I suspect a race condition or something not getting called correctly after an upgrade somewhere in the firmware initialization (on first boot there is an additional step which is called to copy the calibration data from ART partition on the flash to a file in /lib/firmware).

Hi all,
I've joined the fun and loaded arokh's r48147 "factory" build to my c2600. It appears to have worked fine, but I'm being asked for a password (on webui and ssh) and found telnet to be disabled. I've tried the usual combo's as well as no password. The webui shunts me from http -> https, so it appears that 'firstboot' has already been run. Any suggestions?