OpenWrt Forum Archive

Topic: Support for TP-Link Archer C2600

The content of this topic has been archived between 29 Mar 2018 and 6 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Thanks for the answer and the link... It looks like a good place to start reading!

VLAN actually works for me. I dedicated one port for STB and it works fine.

I just can't make IPTV packets flow over my network using udpxy. What I want to achieve is to get IPTV on any network device (PC, mobile, tablet). udpyx runs fine, but when I try to access it (http://10.10.99.1:4022/udp/239.2.3.12:1234), I'm not receiving anything:
http://imgur.com/79DujKK

I'm not exactly sure how udpxy works but when I followed mentioned steps it worked fine on BB or CC builds. It is most likely I'm missing something due to the lack of knowledge and this build is most likely fine.

Here is my config:

root@OpenWrt ~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd7c:f95f:6b12::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'
        option metric '10'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 5'
        option vid '2'

config interface 'tor'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'

config interface 'usb'
        option ifname 'usb0'
        option proto 'dhcp'
        option metric '20'

config interface 'ovpnudp'
        option proto 'none'
        option ifname 'tun0'

config interface 'ovpntcp'
        option proto 'none'
        option ifname 'tun1'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '4 5t'
        option vid '6'

config interface 'vlan6'
        option proto 'none'
        option ifname 'eth0.6'

STB is attached to the Port 4 and works fine but I can't figure why I'm not getting anything from udpxy... I'm missing something.

Regarding NAT throughput, I will post the load tomorrow because I'm currently connected with ac2600 router using a damaged 1000mbps cable and it shows only 100mbps.

Here is the load when I tested my internet speed. Please note I'm using OOKLA to test the speed. I ran OOKLA 4 or 5 times in a row.

Mem: 142540K used, 339216K free, 892K shrd, 5876K buff, 18580K cached
CPU:   2% usr   2% sys   0% nic  94% idle   0% io   0% irq   0% sirq
Load average: 0.49 0.25 0.13 2/77 32473

I didn't change anything but did another test and I'm getting almost 500Mbps download speed. So the slow speed was clearly related to my ISP. I didn't test stock firmware vs openwrt build, so I assumed there is something wrong with a build. I will do more complete testing Stock vs Openwrt and post later.

Can I revert to a stock firmware using a build from tp link website and flash via openwrt interface?

No, to revert to stock firmware you need to use the tftp recovery method currently.

I updated to the latest firmware on http://luci.subsignal.org/~trondah/c2600/r48147/ (before I tried the one from Google Docs). However I'm running into an issue with the dynamic DNS service.

I'm using noip.com. It was supported in the original OpwnWRT firmware from google docs, but this latest one does not have it (it has no-ip.pl, which is a different service).

Is there a way to get this back?

stikves wrote:

I updated to the latest firmware on http://luci.subsignal.org/~trondah/c2600/r48147/ (before I tried the one from Google Docs). However I'm running into an issue with the dynamic DNS service.

I'm using noip.com. It was supported in the original OpwnWRT firmware from google docs, but this latest one does not have it (it has no-ip.pl, which is a different service).

Is there a way to get this back?

It is very easy to add back the support for noip.com and not related to Archer firmware, but to trunk. Edit /usr/lib/ddns/services and add this line after the last:
"no-ip.com" "http://[USERNAME]:[PASSWORD]@dynupdate.no-ip.com/nic/update?hostname=[DOMAIN]&myip=[IP]"

Use no-ip.com as the name of the service in your /etc/config/ddns file

Please help with TFTP Recovery.
I have tried to verify that C2600 has working TFTP recovery method before flashing bendavid/arokh roms.
Without success.
TFPTD on IP Address 192.168.0.66, file ArcherC2600_1.0_tp_recovery.bin
Powering on with Reset button pressed.
Router not downloading firmware.

What have I did wrong?

Archer C2600 with Archer_C2600_V1_150924 ROM,
Windows 10 with tftpd64 on IP 192.168.0.66 connected to port LAN1

I think you need to force link on your network adapter so there is a link when the router starts. If that fails you might have better luck putting a switch in-between the router and the Windows client.

Hi All

Having read the thread I'm looking to build against my own openwrt trunk that I use locally. I've seen there is a link to some patches in previous threads but then saw some improvements to the LED's and a few other bits, plus a few people working on the patched version.

Can anyone post me to the latest patch files that combine all the changes so that I can apply directly against my openwrt build?
Also, what folder do I need to place the patch(es) in order for them to be applied at build?

Thank you

James

tedster22 wrote:

Can anyone post me to the latest patch files that combine all the changes so that I can apply directly against my openwrt build?
Also, what folder do I need to place the patch(es) in order for them to be applied at build?

The current versions of the patches are to be found on the openWRT mailing list. bendavid is constantly reworking them to meet the precise standards of openWRT to get them in.

If after looking at the patches you still have to ask what directories to put them in, you probably aren't at a place to patch and build them yourself.

TeutonJon78 wrote:

The current versions of the patches are to be found on the openWRT mailing list. bendavid is constantly reworking them to meet the precise standards of openWRT to get them in.

If after looking at the patches you still have to ask what directories to put them in, you probably aren't at a place to patch and build them yourself.

I had seen the posts on the mailing list but they are duplicated and wanted to ensure I didn't miss anything.

I've been building OpenWrt from source for a few years now and generally only build against devices that have had official support added, so they are already present in the OpenWrt menuconfig. This is the first real time I'm in need of building against a device not yet added to trunk, and whilst not 100% sure on the correct place to put these patches to the build tree, I'm comfortable with the linux build environment in general.

So, I'm just asking for a few pointers, and then I'll figure the rest out.

Thanks

James

The patches apply to the toplevel of the OpenWrt source.

Thanks for the info.

However now I have problems with ssh. The log contains

Tue Jan 12 20:59:02 2016 authpriv.info dropbear[26752]: Early exit: Bad buf_getptr

and

Tue Jan 12 20:57:06 2016 daemon.info procd: Instance dropbear::instance1 s in a crash loop 6 crashes, 0 seconds since last crash

I searched the issue. There seems to be two different possible reasons:

1. It is missing a patch ( https://www.mail-archive.com/dropbear@u … 01323.html )
2. The root password is not set (but it is).

Is anybody else having problems with SSH?

arpena01 wrote:
stikves wrote:

I updated to the latest firmware on http://luci.subsignal.org/~trondah/c2600/r48147/ (before I tried the one from Google Docs). However I'm running into an issue with the dynamic DNS service.

I'm using noip.com. It was supported in the original OpwnWRT firmware from google docs, but this latest one does not have it (it has no-ip.pl, which is a different service).

Is there a way to get this back?

It is very easy to add back the support for noip.com and not related to Archer firmware, but to trunk. Edit /usr/lib/ddns/services and add this line after the last:
"no-ip.com" "http://[USERNAME]:[PASSWORD]@dynupdate.no-ip.com/nic/update?hostname=[DOMAIN]&myip=[IP]"

Use no-ip.com as the name of the service in your /etc/config/ddns file

(Last edited by stikves on 13 Jan 2016, 07:02)

SSH issue solved by uninstalling, and reinstalling the dropbear package (just restarting did not help).

And no-ip updates are working too smile

@stikves

I did have some reports about SSH issues lately, not sure what's up with that. Did you pull the power during first boot after flashing? The hostkeys in /etc/dropbear are empty until they are generated by the init script during first boot. In that case would be good if you could test a clean flash and wait a couple of minutes before trying SSH.

Yes, I restarted after the update, since the router did not respond for several minutes. Maybe that was a mistake...

arokh wrote:

@stikves

I did have some reports about SSH issues lately, not sure what's up with that. Did you pull the power during first boot after flashing? The hostkeys in /etc/dropbear are empty until they are generated by the init script during first boot. In that case would be good if you could test a clean flash and wait a couple of minutes before trying SSH.

Great work guys. I have built from source and everything is working great. The only two things I note, one of which is already known, is.

- WiFi LED's not working (known issue - any thoughts?)
- The interface MAC addresses are incorrect.

For example on the stock firmware, and printed on the label on the bottom of the unit, the MAC is: 60:E3:27:C8:5B:xx but ifconfig shows all interfaces to have some strange MAC (Atheros reference MACs by the looks of it):

br-lan    Link encap:Ethernet  HWaddr 00:03:7F:12:1D:1D
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:55510 errors:0 dropped:148 overruns:0 frame:0
          TX packets:413333 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2994921 (2.8 MiB)  TX bytes:621255158 (592.4 MiB)

eth0      Link encap:Ethernet  HWaddr 00:03:7F:BA:DB:01
          inet addr:172.16.40.73  Bcast:172.16.41.255  Mask:255.255.254.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:411505 errors:0 dropped:0 overruns:0 frame:0
          TX packets:52977 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:621082398 (592.3 MiB)  TX bytes:3279574 (3.1 MiB)
          Interrupt:255

eth1      Link encap:Ethernet  HWaddr 00:03:7F:BA:DB:02
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:55559 errors:0 dropped:0 overruns:0 frame:0
          TX packets:413342 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3775003 (3.5 MiB)  TX bytes:621255618 (592.4 MiB)
          Interrupt:2

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:58 errors:0 dropped:0 overruns:0 frame:0
          TX packets:58 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4616 (4.5 KiB)  TX bytes:4616 (4.5 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:34:56:78:5C:5C
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:5764 (5.6 KiB)

wlan1     Link encap:Ethernet  HWaddr 00:03:7F:12:1D:1D
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:5644 (5.5 KiB)


Did I miss something, or is this a known issue too?

Thanks

(Last edited by tedster22 on 15 Jan 2016, 10:39)

I have the MAC issue too - coincidentally I noticed when Google Services kept placing me at Qualcomm headquarter some place in California smile. For now I just it let it be...

buz2 wrote:

I have the MAC issue too - coincidentally I noticed when Google Services kept placing me at Qualcomm headquarter some place in California smile. For now I just it let it be...

Do you have the same MACs as me in your ifconfig or is it unique? Either way I am hoping there is a way for the geniuses working on the patch to extract the real MAC(s) from the device.

Thanks

Some seem to be the same


br-lan    Link encap:Ethernet  HWaddr 00:03:7F:12:F4:F4
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::203:7fff:feba:db02/64 Scope:Link
          inet6 addr: fda3:14ae:1f9d::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1197510 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1959835 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:474964088 (452.9 MiB)  TX bytes:2032044469 (1.8 GiB)

br-wan    Link encap:Ethernet  HWaddr 00:03:7F:BA:DB:01
          inet addr:zzzzzzz  Bcast:zzzzzz  Mask:255.255.248.0
          inet6 addr: fe80::203:7fff:feba:db01/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2321510 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1405045 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2067003673 (1.9 GiB)  TX bytes:571350376 (544.8 MiB)

eth0      Link encap:Ethernet  HWaddr 00:03:7F:BA:DB:01
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2961700 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1404446 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2140890969 (1.9 GiB)  TX bytes:571273267 (544.8 MiB)
          Interrupt:255

eth1      Link encap:Ethernet  HWaddr 00:03:7F:BA:DB:02
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:8354 errors:0 dropped:0 overruns:0 frame:0
          TX packets:87814 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:801287 (782.5 KiB)  TX bytes:7887344 (7.5 MiB)
          Interrupt:2


wlan0     Link encap:Ethernet  HWaddr 00:34:56:78:20:20
          inet6 addr: fe80::234:56ff:fe78:2020/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:107435 errors:0 dropped:0 overruns:0 frame:0
          TX packets:299246 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:13753306 (13.1 MiB)  TX bytes:207349633 (197.7 MiB)

wlan1     Link encap:Ethernet  HWaddr 00:03:7F:12:F4:F4
          inet6 addr: fe80::203:7fff:fe12:f4f4/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1211056 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2069114 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:499529288 (476.3 MiB)  TX bytes:1954914459 (1.8 GiB)

wlan1-1   Link encap:Ethernet  HWaddr 02:03:7F:12:F4:F4
          inet6 addr: fe80::3:7fff:fe12:f4f4/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:124913 errors:0 dropped:0 overruns:0 frame:0
          TX packets:108781 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:11556223 (11.0 MiB)  TX bytes:108244045 (103.2 MiB)

(Last edited by buz2 on 17 Jan 2016, 12:01)

buz2 wrote:

Some seem to be the same

Ah, not good!

Wifi status LED's:  The issue here is that these are not controlled through the same GPIO mechanism from the CPU as the other LED's, but are rather controlled directly from the QCA9980 wireless chips.  Needs some investigation how to handle this (or input from someone who has implemented support for a similar led configuration on previous Qualcomm/Atheros chips.)

For the MAC addresses, indeed this looks like a problem.  Probably the correct MAC addresses need to be read from the router flash, will look into that together with finishing revising the patches eventually.

bendavid wrote:

Wifi status LED's:  The issue here is that these are not controlled through the same GPIO mechanism from the CPU as the other LED's, but are rather controlled directly from the QCA9980 wireless chips.  Needs some investigation how to handle this (or input from someone who has implemented support for a similar led configuration on previous Qualcomm/Atheros chips.)

For the MAC addresses, indeed this looks like a problem.  Probably the correct MAC addresses need to be read from the router flash, will look into that together with finishing revising the patches eventually.

The TP-Link Archer C7 v2 is the closest board I can find that has full LED support using ath10k right now. It does have a QCA chip, bit 9880 not 9980, and the same switch. Maybe it will provide some help and be similar however?

https://dev.openwrt.org/browser/trunk/t … rcher-c7.c

Any help on the MACs would be great. I'm sure the MAC's are stored in the mtd/flash somewhere, it's just working out where. Does the stock firmware provide any mappings to it? Happy to test if you get the time to look.

Thanks

(Last edited by tedster22 on 19 Jan 2016, 10:40)