OpenWrt Forum Archive

Topic: Installing OpenWrt in Xiaomi Wifi Mini

The content of this topic has been archived between 8 Feb 2018 and 5 May 2018. Unfortunately there are posts – most likely complete pages – missing.

try this version of pandorabox

downloads.pandorabox.com.cn/pandorabox-16-10-stable/targets/ralink/mt7620/PandoraBox-ralink-mt7620-xiaomi-mini-2017-01-03-git-6c24a7a-squashfs-sysupgrade.bin

Its the latest chinese version of pandorabox.(jan 3rd 17 stable build)
(don't  try snapshots, its outdated and gui for especailly wireless works really wired)

I think its one of the most stable firmwares for mi mini router that I've tried

gui is in chinese but of course its luci
just change system setting from simplified chinese to auto. then, bam! english!

(or use scp tool to change config file.)

(Last edited by djseltus on 4 Mar 2017, 13:43)

Hi, I've been trying the lede versions for a while, but always got worse reception for 2,4 wifi, than the strangeorange version, wich I use as my stable fw.

The stable build of lede still has poor 2,4 wifi, but the newest snapshot (I've tried the one from last monday, now I am one the one from saturday) has a strong 2,4 wifi, I get the same results as the strangeorange one.

Just fyi. smile

I saw the LEDE project commit

https://github.com/lede-project/source/ … 0d8c3ae12f
https://github.com/lede-project/source/ … 0692408462

These 2 commit must make a better support for all MT7620 project.

The LEDE snapshot image include these patch
https://downloads.lede-project.org/snap … ps/mt7620/

as the commit log described. this patch is funded by kickstar project
https://www.kickstarter.com/projects/13 … nwrt-lede/

Thanks to Daniel Golle and the backers to support this project.

changeway wrote:

I saw the LEDE project commit
....

Yup. Those patches landed on the 69th lede snapshot build.

h t t p : //phase1.builds.lede-project.org/builders/ramips%2Fmt7620/builds/69

I'm going to give lede another go.

******************************************************************************************************************
UPDATE:

Even after an additional commit for our wireless that made it in today: h t t p : //phase1.builds.lede-project.org/builders/ramips%2Fmt7620/builds/76

rt2x00: mt7620: make fixes requested upstream
Introduce RT6352 instead of matching against RF7620.
Clean up channel setting rfvals.
Port bandwidth filter calibration.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>

The wireless stability and performance is no better. Unfortunately the 2.4Ghz performance still suffers some very notable dropped packets and degredation which can be seen in network graphs whilst under load.

I simply do not see this behaviour on builds using proprietary libraries - which is a given. I'll certainly keep checking back at lede as it seems to be making some big strides as of late; not to mention active support.

(Last edited by stickman89 on 11 Mar 2017, 23:36)

Hey Guys,Im a Newbie, Please help me.
Im using Mi Wifi Mini
I tried the PandoraBox firmware with this step
-Flash dev rom "miwifi.bin" from Xiaomi
-Flash "miwifi_ssh.bin"
-Connect to ssh and run "mtd -r write PandoraBox.bin OS1"
It totally work, blue light signal ! I can using PandoraBox perfectly.

But when i tried other firmware,not PandoraBox,ex:"openwrt-15.05-ramips-mt7620-xiaomi-miwifi-mini-squashfs-sysupgrade.bin" from Link:downloads.openwrt.org/chaos_calmer/15.05/ramips/mt7620/ (I cant post the link) ,It didnt work.I got a red light signal from the Router. I did the same as above step: Flash dev rom > flash miwifi_ssh.bin > flash openwrt image. But it didnt work.

Is that the right way to flash openwrt image on this router.
Any solution for this. Thanks you guys.
*Sorry for my bad English.

latest lede snapshot build's 2.4ghz radio performs way better then before
no more packet drop, loss, 60mbps limitation

(Last edited by djseltus on 21 Mar 2017, 08:16)

hptaist wrote:

Hey Guys,Im a Newbie, Please help me.
Im using Mi Wifi Mini
I tried the PandoraBox firmware with this step
-Flash dev rom "miwifi.bin" from Xiaomi
-Flash "miwifi_ssh.bin"
-Connect to ssh and run "mtd -r write PandoraBox.bin OS1"
It totally work, blue light signal ! I can using PandoraBox perfectly.

But when i tried other firmware,not PandoraBox,ex:"openwrt-15.05-ramips-mt7620-xiaomi-miwifi-mini-squashfs-sysupgrade.bin" from Link:downloads.openwrt.org/chaos_calmer/15.05/ramips/mt7620/ (I cant post the link) ,It didnt work.I got a red light signal from the Router. I did the same as above step: Flash dev rom > flash miwifi_ssh.bin > flash openwrt image. But it didnt work.

Is that the right way to flash openwrt image on this router.
Any solution for this. Thanks you guys.
*Sorry for my bad English.

just flash the firmware on the pandorabox gui (but don't check the keep settings option)
system->backup / flash firmware

anyway don't use chaos calmer openwrt
its outdated and no longer sustained

I recomand
prometheus firmware(more user friendly ui, more built in features w/o installing package and setting, but radio performace is not that good), lede snapshot build(its performance is the best, but little bit unstable), latest chinese version of pandorabox

prometheus.freize.net
downloads.lede-project.org/snapshots/targets/ramips/mt7620/lede-ramips-mt7620-miwifi-mini-squashfs-sysupgrade.bin
downloads.pandorabox.com.cn/pandorabox-16-10-stable/targets/ralink/mt7620/PandoraBox-ralink-mt7620-xiaomi-mini-2017-01-03-git-6c24a7a-squashfs-sysupgrade.bin

djseltus wrote:

just flash the firmware on the pandorabox gui (but don't check the keep settings option)
system->backup / flash firmware

anyway don't use chaos calmer openwrt
its outdated and no longer sustained

I recomand
prometheus firmware(more user friendly ui, more built in features w/o installing package and setting, but radio performace is not that good), lede snapshot build(its performance is the best, but little bit unstable), latest chinese version of pandorabox

prometheus.freize.net
downloads.lede-project.org/snapshots/targets/ramips/mt7620/lede-ramips-mt7620-miwifi-mini-squashfs-sysupgrade.bin
downloads.pandorabox.com.cn/pandorabox-16-10-stable/targets/ralink/mt7620/PandoraBox-ralink-mt7620-xiaomi-mini-2017-01-03-git-6c24a7a-squashfs-sysupgrade.bin

Hi I'm running Prometheus if I want to switch to LEDE cant I just download .bin file and flash on the firmware upgrade menu?

grand_x wrote:
djseltus wrote:

just flash the firmware on the pandorabox gui (but don't check the keep settings option)
system->backup / flash firmware

anyway don't use chaos calmer openwrt
its outdated and no longer sustained

I recomand
prometheus firmware(more user friendly ui, more built in features w/o installing package and setting, but radio performace is not that good), lede snapshot build(its performance is the best, but little bit unstable), latest chinese version of pandorabox

prometheus.freize.net
downloads.lede-project.org/snapshots/targets/ramips/mt7620/lede-ramips-mt7620-miwifi-mini-squashfs-sysupgrade.bin
downloads.pandorabox.com.cn/pandorabox-16-10-stable/targets/ralink/mt7620/PandoraBox-ralink-mt7620-xiaomi-mini-2017-01-03-git-6c24a7a-squashfs-sysupgrade.bin

Hi I'm running Prometheus if I want to switch to LEDE cant I just download .bin file and flash on the firmware upgrade menu?

nope, u should revert it back first
run Prometheus linux terminal, then u can find restore option

or if u already removed the backup or whole Prometheus installer, then just flash the dev firmware and ssh with usb again

(Last edited by djseltus on 22 Mar 2017, 11:15)

i want change from lede to pandorabox, do i need to revert to mi firmware dev ?

baolinhtv wrote:

i want change from lede to pandorabox, do i need to revert to mi firmware dev ?

No, there is no need to revert to the Xiaomi dev firmware for your scenario.
Simply flash the '.bin' firmware image via Luci @System > Backup / Flash Firmware > Flash new firmware image.

Or alternatively issue the following commands via SSH:

jffs2reset -y

Issue the above 'jffs2reset' command if you wish to restore the default configuration prior to flashing, otherwise ignore this step to retain your current configuration.

Then use the following command:

sysupgrade -n /path/to/firmware/image/firmware_filename_here.bin

You can either use wget (assuming your access point has internet access) to obtain your firmware image, or you can transfer your firmware image to a directory residing on your access point via SCP; remembering to amend the path and filename presented in the 'sysupgrade' command enlisted above.

Best Regards,

Stickman89

(Last edited by stickman89 on 23 Mar 2017, 20:40)

Thank you so much
I flashed ok
But i have question about how to build package from SDK of Pandorabox
It empty list in feed.conf.default
I dont know where to get base source for it
I want build wifidog package for Pandorabox

I'm running LEDE snapshot on Xiaomi Mini and speed/stability seems to be fine, but I noticed a weird behaviour with wireless channels - if I set channels 10/11 for 2.4Ghz band, SSID broadcasting stops, no warning or errors given.

I'm using pandorabox 16.10 stable, mobile phone can't connect to 5ghz wifi ... 2.4ghz still ok
how to check or know it (wireless) work ok ?
thank you all

djseltus wrote:

nope, u should revert it back first
run Prometheus linux terminal, then u can find restore option

or if u already removed the backup or whole Prometheus installer, then just flash the dev firmware and ssh with usb again

I'm using Breed bootloader I'm sure that I need flash dev firmware first that's right?
Thank you.

anarchy99 wrote:

with lede tx/rx 80/80 Mbps, with openwrt i manage to get 95/80 Mbps

That's some pretty good results. Are you getting this on 2.4Ghz band?

My Mini with LEDE only gives me ~22Mbps max on 2.4Ghz. Another router of mine using the same uplink - ~70Mbps.

yes, 2.4

anarchy99 wrote:

yes, 2.4

Wow, would you mind to share your wireless config?

anarchy99 wrote:

HT40
noscan 1
channel 13

not sure but i think i used this patch:

Isn't this the "Kickstarter" patch? I mean the one made by Daniel Golle and funded using Kickstarter.
If it is, I believe it's already a part of the LEDE snapshot build so there is no need to apply it manually.

I believe I'm running it, and I still can't get more than 21Mbps on 2.4Ghz band sad

no. some parts of the patch are from his staging tree, others i've made myself. i've built lede without any changes and got 80Mbps both way, then tried to apply his changes to openwrt but got extremly strong signal with tx rate at 90Mbps or less resulting in bad throughput. so i used these changes (or maybe even some others i'm not sure since i have several buildroots accros variosu dirs on my machine) and got tx 95 rx 80 under same conditions

what client card do you use and which OS?

(Last edited by anarchy99 on 27 Mar 2017, 08:30)

anarchy99 wrote:

no. some parts of the patch are from his staging tree, others i've made myself. i've built lede without any changes and got 80Mbps both way, then tried to apply his changes to openwrt but got extremly strong signal with tx rate at 90Mbps or less resulting in bad throughput. so i used these changes (or maybe even some others i'm not sure since i have several buildroots accros variosu dirs on my machine) and got tx 95 rx 80 under same conditions

what client card do you use and which OS?

I'm testing from iPhone 6, Nexus 5 and a desktop iMac. Same result everywhere - 20Mbps. Using LAN ports gives me full speed so it's definitely a wireless issue.

Have just tried the latest LEDE build - no difference.

PS. I've just noticed that if I use Image Builder - my resulting image only goes up to 20Mbps, but if I install pre-built snapshot image - the speeds are higher. Could it be that Image Builder is downloading an older package/module, when fetching dependencies? Anyway, I'll try to build from source now, see if it makes any difference. I need to include extra files with the image, so using a pre-built image is not an option for me.

(Last edited by dusterio on 27 Mar 2017, 09:17)

I am also on latest Pandora, this is the best FW in my opinion. Fast, stable, custom addons, IP Bandwidth, wshapper, just everything !!!

Wow, it's great to see so many engineers discuss how to enable openWrt on this cheap device. I would like to install DslrDashboardServer to enable remove control my DSLR.

But one more confusion, are we talking about this one?
http://c1.mifile.cn/f/i/2013/cn/goods/miniwifi/bg-05.jpg
http://c1.mifile.cn/f/i/2014/cn/goods/minimiwifi/bg-01-02.jpg

(Last edited by lightseed on 11 Apr 2017, 15:48)

Hello, i am on the latest pandorabox 17.01 and in kernel log is still repeating following error:

[ 6506.208000] ACT - SendBSS2040CoexistMgmtAction( BSSCoexist2040 = 0x6 )  
[ 6506.212000] ACT - SendBSS2040CoexistMgmtAction( BSSCoexist2040 = 0x6 )  
[ 6506.220000] ACT - SendBSS2040CoexistMgmtAction( BSSCoexist2040 = 0x6 )  
[ 6506.228000] ACT - SendBSS2040CoexistMgmtAction( BSSCoexist2040 = 0x6 )  
[ 6725.584000] ACT - SendBSS2040CoexistMgmtAction( BSSCoexist2040 = 0x6 )  
[ 6725.588000] ACT - SendBSS2040CoexistMgmtAction( BSSCoexist2040 = 0x6 )  
[ 6725.596000] ACT - SendBSS2040CoexistMgmtAction( BSSCoexist2040 = 0x6 )  
[ 6725.604000] ACT - SendBSS2040CoexistMgmtAction( BSSCoexist2040 = 0x6 )  
[ 6872.024000] ACT - SendBSS2040CoexistMgmtAction( BSSCoexist2040 = 0x6 )  
[ 6872.032000] ACT - SendBSS2040CoexistMgmtAction( BSSCoexist2040 = 0x6 )  
[ 6872.036000] ACT - SendBSS2040CoexistMgmtAction( BSSCoexist2040 = 0x6 )  
[ 6872.044000] ACT - SendBSS2040CoexistMgmtAction( BSSCoexist2040 = 0x6 )  
[ 7017.968000] ACT - SendBSS2040CoexistMgmtAction( BSSCoexist2040 = 0x6 )  
[ 7017.976000] ACT - SendBSS2040CoexistMgmtAction( BSSCoexist2040 = 0x6 )  
[ 7017.984000] ACT - SendBSS2040CoexistMgmtAction( BSSCoexist2040 = 0x6 )  

Does anyone who is using also pandorabox having the same issue? What it should mean?

System log:

Tue Apr 11 16:26:24 2017 kern.alert kernel: [115215.076000] ACT - SendBSS2040CoexistMgmtAction( BSSCoexist2040 = 0x6 )  
Tue Apr 11 16:26:24 2017 kern.alert kernel: [115215.080000] ACT - SendBSS2040CoexistMgmtAction( BSSCoexist2040 = 0x6 )  
Tue Apr 11 16:26:24 2017 kern.alert kernel: [115215.088000] ACT - SendBSS2040CoexistMgmtAction( BSSCoexist2040 = 0x6 )  
Tue Apr 11 16:26:24 2017 kern.alert kernel: [115215.096000] ACT - SendBSS2040CoexistMgmtAction( BSSCoexist2040 = 0x6 )  
Tue Apr 11 16:28:50 2017 kern.alert kernel: [115361.300000] ACT - SendBSS2040CoexistMgmtAction( BSSCoexist2040 = 0x6 )  

I noticed, that the log is showing when i have connected my 2nd laptop (2.4G)...  What can it be?? Any app? There is WIN 10, system running fine, the wifi also..

Any ideas? THANKS !

(Last edited by kaper on 11 Apr 2017, 20:21)