OpenWrt Forum Archive

Topic: Bricked tp-link wr1043nd

The content of this topic has been archived on 19 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hey guys,

I have a Tp-link wr1043 nd router that I've unfortunately bricked.

following the serial unbrick guide I've soldered pins to the PCB and i've connected the router to my pc using the serial port

Thing is, I only get this from the serial port:

https://dl.dropboxusercontent.com/u/1705303/dasdadsad.PNG

U-Boot 1.1.4 (Jun 13 2014 - 15:14:01)

ap135 - Scorpion 1.0DRAM:
sri
Scorpion 1.0
ath_ddr_initial_config(211): (16bit) ddr1 init
tap = 0x00000002
Tap (low, high) = (0xaa55aa55, 0x0)
Tap values = (0x8, 0x8, 0x8, 0x8)
 4 MB

Any help would be appreciated :C

(Last edited by maxpaynner on 22 Jan 2015, 15:09)

Take a look at that

Hey guys I was able to unbrick my router. I pasted the image contents in text so that this post will be easier to find for others with the same problem.

I was following this guide http://sjoosten.nl/2013/07/unbrick-tl-wr1043nd.html and got stuck at this point. The problem was with my USB-TTL converter. I was using a Prolific based TTL converter and it wasn't working properlly.

I wound up using my Arduino Leonardo as an usb to ttl converter as per https://petervanhoyweghen.wordpress.com … converter/ and it worked perfectly. I flashed the latest factory firmware using

tftp 0x80060000 openwrt-ar71xx-generic-tl-wr1043nd-v2-squashfs-factory.bin
erase 0x9f020000 +0x7c0000
cp.b 0x80060000 0x9f020000 0x7c0000
boot.m 0x9f020000

Thanks for your help smile

I can confirm that using an Arduino Uno, I was able to unbrick my TP Link WR1043ND V2 router. I was getting the same error as the OP posted above using a standard USB-TTL converter, however thanks to his advice I tried using an Arduino Uno at it worked perfectly for me.

I later followed the guide posted by gtanases at http://www.dd-wrt.com/phpBB2/viewtopic.php?p=880506 to flash my router once I was able to access the console through putty.

Maxpaynner, thank you for sharing this and helping me unbrick my router using the Arduino! :-)

The discussion might have continued from here.