OpenWrt Forum Archive

Topic: OpenWrt and USB Wifi Hotspot with Ralink RT5370

The content of this topic has been archived on 15 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi, I have a wifi usb dongle with Ralink RT5370 Chipset installed on OpenWrt (which relies on an Atheros CPU) .
I'd like to establish a direct WIFI connection between the Atheros and my PC, so the new dongle must work as hotspot.

The installation of the related packages on OpenWrt was fine and the OS recognized the new dongle.

opkg install kmod-rt2800-lib kmod-rt2800-usb kmod-rt2x00-lib kmod-rt2x00-usb

Since my Atheros has an integrated WIFI I tried to disable the internal WIFI and enable the new one via Luci Interface. and modifying /etc/config/wireless but I didn't solve the problem. My pc tries to connect to the wifi (new dongle interface) but gets no IP. I think it's  an OpenWrt's DHCP server problem .   Have you got some tips? Which files do I need to modify ? Thanks

my /ect/config/wireless file

config wifi-device 'radio0'
    option type 'mac80211'
    option channel '11'
    option hwmode '11ng'
    option path 'platform/ar933x_wmac'
    option htmode 'HT20'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option disabled '0'

config wifi-iface
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option encryption 'none'
    option ssid 'Arduino Yun-9'

config wifi-device 'radio1'
    option type 'mac80211'
    option channel '11'
    option hwmode '11ng'
    option path 'platform/ehci-platform/usb1/1-1/1-1.1/1-1.1:1.0'
    option htmode 'HT20'
    list ht_capab 'GF'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'RX-STBC1'

config wifi-iface
    option device 'radio1'
    option network 'lan'
    option mode 'ap'
    option ssid ‘DongleWifi’
    option encryption 'none' 

my /etc/config/dhcp file

config dnsmasq
    option domainneeded '1'
    option boguspriv '1'
    option filterwin2k '0'
    option localise_queries '1'
    option rebind_protection '1'
    option rebind_localhost '1'
    option local '/lan/'
    option domain 'lan'
    option expandhosts '1'
    option nonegcache '0'
    option authoritative '1'
    option readethers '1'
    option leasefile '/tmp/dhcp.leases'
    option resolvfile '/tmp/resolv.conf.auto'
    option nonwildcard '1'
    list interface 'lo,wlan0'

config dhcp 'lan'
    option interface 'lan'
    option start '100'
    option limit '150'
    option leasetime '12h'

config dhcp 'wan'
    option interface 'wan'
    option ignore '1'

(Last edited by rocker on 1 Mar 2015, 13:39)

up!

The discussion might have continued from here.