For the past couple of days, I've been trying to make alsa work fully with a usb audio card on a WGT634U. Since full-duplex didn't appear to work with OSS emulation (although I'm not sure how to test it correctly, other than try to open /dev/dsp for r/w), and asterisk's chan_oss seems to only slow down the box, I've tried compiling alsa-lib, -utils and esound, using the packages here:


They compile fine (tried up to 1.0.11, including alsa-driver), but nothing using libasound seems to work (except esd, which works, but _very_ slowly).

Crashes when pressing F1-F4, but not F5 (??), otherwise seems fine

arecord (all formats/options, it seems):
Recording WAVE '(null)' : Unsigned 8 bit, Rate 8000 Hz, Mono
Floating point exception

Playing WAVE 'play.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
aplay: set_params:1005: unable to install sw params:
start_mode: EXPLICIT
xrun_mode: NONE
tstamp_mode: NONE
period_step: 1
sleep_min: 0
avail_min: 0
xfer_align: 268443944
silence_threshold: 0
silence_size: 0
boundary: 1073741824

madplay (compiled with alsa support):
MPEG Audio Decoder 0.15.2 (beta) - Copyright (C) 2000-2004 Robert Leslie et al.
           Year: 2002
Segmentation fault
(using oss works fine)

(the card itself doesn't seem to be the problem, I've been using it for a while even with older 2.6 kernels)

Any ideas? (I've also tried enabling "soft-float" option and recompiling everything, without much effect (esd beeps slightly faster smile