OpenWrt Forum Archive

Topic: Wifi N on Linksys WRT320N

The content of this topic has been archived on 9 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi,

I'm trying to get Wifi with N speed to work on my Linksys WRT320N, but i seem to be having some troubles getting above Wifi G speeds.

My /etc/config/wireless looks like this:

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'bcma0:1'
        option txpower '20'
        option country 'NL'
        option channel '11'
        option noscan '1'
        option hwmode '11g'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWRT'
        option key '**********'
        option encryption 'psk2+ccmp'

The above config is a mixture from results i found on these forums and the OpenWRT wiki. The net result is wigi g with 54 mbit/s (that is if i'm lucky and basically sitting on top of the router). I tried setting htmode to HT40- but that apparently completely disables my wifi.

I'm sure Wifi N speeds are possible on this router, i must be missing some obvious setting somewhere?

Also, the radio0 is displayed as b/g radio in the OpenWRT web admin. Why is that? It's most certainly N capable.

The firmware version i'm using:
OpenWrt Chaos Calmer 15.05-rc1 / LuCI Master (git-15.126.50380-7a54785)

I hope someone can help me solving this issue?

Cheers,
Mark

Zajec, it would be nice if you could be a little more elaborate instead of just pointing me to links as hints..

Anyway, the first link was the hint i needed to get this to work. And to help others out that might have the same issue, i will describe what i did to get it working.

First is installed the following packages: kmod-brcm-wl wl wlc nas
Then i disabled the b43 driver in /etc/modules.d/b43 (just remove the line in that file or put a # before it.
Then i copied the sample wireless config to /etc/config/wireless:

config wifi-device 'wl0'
    option type 'broadcom'
    option disabled '0'
    option channel '4'
    option txpower '16'

config wifi-iface
    option device 'wl0'
    option network 'lan'
    option ssid 'OpenWrt'
    option key 'passphrase'
    option mode 'ap'
    option encryption 'psk2'

followed by the following commands:

root@OpenWrt:~# wl -i wl0 chanspec -c 9 -b 2 -w 40 -s 1
root@OpenWrt:~# wl -i wl0 down
root@OpenWrt:~# wl -i wl0 up

At that point i just rebooted. Just to be sure that the right modules would be loaded (and unloaded).

After a reboot i had a new wireless AP in my wifi list so i used the OpenWRT web interface to further change wifi settings as i deemed right. I now have a working wifi-n connection! Yay smile

(Last edited by markg85 on 31 May 2015, 23:37)

The discussion might have continued from here.