OpenWrt Forum Archive

Topic: TP-WR741ND v5.0 Barrier Breaker 14.07 howto

The content of this topic has been archived on 2 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Try this on your OWN RISK!!! I won't be responsible for ruined equipment!

This guide supposes that you have fresh v5.0 device with original firmware, and that you know how to flash Openwrt. If not so please read following link before proceeding: http://wiki.openwrt.org/toh/tp-link/tl- … stallation

1st  - download wr741nd-v5-squashfs-factory.bin snapshot from trunk: http://downloads.openwrt.org/snapshots/ … actory.bin

2nd - Upload and flash squashfs-factory.bin over original TP-LINK (WARNING: note that snapshot doesn't include Luci by default so you have to telnet to device)

3rd - download Barrier Breaker 14.07 wr741-v4-squashfs-sysupgrade.bin from: https://downloads.openwrt.org/barrier_b … pgrade.bin

4th - SCP to device (if on Windows use Winscp) and upload downloaded wr741nd-v4-squashfs-sysupgrade.bin to "/tmp"

5th - telnet to device (suggest you to read: http://wiki.openwrt.org/doc/howto/generic.sysupgrade before proceeding)

6th - enter command in console "sysupgrade -n -v -F /tmp/openwrt-ar71xx-generic-tl-wr741nd-v4-squashfs-sysupgrade.bin"
(this will force flash to skip hardware check)

Wait for process to finish (watch for blinking leds), and after cca. 2 min you can telnet or browse to your router (as now it has Luci installed).
Theoretically using this method you can also install Attitude Adjustment 12.09 (watch to use wr741nd-v4-squashfs-sysupgrade.bin), but I only tested device with Barrier Breaker 14.07.

Excellent for me. Tested on wr740n-v5.

Thanks you

Any experiences with flashing V5.1?

i just install epenwrt on my wr740n v5.1

172.16.193.250
255.255.255.248
172.16.193.249
101.2.166.26
8.8.8.8
this ip i got from my isp

please help me how i configure my router.

ahadcox wrote:

i just install epenwrt on my wr740n v5

Please don't do double posts, I will answer you on the first one
This is off topic, if you are in a urgency and can't wait, in the mean flash back to stock, you need a Bin without boot download from here, http://www.friedzombie.com/tplink-stripped-firmware/ make sure you download the right file model and version, from LuCi Sysrem/back up firmware upload it
At the bottom Flash new firmware image and uncheck keep serttings
Once back to TL upgrade FW to a new one from TL web.

(Last edited by danymarc on 9 Jan 2016, 15:28)

If I were to go for this guide with TP-WR741ND V5 (on the back 5.1 in the firmware stat page 5.0)
I would be using chaos calmer V4 I assume, since its newer than Barrier Breaker and at the time of OP writing this, it was not an option... but now it is...

Also what is the reason to do it this way?
uploading that sysupgrade image, its mentioned that it skips hardware check.. is that all?

I am considering just sticking with trunk build since it seems to be working, and configuring it through cli only
luci I cant install, it says "No space left on device" so I am looking around

/EDIT

Yeap, all went well, I followed first posts guide but used Chaos Calmer 15.05 and not barrier Breaker.
Now I have luci, and all seems to be working well

(Last edited by DoTheEvo on 2 Feb 2016, 00:32)

741 nd v5.0 working thanks

*** Update: 6/5/2016

Have been having frequent disconnection/wireless dropping issues.

Noticed today that the version reported in overview page is:
TP-Link TL-WR741N/ND v4

.. However, the version printed on the box is 5.1 .

Also noticed that I reported installing what looks like a v4 squashfs.

root@OpenWrt:~# cat /proc/cpuinfo
system type        : Atheros AR9330 rev 1
machine            : TP-LINK TL-WR741ND v4

It looks like the version reported is V4, not V5?

Not sure what I was referring to in this post when I said the web interface reported 5.0 ... Maybe I meant the original factory firmware

I think the disconnects are due to using incorrect firmware, so I'm looking into 5.0 firmware.

***

Followed the guide above, but used https://downloads.openwrt.org/chaos_cal … pgrade.bin

Worked like a charm.

I'm impressed at how easy the setup was:

Went from out-of-the-box ( just ordered 3 days ago ) TP-WR741ND 5.1 ( on the unit ) / 5.0  ( on the web interface ), navigated to the firmware update page and updated with openwrt-ar71xx-generic-tl-wr741nd-v5-squashfs-factory.bin.

Waited for the reboot to finish, then pinged for 192.168.1.1 instead of 192.168.0.1. SSHed in as root@192.168.1.1 and scp'ed the -sysupgrade.bin image above to /tmp. Then issued the command to update the firmware while bypassing the hardware check. Waited for it to reboot again, and then found I was unable to SSH in anymore.

Hit the web interface and found it asking to change my password. Still was unable to SSH in, so I change my password under administration. Then I think I was able to SSH in after doing that.

Then I tried to get wireless working through luci, and made a real mess out of everything. ( Something about the interface wasn't immediately intuitive to me -- I think it was not being able to 'see' what eth0 and eth1 were supposed to be ... )  Anyway, figured that I could do a factory reset by holding down the reset switch, which worked as expected.

Afterward, was able to get all the settings exactly like I want them, with a separate guest network, and everything. ( https://wiki.openwrt.org/doc/recipes/gu … binterface )

*** Update: See top of this post ...

(Last edited by cognitiaclaeves on 6 Jun 2016, 07:00)

Upgrading to V5  via sysupgrade was easy enough. But then it left me without an interface ( not to mention on the  bleeding edge ), and apparently there isn't enough room in the router to install Luci.

( I may have one of the cheaper Chinese models, with only 2M of flash. )

... This was how I found out that it's quite easy to fill up all available space on the router ... an unpleasant situation that you might want to avoid, if at all possible. Fortunately, I was able to flash over it with sysupgrade again, even though I had triggered the 'no space left on the device' error.

According to the supported hardware table ( https://wiki.openwrt.org/toh/start?data … ~%5D=741nd ), v5 is supposed to be supported by r46238 ( this is seen by clicking on the device page, https://wiki.openwrt.org/toh/tp-link/tl-wr741nd ), and while there is a note at the bottom of the page saying that actual revs will vary more than what's updated in the wiki, what I actually got when I installed it was: Bleeding Edge, r49377 . That's quite a difference in revs!

And after installing it, I was still having connection issues. This time with my Nexus 5x.  Switching it to always use the 2.4GHz band ( instead of automatic ) seemed to make the connection stable. ... But now I have a router that isn't stable on 5GHz.

This post ( that I'm replying to ) advocates installing a V4 image while ignoring the hardware check ... and it might do that because the hardware itself for "V5.1" reports as "TP-LINK TL-WR741ND v4" ( at least it does when querying /proc/cpuinfo.)

If you're really persistent, you might find this thread: https://forum.openwrt.org/viewtopic.php?id=47382 for installing Chaos Calmer on your 741ND .. spoiler, as of 5/8/2016, it's EOL.

( I ended up installing this one, and it appeared to work well, until I noticed that we were having issues with wireless dropping out all the time ... )

Bottom line, 741ND is nowhere in on this page:

https://wiki.openwrt.org/toh/views/toh_ … ~%5D=741nd

I might stick with r49377 for a while ( provided that there are no other issues than not being able to use 5GHz, and that I don't decide that I really want the 5GHz option ) ...  at least until I can make the time to flash-back to the manufacturer's firmware.

If it were me, and I would have read this, I might have stayed with the manufacturer's firmware. ( Or at least have been more prepared to accept the consequences if I decided to install OpenWRT anyway! )

It would really be nice if a release for a UI was made for v5 of the WR741ND soon.

Oh, and this page: https://wiki.openwrt.org/doc/uci/wireless ... was really hard to follow. If you find yourself having to configure wireless via ssh, skip that page, and check out this video instead:  https://youtu.be/U0Gk9TnMrFQ

In this video, he essentially uses these commands:
vi /etc/config/wireless
wifi down && sleep 4 && wifi up

.. which was much easier than trying to make sense of the wireless page.

(Last edited by cognitiaclaeves on 6 Jun 2016, 07:11)

cognitiaclaeves wrote:

I might stick with r49377 for a while ( provided that there are no other issues than not being able to use 5GHz, and that I don't decide that I really want the 5GHz option

I dont understand this one 741 does not support 5GHz

Well that was quite a basic thing for me to miss ...

I'm back at this, still having issues with wireless.

Dear all.

I went throw steps 1 - 4 but now I cannot telnet to device:
a. open 192.168.1.1 23 - cannot connect
b. open 192.168.1.1 22 - I receive message like this:
------------------------------------------------------------------------------------------------------
SSH-2.0-dropbear_2016.74
☺¶
  ¶═'Ě°GńvŚű×~(^(F░mcurve25519-sha256@libssh.org,diffie-hellman-group14-sha1,dif
fie-hellman-group1-sha1,kexguess2@matt.ucc.asn.aussh-rsa§aes128-ctr,aes256-ctr§a
es128-ctr,aes256-ctr↕hmac-sha1,hmac-md5↕hmac-sha1,hmac-md5♦none♦noneĄ=╣l@Ę<|Z
-----------------------------------------------------------------------------------------------------------------------
What I'm doing wrong?

The discussion might have continued from here.