Hi JohnV & RangerZ,
Thanks a lot for the reply. Yes we are using AR9344.
We will explain our scenario in details:
Initially we configure the wireless config file as below:
config wifi-device 'wifi0'
option type 'qcawifi'
option macaddr '00:26:75:bd:37:24'
option hwmode '11ng'
option txpower '16'
option htmode 'HT20'
option disabled '0'
option channel '11'
config wifi-iface
option device 'wifi0'
option mode 'ap'
option ssid 'LANSSID'
option network 'lan'
option encryption 'psk2'
option key 'LANSSID_2.4'
option vap_ind '1'
option athnewind '1'
option scanband '1'
and network file :
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth0.1 eth1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.5.1'
option netmask '255.255.255.0'
config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'
config switch
option name 'eth0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'eth0'
option vlan '1'
option ports '0t 2 3 4 5'
config switch_vlan
option device 'eth0'
option vlan '2'
option ports '0t 1'
config switch
option name 'eth1'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'eth1'
option vlan '1'
option ports '0 1 2 3 4 5'
So this works fine as AP mode.
-----------------------------------------------------------------------
Then we scan the network and join one of the wireless AP/hotspot.
We configure the wireless config file as below:
config wifi-device 'wifi0'
option type 'qcawifi'
option macaddr '00:26:75:bd:37:24'
option hwmode '11ng'
option txpower '16'
option htmode 'HT20'
option disabled '0'
option channel '11'
config wifi-iface
option device 'wifi0'
option mode 'ap'
option ssid 'LANSSID'
option network 'lan'
option encryption 'psk2'
option key 'LANSSID_2.4'
option vap_ind '1'
option athnewind '1'
option scanband '1'
config wifi-iface
option network 'wwan'
option ssid 'WirelessRouter'
option encryption 'psk2'
option device 'wifi0'
option mode 'sta'
option key '0009593460'
option wds '1'
and network file:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth0.1 eth1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.5.1'
option netmask '255.255.255.0'
config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'
config switch
option name 'eth0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'eth0'
option vlan '1'
option ports '0t 2 3 4 5'
config switch_vlan
option device 'eth0'
option vlan '2'
option ports '0t 1'
config switch
option name 'eth1'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'eth1'
option vlan '1'
option ports '0 1 2 3 4 5'
config interface 'wwan'
option proto 'dhcp'
If we do this process using wired connection everything works fine, we are join the other network. but when we use wireless to configure this process during joining the wireless AP its disconnect the connection because the during connecting the OpenWrt change the /etc/config/network, /etc/config/dhcp etc.. file.
If we try to connect to wireless AP of same network also it disconnect the connection using wireless.
Sorry for the very lengthy post, but it is just trying to word down the scenario that I am looking at to configure the wifi module.
Mainly we have to configure for AP and router mode at same time.
Could you pleas suggest can we do this process using wireless connection.
(Last edited by afkar.ec on 17 Sep 2015, 03:49)