OpenWrt Forum Archive

Topic: OpenWRT on Asus RT-AC51U

The content of this topic has been archived between 12 Apr 2018 and 2 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi,

here is the content of /etc/config/network:

cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd78:c5af:87f3::/48'

config interface 'lan'
        option force_link '1'
        option macaddr 'a6:7b:54:bd:b2:1a'
        option type 'bridge'
        option proto 'static'
        option ipaddr '10.0.0.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ifname 'eth0.1 tap_myvpn'

config interface 'wan'
        option ifname 'eth0.2'
        option force_link '1'
        option macaddr 'a6:7b:54:bd:b2:1b'
        option proto 'static'
        option ipaddr '192.168.1.80'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config interface 'vpn0'
        option ifname 'tun0'
        option proto 'none'
        option auto '1'

I use trunk branch trunk, DESIGNATED DRIVER (r47159).

Francis.

It's very possible that mt76 module do not support PCI vendor & device ID of 2-nd wifi. Can you show vendor and device ID?

Hi 123serge123,

Where can I find these information? Should I look on chipsets soldered to the board?

Thank you.
Francis.

See content of files vendor & device in dir /sys/bus/pci/*/ (where * - device number.function on pci-bus). Or output of

lspci -v

But I don't remember  which package contain this utility (possibly in pci-util  or  busybox).

Hi,

so I installed pciutils package and here is the command output:

root@OpenWrt:/# lspci -v
00:00.0 PCI bridge: Ralink corp. Device 0801 (rev 01) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Memory at <unassigned> (32-bit, non-prefetchable) [size=2]
        Memory at 20200000 (32-bit, non-prefetchable) [size=64K]
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        Memory behind bridge: 20000000-201fffff
        Expansion ROM at <unassigned> [disabled] [size=2]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Root Port (Slot-), MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Virtual Channel
lspci: Unable to load libkmod resources: error -12

01:00.0 Network controller: MEDIATEK Corp. Device 7650
        Subsystem: MEDIATEK Corp. Device 7650
        Flags: bus master, fast devsel, latency 0, IRQ 4
        Memory at 20000000 (32-bit, non-prefetchable) [size=1M]
        Memory at <unassigned> (32-bit, non-prefetchable) [size=2]
        Memory at <unassigned> (32-bit, non-prefetchable) [size=2]
        Memory at <unassigned> (32-bit, non-prefetchable) [size=2]
        Memory at <unassigned> (32-bit, non-prefetchable) [size=2]
        Memory at <unassigned> (32-bit, non-prefetchable) [size=2]
        Expansion ROM at <unassigned> [disabled] [size=2]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Device Serial Number 00-00-ff-ff-ff-ff-ff-ff
        Capabilities: [150] Latency Tolerance Reporting

01:00.1 Bluetooth: MEDIATEK Corp. Device 8650
        Subsystem: MEDIATEK Corp. Device 8650
        Flags: bus master, fast devsel, latency 0, IRQ 4
        Memory at 20100000 (32-bit, non-prefetchable) [size=1M]
        Memory at <unassigned> (32-bit, non-prefetchable) [size=2]
        Memory at <unassigned> (32-bit, non-prefetchable) [size=2]
        Memory at <unassigned> (32-bit, non-prefetchable) [size=2]
        Memory at <unassigned> (32-bit, non-prefetchable) [size=2]
        Memory at <unassigned> (32-bit, non-prefetchable) [size=2]
        Expansion ROM at <unassigned> [disabled] [size=2]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Device Serial Number 00-00-ff-ff-ff-ff-ff-ff
        Capabilities: [150] Latency Tolerance Reporting

I also modified the serial port speed in the DTS file. Original speed is 115200 and OpenWRT speed was 57600.

Sorry, current code of mt76 module support only device 7662.
To correct LAN WAN port mapping add to /etc/config/network

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'

Thank you very much 123serge123!

I added the config you gave me and now, the physical WAN port works as a real WAN port.

So we have to wait for MediaTek to release their code for the device 7650? Previously, asus-wrt was installed, is there any way to import code from the asus-wrt sources to OpenWRT sources for this device?

Again, thank you for your help.

Hi francis, you share firmware?
Regards, sehack.

Hi sehack,

try to use this one. You MUST flash the firmware using the serial console, it won't work using the web interface provided by Asus-WRT.

Hi Francis,
    wich are the features suppored so far  in your firmware ?

thanks

I would recommend the firmware from Xiaomi Mi Wifi Mini works well under diodes led and 5GHz radio.

(Last edited by sehack on 7 Feb 2016, 02:14)

FYI, if the only thing you want is stable working firmware for Asus rt-ac51u (with full source), look at Padavan's project bitbucket.org

stgtt wrote:

Hi Francis,
    wich are the features suppored so far  in your firmware ?

thanks

LEDs and 5GHz are not working. I haven't tested USB port but I don't think it works.
Anyway, it runs an OpenVPN server which is working fine and some cron jobs. VLANs are OK.

sehack wrote:

I would recommend the firmware from Xiaomi Mi Wifi Mini works well under diodes led and 5GHz radio.

can you check wifi signal strength and RSSI for both 2.4 and 5 GHz? if everything is good please dump factory partition from router.

123serge123 wrote:

To add support for 2-nd wifi you need correct dts-file pci section. This section must look like:

        pcie@10140000 {
                    status = "okay";
    
                    pcie-bridge {
                            mt76@0,0 {
                                    reg = <0x0000 0 0 0 0>;
                                    device_type = "pci";
                                    mediatek,mtd-eeprom = <&factory 0x8000>;
                                    mediatek,2ghz = <0>;
                            };
                    };
            };

and add kmod-mt76 package into your firmware image.

some devices use pci0/pci1 instead of pci-bridge. maybe check that first?

anarchy99 wrote:

some devices use pci0/pci1 instead of pci-bridge. maybe check that first?

Possible.
But as you can see in mt76x2_pci.c:

static const struct pci_device_id mt76pci_device_table[] = {
    { PCI_DEVICE(0x14c3, 0x7662) },
    { },
};

and I am not sure that simple addition PCI_DEVICE(0x14c3, 0x7650) may help. At any case you may try smile

As the situation is, I bury the sources of the original firmware and did not find mention of mediatek,2ghz

RT-AC51U with Padavan soft RT-AC51U_3.4.3.9-099_full.trx occasionally get stuck. No connection to WLAN.
I use router to distribute openvpn to local network in a constant way.
When the next stuck happen I'll try to check if LAN has failed either.

Is there any progress?

mt7610e is not supported by official openwrt

Hi to all, just got this router, trying to flash openwrt. Flashing via web-gui rescue not possible (using 192.168.1.10).
Flashing via tftp (using 192.168.1.75), it connects, can put the new fw but when I visit 192.168.1.1 asus fw is there.
Is there something Iam missing;

The discussion might have continued from here.