OpenWrt Forum Archive

Topic: Netgear AC2600 Nighthawk X4S VDSL/ADSL Modem Router (D7800)

The content of this topic has been archived between 6 Apr 2018 and 28 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

The build on is based on AA and the DSL seems to work on that one. You find it if you search D7800 on Is there a way to upgrade from that build to the newer trunks and keep whatever firmware/drivers was making it work? Or at least figure out what those drivers were and install them over a newer build?


I flashed openWRT on my d7800. After flashing is bricked. I cannot access router through even if PC gets connected to the router and I can ping using CMD with TTL=64.

I tried TFTP to flash stock firmware. It does not work.

I used putty and I can login to root, but what commands should I use to reflash with stock firmware. I tried to find .bin for D7800 but everywhere .img only.

I flashed


on my stock firmware

sorry for the english but I translate with google !!

I flashed a D7800 with open wrt, now I would like to return to the firmrare stock where I can find the bin file?

The good part, it's a lantiq (PSB80320) ADSL frontend - the bad part, it's just the ADSL frontend without the accompanying lantiq SOC (VRX320), no RAM, no flash, it appears to be driven solely from the IPQ8064 SOC. It doesn't help either that LEDE/ OpenWrt doesn't appear to support lantiq VRX320 in general so far.

The discussion might have continued from here.