OpenWrt Forum Archive

Topic: WAG54GS upgrading

The content of this topic has been archived on 23 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I have a WAG54GS router on my desk and it's currently more like an expensive brick of plastic with lights. The problem is that my internet connection isn't compatible with WAG54GS. The reason to this is my ISP and their old technology (Sonera in Finland). I've tested the device in other ADSL networks and it works just fine. I've already informed Linksys technical support about this (and so have several other persons before me) but a new firmware just ain't coming. Doing something useful with the plastic brick would be nice.

So, I found the 1.00.08 firmware as a GPL release (current is 1.00.06) but the problem is that it ain't a good-to-go kinda firmware. It includes application source codes etc so it needs to be compiled. I just don't know how. Upgrading from 1.00.06 to 1.00.08 might help me with my problem or then it might not. There are also few applications included in the 1.00.08 firmware that could be upgraded to a newer version:

iptables 1.2.8 -> 1.3.5
linux-atm 2.4.0 -> 2.4.1
mini_httpd 1.17beta1 -> 1.19
udhcp 0.9.7 -> 0.9.8

Perhaps these upgradings could be also done without compiling a completely new firmware? Telnet connection is available to my router so perhaps there is a way to upgrade that way.

I've got a Debian server running somewhere in my closet if I need to compile something but I just don't know what and how. That's where I need lots of help, help and help.

- Crnd

(Last edited by Crnd on 7 Jun 2006, 23:00)

when you say your internet connection isnt compatible how do you mean??

ISP is using older technology and my router doesn't understand it (the problem was ATM if I remember it correct). It requests an address from DHCP but it doesn't correctly interpret the command when it receives the address. Works just fine with other operators that have newer technology.


The device is working just fine now. Found a beta version of 1.00.08 firmware and everything runs perfectly.
If someone needs the firmware, it can be found from … A/1.00.08/
username: linksys
password: beta7

(Last edited by Crnd on 9 Jun 2006, 09:27)

Hi Crnd,

Just tried to download the Firmware 1.00.08 from the link you provided,
but the username and password are not current anymore sad

Do you know what the new ones are? as I have been looking for this
firmware for a while and i am so close to getting it ;-)

I have sent you a PM as well.



You can get v1.00.08 of the firmware by first downloading the GPL code from here and then extracting the pre-compiled firmware upgrade image file.

You don't say what OS you're running on (linux/windows/mac) but I'll assume its windows in which case once you've downloaded the above file, do the following...

1) Get a version of winzip that supports '.gz' and '.tar' files (the latest version from the winzip website does)
2) Open 'WAG54GS_A_v1.00.08.tar.gz' in winzip and extract 'WAG54GS_A_v1.00.08.tar'
3) Open 'WAG54GS_A_v1.00.08.tar' in winzip and extract the 'WAG54GS_A_V1.00.08.img' file
4) Use the firmware upgrade page on the WAG54GS to load the 'WAG54GS_A_V1.00.08.img' file

I successfully upgraded my WAG54GS to v1.00.08 this afternoon so I can't say yet if there are any improvements/problems in this new version of the firmware. I was previously running v1.00.02 which was pre-installed on the unit when it was shipped from the factory and I had an issue with my ADSL connection being dropped every so often (requiring the WAG54GS to be rebooted) so I'm hoping this newer firmware version might resolve that.

(Last edited by garym71 on 5 Aug 2006, 20:51)

Hi Garym71,

Thanks for the info smile and yeah I am running Win2k OS.

I have been having constant internet drop-outs with 1.00.08 so i wanted
to downgrade to 1.00.06 but wanted to have 1.00.08 to go back to if 1.00.06
did not help.

Well after a few days of concidering if i should downgrade my
firmware to 1.00.06 I did it and now have a very stable connection,
it has not dropped out at all !!

So if anyone has version 1.00.08 on their WAG54GS
and are having drop-outs then I would recomend down
grading to 1.00.06. as this seem to be the latest most stable
firmware version at the moment.


(Last edited by solorize on 8 Aug 2006, 13:46)

I had no problems using 1.00.08 firmware but still I wanted to upgrade to a newer version that I found, 1.00.09C. It has few new settings available but it seems to drop all wlan connections after a week of uptime so it needs to be booted. If you want to test it anyways, you can find it on

solorize wrote:

Hi Crnd,

Just tried to download the Firmware 1.00.08 from the link you provided,
but the username and password are not current anymore sad

Do you know what the new ones are? as I have been looking for this
firmware for a while and i am so close to getting it ;-)

username: linksys
password: beta49

Linksys has finally managed to give WAG54GS users a real xmas present: they released a new official firmware. The current version is 1.00.12 and can be downloaded straight from the firmware section of WAG54GS. The date on the site is wrong so don't get confused. It is 2005 and it should be 2006.

Didn't find any new menus so this is probably the official version of 1.00.09C. Working fine on my device right now. Hopefully it'll stay that way...

- Crnd

Thanks a lot for this information. I've reported a few bugs in the old firmware, but wasn't notified about any update. Don't know if they really fixed the bugs I've reported. I've fairly given up on this device and now use it in bridge mode only with a WRT54GL running OpenWRT (runs since 34 days without problems). I had to reboot the WAG54GS at least once a week because it wasn't responding over WLAN anymore, but it seems it does a good job in bridge mode.

I just found the new v1.00.12 firmware but I get a message telling me that the "WAG54GSv1-EU-AnnexA-ETSI-1.00.12-code.img" is the wrong file type when trying to upgrade via the official router menu...?

I did try the earlier suggestion of using that tftp.exe but I couldnt find my server either...

I am trying to fix a line dropping problem - I have v1.00.06 at the moment...:(

Happy New

(Last edited by nikgrey on 31 Dec 2006, 19:11)

nikgrey wrote:

I just found the new v1.00.12 firmware but I get a message telling me that the "WAG54GSv1-EU-AnnexA-ETSI-1.00.12-code.img" is the wrong file type when trying to upgrade via the official router menu...?

You could try to upgrade it to 1.00.08 or 1.00.09C first and then upgrade it to 1.00.12. Also be sure that you've got the zip unpacked so that you're not trying to upgrade your WAG54GS with the zip file instead of the img file. I had 1.00.09C when I upgraded to 1.00.12 and it worked fine. Didn't have any problems and my old settings remained intact. I can upload both images (1.00.08 and 1.00.09C) on an FTP server later. But you'll find 1.00.08 from Linksys' web page under the GPL menu. Though you need to unpack the file but it is there. And 1.00.09C can be found from but you need to create an account there.

I can imagine people trying to use the zipped file for this but I did unpack it first.

I just lost wireless connection again which made me check back here - thanks for the quick response Crnd..

I have a NIC card in my main machine now which keeps losing the connection - next to it I have a laptop which is handy as I can make sure it is a local problem I am having with this one machine!

The lappy never loses its connection fortunately - just now I went into the properties of the dodgy network connection and entered the TCP/IP properties, I left the "Obtain IP addrss auto" but changed the DNS server addresses and set them to the same as my router admin status screen shows... the connection is back - I wonder if that will solve my problem?

I would like to get copies of 1.00.06 - 1.00.08 for back up purposes should anything go wrong with my intended firmware update but I cant find them - could you upload them for me please? that would help loads.

(Last edited by nikgrey on 1 Jan 2007, 17:50)

My only problems with this device have been nonworking ADSL connection (1.00.06 firmware didn't support my ISP's hardware) and losing WLAN connection after few days of uptime. Newer firmwares fixed the ADSL connection but this WLAN problem was bugging me all the way until I got this new 1.00.12. Haven't experienced any problems with this one yet.

Those "Obtain an IP address automatically" settings affect only DSL connections. So the key is probably just to set manually all the settings of your table pc. It should work just fine after that especially if you've got NAT enabled. Then the pc doesn't need to fetch any IP's anymore or anything and it'll be slightly faster.

I uploaded the firmware files and you can find those from the following address:
There are versions 1.00.08, 1.00.09C and 1.00.12. Unfortunately I don't have 1.00.06 firmware here on my laptop but you'll probably find that from the GPL downloads of WAG54GS. There's also the 1.00.08 firmware's GPL release. You just need to unpack those files and find the img file inside.

Thanks for posting the files.

Still no joy though - I started with 1.00.08 with the intention of moving up to the latest but same problem with all of them - it gets to 12% and tells me its the wrong file type.

I do have a WAG54GS with version 1.00.06 firmware.

I have no idea now...:(

If all the files do the same trick then it probably ain't a corrupted file either.

There are Annex A and Annex B type devices and those firmwares aren't compatible with each other. You should probably try both of these firmware versions. Go to Linksys' site and choose the country from top left corner to Germany. Then go to Support and Downloads and there under Firmware you'll find v1.00.12 Annex A and Annex B versions. Can't access my WAG54GS right now so can't see if there was a place in administration window where you could see which Annex version your device is. You could check your device's bottom if there's some information about that.

But that's the best I can do. Can't think of anything more that could be the problem. Hopefully this helps.

Just lost connection again for nearly an hour - most frustrating when you are doing business, its not like I use my time playing games and just wasting time...arghhhh.

I am in the UK and assume my router is Annex A although I have no idea how to make sure - where is that info in the admin panel?

I've got similar problem with disconnecting and connection losses. After updating to 1.00.12 problem stayed, and other arised. Then I'm downloading some large file, and someone on other computer opens some connection, eg. some web page, my download stops. Now I'm trying to downgrade to 1.00.08, 1.00.09C, but then it finishing uploading image to router it says that the file is incorrect. At this moment I'm trying to download 1.00.06, but I'm afraid that it's gonna be the same. 1.00.12 was the file WAG54GSv1-EU-AnnexA-ETSI-1.00.12-code.img. I'm in UK so that file should be ok. I've tried to use WAG54GS_Upgrade_Utility but it says Broadcast error. Any ideas ?

Problem solved. I couldn't believe that 2 PCs with the same motherboards had the same physical addresses on 2 onboard ethernet cards. I have 2 onboard network cards with the same addresses, and the same addresses have my friend. That's what coused the confict. We forced different address on one PC, and now everythink is working fine. I just can't figure it out why this happened. I'm thinking that before update everyting worked fine because of WINS was working. And now on status on router thers just ---- in there. I can't remember, was there something before upgrade.

Just wanted to inform if here are WAG54GS users that  haven't noticed yet: Linksys has released a new firmware version 1.01.00. It has just few fixes and it mostly just adds language support for English, French and German. Installed it around ten hours ago and haven't noticed anything bad with this one yet so I'll be using this one from now on.

- Crnd

The discussion might have continued from here.