OpenWrt Forum Archive

Topic: RavPower RP-WD03 openwrt?

The content of this topic has been archived on 10 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

hello is possible? … P-WD03.pdf

Project name FileHub
Model name RP-WD03
Model MTK 7620
Frequency MIPS24KEc 360MHZ
Flash Type SPI Flash
Capacity 8MByte SPI flash
Memory Type SDRAM
Capacity 32MB*16Bits(64MB)
standard 802.11 b/g/n
Transceiver 1TX 1RX
Frequency 2.4GHz
Antenna Chip Antenna
Speed 300Mbps
WAN port
Protocol Ethernet
Speed 100Mbit/s
Interface Battery
LED (Blue*4pcs)


hello I own a pocket ravpower server RP-WD03
  I have ssh access but I remain the only single user info that I have recover over his lean
RP-WD03 Linux 2.6.36 # 56 Wed Aug 13 10:51:08 CT 2014 mips unknown
rootfs 5376 5376% 0100 /
/ dev / root 5376 5376% 0100 /
/ dev / sda1 61,403,136 54,026,496 7,376,640 12% / data / usbdisk1 / Volume1
All other commands are refusing me
  there has been there a metode to retrieve root access?
thank you for your good read


Wrong section.


Have you find the solution ?
I want to configure a corporate proxy in my ravpower. I think it is more easy with openwrt.
The mean is it , I don't need configure in all my machines.


OK, I can confirm that OpenWRT works on this device!!   I've programmed up about 5 of them so far.    I have even built from sources on the chaos calmer branch.

1 caveat is that for this to work, an SDcard MUST BE inserted.   It doesn't have to be a large card.   1 gig will do.

1st thing is to upgrade the firmware to the latest release from Ravpower which is 2.000.040.    I'm going to assume you all can find it, it's on the Ravpower website.     I have not tried upgrading to OpenWRT before 1st upgrading to .040, so best to do that.

Once you have upgraded to 2.000.040, you can proceed with the OpenWRT installation.    It's actually fairly easy.

I discovered that the Hardware is essentially identical to the HooToo TM-05.    The RP-WD03 only has 32MB of memory, where the TM-05 has 64 MB of memory.     I believe that this difference is why the RP-WD03 needs to have the SD card.

The firmware will not upgrade unless the card is inserted.    And after upgraded to OpenWRT, it will not boot up unless the SD card is inserted.     So put it in there, and keep it in there.

Follow the instructions on the HooToo TM-05 OpenWRT page:

  OK guys, for some reason I'm not allowed to post links.    Google search on this:

         openwrt hootoo tm-05

The 1st hit should be good.

Scroll down to the bottom of the page and follow the directions under "WIP OpenWRT Install".
I used ubuntu linux as my tftp server.    I set it up so that the TFTP Server messages were shown in syslog.
I did a tail -f on /var/log/syslog to monitor the activity going on with TFTP.

When I saw the messages start up requesting rootfs, I waited about another 30 seconds, and then powered off.
I powered on, and OpenWRT came up.    Homepage was accessible at 192 168 1 1.     You've got to put a password on using LuCI, and then ssh is available at the same address.

For the more ambitious builders out there you can build from these sources:

github dott comm Slash domino-team Slash openwrt-cc

Evidently the hardware is also 100% compatible with the GL-MT300N

I would like to post my diffconfig, but this editor is not allowing me.
I will see what I can figure out in a subsequent posting.

Basis of the configuration is:

Target System  (Ralink RT288x/RT3xxx)
Subtarget (MT7620 based boards)
Target Profile (GL-MT300N)
Enable LuCI
Enable LuaSockets        (note I only needed this for my app)

Good luck!!   I've had great success with this device.     Please ask if you have questions.

I can answer 1 question up front:   I've no idea how to get back to the original Ravpower firmware.    Haven't tried, and not going to.

SeeYa OutThere!

My RP-WD03 config:    /etc/config/dhcp:

config dnsmasq
    option domainneeded '1'
    option boguspriv '1'
    option localise_queries '1'
    option rebind_protection '1'
    option rebind_localhost '1'
    option local '/lan/'
    option domain 'lan'
    option expandhosts '1'
    option readethers '1'
    option leasefile '/tmp/dhcp.leases'
    option resolvfile '/tmp/'
    option localservice '1'

config dhcp 'wifi'
    option interface 'wifi'
    option start '100'
    option limit '150'
    option leasetime '12h'
    option force '1'

config odhcpd 'odhcpd'
    option maindhcp '0'
    option leasefile '/tmp/hosts/odhcpd'
    option leasetrigger '/usr/sbin/odhcpd-update'

My RP-WD03 config:   /etc/config/firewall:

config defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'

config zone
    option name 'lan'
    option network 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'
    option masq '1'
    option mtu_fix '1'

config zone
    option name 'wifi'
    option network 'wifi'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'

config forwarding
    option dest 'lan'
    option src 'wifi'

config forwarding
    option dest 'wifi'
    option src 'lan'

config include
    option path '/etc/firewall.user'

config rule
    option enabled '1'
    option name 'DisallowDHCPonLan'
    option proto 'udp'
    option target 'DROP'
    option dest_port '67 68'
    option src 'lan'

My RP-WD03 config:   /etc/config/network:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr ''
    option netmask ''

config interface 'lan'
    option ifname 'eth0'
    option proto 'dhcp'
        option hostname 'WD03a'
        option macaddr 'B2:DD:8D:10:19:9F'

config globals 'globals'
    option ula_prefix 'fd16:9263:09eb::/48'

config interface 'wifi'
    option proto 'static'
    option ipaddr ''
    option netmask ''

config switch
       option name 'switch0'
       option reset '1'
       option enable_vlan '0'

My RP-WD03 config:   /etc/config/wireless:

config wifi-device 'radio0'
    option type 'mac80211'
    option channel '11'
    option hwmode '11g'
        option path  '10180000.wmac'
    option htmode 'HT20'

config wifi-iface
    option device     'radio0'
    option network    'wifi'
    option mode       'ap'
    option ssid       'WD03a'
    option encryption 'none'

The config files I've posted are mostly from the OpenWRT recipe for Routed Access Point.

loogatee,  were you able to mount the sdcard to be used as a file system?  I have minidlna running on this box as well (good instructions btw, and firmware from RavPower is up to ...052 as of this date) and want to stream music from it to my phone.  Thanks.

Loogatree's method didn't work for me. If wouldn't see my TFTP server. I've tried a few other methods (creating a custom firmware from wingspinner's images) but they didn't work either - WD02 works fine but WD03 refuses any firmware that's not it's own.

Anyone got any ideas?

I do confirm that it's possible to flash OpenWrt to RP-WD03.
Instructions for flashing located here:
I used newer firmware version 2.264 instead specified v.1.0:
According to readme: "clean" contains a clean firmware with minimal packages, with LuCI installed (for my luck!), wifi is disabled by default.
Initially I burned older Ravpower firmware 2.000.040 (I was trying to get SD-card slot working) thru native web-interface, and then flashed OpenWrt via Tftpd64.
But, surprise!
USB-port is out of operation. Nobody told about...
The reason for experiment was SD-card slot dead. Now USB-port is lost also.
Next step, before throwing to trash-bin, will be the device disassembling, I guess...

I'm planning to buy RP-WD03 because of the specs and the ability to put OpenWrt on it. My MR3020 needs an upgrade because of the 4MB ROM / 32 MB RAM limitation.
I have some questions :
1 - Is OpenWrt running stable on the device, are there any issues ?
2 - loogatee reported that it has only 32 MB RAM while the specs says it has 64 MB RAM ... ?.
3 - 8 MB flash is enough for clean OpenWrt, why does it need an SD card to be always plugged in to boot OpenWRT ?

to mouda3
1. There is no dedicated OpenWrt build for this device. Loogatee told that he did, but nobody have seen.
2. Which specs? There is no detailed official specs. Wikidevi page is says nothing about memory capacity. Meminfo
command says - 28872 kB total.
3. No it doesn't. I flashed OpenWrt (my previous reply) with USB-stick inserted. But at the moment OpenWrt runs without USB or SD plugged at all.

Specs provided by the company are in the link posted by gat Page 116

It says :

- Memory
Type : SDRAM
Capacity : 32MB*16Bits(64MB)

- Flash
Type : FlashSPI
Capacity 8MByte SPI flash

That was starting post, I need to go sleep :-D
I didn't check that pdf for my sorrow.
That data confuses me. I guess there is a mistake in those specs.
Compare to HooToo specs, and it's MemInfo, both indicates 64MB:
And check the loogatee' post #7 at this topic. And again, meminfo indicates 28872 kB total at my WD03.
But anyway the general problem is proper OpenWrt build for this device.
Memory capacity it's a secondary I believe.

Wd03 running open-wrt would definitely be the ideal road warrior companion.

What exactly is preventing it from running open-wrt ?

I would definitely donate if that could help have open-wrt support this device (and all its functionality I.e. USB, sd-card).

The discussion might have continued from here.