OpenWrt Forum Archive

Topic: Xiaomi Mi Wifi Nano

The content of this topic has been archived between 22 Mar 2018 and 27 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

The only form I found it by reprogramming the uboot, it appears UART is enabled on uboot. If not, reprogram by flash, that is what I did. The Mini ROM doesn't work with this one, as this one uses MT7628. Wifi is not working ATM

I know, I didn't have time to make a guide. Will do it today or tomorrow. But remember, it is not on a working state! LAN is slow and no WiFi.

I am working on a image with the factory firmware but access to SSH.

Dear netomx?
when do you install PandoraBox what works, what not works? broadcast works?

It "works". Ap+sta is very unstable. Wifi works but giving 10mbps output. Range is pretty good

So how do you flash a new uboot or a pandora image? I can read the serial console but i cant get write access... how do i interrupt the boot sequence to tfpt the image? because the standard uboot webserver on 192.168.31.1 doesn't accept any other images...

(Last edited by s1lvester on 25 Nov 2015, 22:09)

s1lvester wrote:

So how do you flash a new uboot or a pandora image? I can read the serial console but i cant get write access... how do i interrupt the boot sequence to tfpt the image? because the standard uboot webserver on 192.168.31.1 doesn't accept any other images...

The serial console from the MI image doesn't work, but the uboot works. Check your connections. When the uboots starts to boot, it asks for 9 options, choose the one that says "upload new rom and flash it".

It works

F me! I wasted two days of banging my head against the wall.

writing to uboot only works with the stock 2.0.30 firmware form miwifi.com. I initially flashed the development-version 2.1.26 which doesn't seem to allow any console access anymore.

You downgrade it and it worked?

netomx wrote:

You downgrade it and it worked?

yes

Excellent news!

Hi all. I connect to my Xiaomi mi nano R1CL with 2.0.30 for UART 115200 but UBoot does not respond to a keystroke 2.

Serial cable and connect is proper. I connected to router with Putty. Please help me.

RESET MT7628 PHY!!!!!!
Please choose the operation:
   1: Load system code to SDRAM via TFTP.
   2: Load system code then write to Flash via TFTP.
   3: Boot system code via Flash (default).
   4: Entr boot command line interface.
   5: Load system2 code then write to Flash via TFTP.
   7: Load system code via web.
   9: Load Boot Loader code then write to Flash via TFTP.

It should work. Check your uart connection

habl wrote:

Hi all. I connect to my Xiaomi mi nano R1CL with 2.0.30 for UART 115200 but UBoot does not respond to a keystroke 2.

Serial cable and connect is proper. I connected to router with Putty. Please help me.

I got my hands on a second router and had exactly the same problem again although it was on 2.0.30.

So I did the following:

1. Connect UART and boot to check wether you're able to read. (115200 8N1)
2. Hold reset-key until the router boots into recovery-mode
3. re-flash the original image (v. 2.0.30) through the web-interface
4. when the unit reboots press 2 over and over again to interrupt boot

Maybe uboot gets locked down during first boot or maybe it's only open as long as the unit isn't configured. I dunno.

s1lvester wrote:
habl wrote:

Hi all. I connect to my Xiaomi mi nano R1CL with 2.0.30 for UART 115200 but UBoot does not respond to a keystroke 2.

Serial cable and connect is proper. I connected to router with Putty. Please help me.

I got my hands on a second router and had exactly the same problem again although it was on 2.0.30.

Maybe uboot gets locked down during first boot or maybe it's only open as long as the unit isn't configured. I dunno.

OK. I have thinking about. I did it. But it does not help me. Version of boot does not changed. I downloaded firmare from this http://bigota.miwifi.com/xiaoqiang/rom/ … 2.0.30.bin

U-Boot 1.1.3 (Jul 31 2015 - 19:31:38)

Board: Ralink APSoC DRAM:  64 MB
relocate_code Pointer at: 83fa8000
RT2880_RSTSTAT_REG 0xc0030204
******************************
Software System Reset Occurred
******************************
flash manufacture id: ef, device id 40 18
find flash: W25Q128BV
============================================
Ralink UBoot Version: 4.3.0.0
--------------------------------------------
ASIC 7628_MP (Port5<->None)
DRAM component: 512 Mbits DDR, width 16
DRAM bus: 16 bit
Total memory: 64 MBytes
Flash component: SPI Flash
Date:Jul 31 2015  Time:19:31:38
============================================
icache: sets:512, ways:4, linesz:32 ,total:65536
dcache: sets:256, ways:4, linesz:32 ,total:32768

 ##### The CPU freq = 575 MHZ ####
 estimate memory size =64 Mbytes
RESET MT7628 PHY!!!!!!
Please choose the operation:
   1: Load system code to SDRAM via TFTP.
   2: Load system code then write to Flash via TFTP.
   3: Boot system code via Flash (default).
   4: Entr boot command line interface.
   7: Load system code via web.
   9: Load Boot Loader code then write to Flash via TFTP.


3: System Boot system code via Flash.
Try to boot OS1                   

And in the wiki UBoot has version U-Boot 1.1.3 (Sep 25 2015 - 17:14:30)

[04060C0B][04060D06]
DDR Calibration DQS reg = 00008A88


U-Boot 1.1.3 (Sep 25 2015 - 17:14:30)

Board: Ralink APSoC DRAM:  64 MB
relocate_code Pointer at: 83fa8000
RT2880_RSTSTAT_REG 0xc0030000
***************************
Board power on Occurred
***************************
flash manufacture id: ef, device id 40 18
find flash: W25Q128BV.

Mine is the same. Same version.

By the way: I used 3.3V from my USB to serial adaptor to power the chip, not mini-usb power. Also I had no luck with an PL2303 adaptor and used a different one

I flashed developer firmware 2.1.26 and version of boot chanded. After I flashed 2.0.30 but new boot dont changed anymore.

U-Boot 1.1.3 (Oct 15 2015 - 20:59:29)

Board: Ralink APSoC DRAM:  64 MB
relocate_code Pointer at: 83fa8000
RT2880_RSTSTAT_REG 0xc0030204

I wathed miwifi_r1cl_firmware_1236b_2.0.30.bin and it does not has uboot information. What about replase uboot information from http://downloads.openwrt.org.cn/Pandora … CL/u-boot/ to miwifi_r1cl_all_59371_2.1.26.bin and flash it from the recovery?

I think this wont work since the updater checks the hashes during updating.

It checks hashes, so you may need to reprogram it using a SPI adapter.

Try to look for older versions, they may have the uboot you need.

EDIT 1: They may be here: http://www.miui.com/thread-1776173-1-1.html

(Last edited by netomx on 1 Dec 2015, 22:44)

I have a question about installing OpenWrt to Mi Wifi Nano without UART. I already sent the question but to wrong thread. Shall I move it here?

https://forum.openwrt.org/viewtopic.php … 59#p302659

(Last edited by UbuntuInMacBook on 6 Dec 2015, 23:48)

Please, is it possible that someone who has ssh access to Nano can do this to any firmware file and enable then ssh:
mkxqimage -x <firmware_name.bin>

Here is guide how to validate modified firmware (If you don't understand Chinese use chrome and translator):
http://www.iptvfans.cn/wiki/index.php/% … E%E6%94%B9

In original firmware mkxqimage is in /bin/ folder. You can copy private.pem and public.pem from that web site.

I tried to do it in mini router with official OpenWrt release, and it can't find /proc/xiaoqiang/model file. I copied mkxqimage and crypt 1.0.0 library from nano filesystem to mini router without success. I don't have access to nano, so I can't do it there.

(Last edited by UbuntuInMacBook on 8 Dec 2015, 22:13)