OpenWrt Forum Archive

Topic: [SOLVED] Issue with new distributed firmware on Archer C7 v2 AC1750

The content of this topic has been archived on 22 Mar 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi everyone,

I had an issue last night with my Archer C7 that I wanted to post about. I bought my Archer C7 off Amazon 27 November 2015, and it shipped with a different version of the firmware than was up on TP-Link's website:

Firmware Version: 3.14.3 Build 151014 Rel.49676n
Hardware Version: Archer C7 v2 00000000

I downloaded the correct factory.bin for the hardware version I had, checked the MD5 hash, and attempted to install OpenWRT. I got the following error again and again:

Error Code: 18005
Upgrade unsuccessfully because the version of the upgraded file was incorrect. Please check file name.

I also tried to "update" the firmware to the previous "Archer C7_V2_150427" firmware, and I got the same message. After some digging around, I found this thread ( … a995bc5d10), where OP had a similar issue. The folks at DD-WRT put up a new version of the old 150427 firmware that could be flashed on top of 3.14.3 Build 151014 Rel.49676n (you do need to be logged in in order to see the attached file. I also mirrored it here if that's okay: I successfully flashed to this version of the TP-Link firmware.

I was then able to flash to the current 15.05 CC version of OpenWRT. Very happy with the performance! I hope this helps someone else.


Thanks, Sean, for this information. 

I had this exact problem tonight with the same firmware and hardware versions.  I was trying to flash my Archer C7 V2.0 to Gargoyle with no luck due to the 18005 error code.  I used the file you posted (because I hate to create yet another login) and it flashed just fine.  I then flashed the Gargoyle 1.9.0 factory bin and it flashed without any problems.  I'm now up and running.

Thanks again for posting your experience for others to learn from!


Purchased a TP-LINK AC1750 last night (overnight prio delivery) since I needed one IMMEDIATELY. I ran into that stupid problem with the headers where tp-link is trying to force you to use their firmware (preventing people from installing unauthorized firmwares). I used the firmware sean56 provided above at which flashed to 3.14.3 Build 151014 Rel.49676n. Once complete, I tried to flash to 15.05, the firmware upgrade proceeded. Then, that was the last I ever saw of the router. Instantly bricked.

Model: Archer C7(US) Ver:2.0

I would not recommend following the advice listed above (or buying this, or any other tp-link device). I've gone through 12+ openwrt/ddwrt routers over the last 10 years and this is the first one I've ever bricked. Quite pissed about it and the wasted $100. And... I still have no fucking internet!</rant>

(Last edited by senseless on 17 Mar 2016, 21:37)

@senseless It's likely not bricked, but just not booting OpenWRT

I was able to get mine to run DD-WRT, but NOT OpenWRT...

I detailed some of that here: … 811_after/

and here: … 29#p315429

The short of it is that you need to find the previous TP-Link version, setup a TFTP server, then after that is flashed, you can install DD-WRT.

OpenWRT 15.05* results in just the power LED being on + Network LED and no interface activity (nothing on

Weird, there're lots of people on this forum (including me) running OpenWrt 15.05* on their routers without an issue.

I have a theory that @senseless soft-bricked his router by trying to flash OpenWrt from DD-WRT.

I *believe* you shouldn't be flashing OpenWrt directly from DD-WRT. If your router is locked, the path should be: Locked TP-Link firmware --> DD-WRT unlock --> Unlocked TP-Link firmware (older version) --> OpenWrt.

The OP hinted that's the way he's done it, but it wasn't explicitly specified by him.

I've tried all possible paths (Usually recovering via TFTP flash if something goes wrong)

This machine will not boot OpenWRT's image. Works will all versions of TP-Link firmware that I've tried, and the latest version of DD-WRT.

And you're certain you've got a v2, not maybe a newer version with the different hardware? And a proper version of OpenWrt (either v1 or v2) to match your router? And checked an md5sum of the file you ended up with vs what's posted in downloads?

Yes absolutely certain, unless they're putting "Ver: 2.0" stickers on non version two hardware tongue

I reverted back to the stock TP-Link firmware because I actually need something that works in the time being while I decide whether or not to return this hardware. Currently using:

Firmware Version: 3.14.3 Build 151014 Rel.49676n
Hardware Version: Archer C7 v2 00000000

I see you saw the other thread so I'll try to crack her open without voiding the warranty and fulfill your request of getting a PCB photograph if I have time today. (and reply back there, but I'm going to be rather busy today)

I'd recommend getting a serial cable so that you can see what's wrong during the flashing and boot-up, embedded devices are damn near impossible to debug without one. I just bought the pin headers, cables, and board so that I can make a permanent, simple solution whenever I have issues. If everything works as expected I'll post what I bought, it should be here tomorrow.

I soldered pin headers in my V2 in attempt to use a TTL to RS232 USB adapter tha came with my RaspberryPi but it doesn't support Windows 10. After installing the pin headers the router boots and all the lights come on except for "internet" (currently using it as a WAP) and the unused LAN jacks, but it doesn't have an IP nor does the WiFi broadcast. TFTP booting doesn't work either so without a serial cable it's damn near impossible to figure out what's going on.

Re: win10 driver issue. This may help, depending on TTL chip.

@senseless: What are your symptoms? I did the same thing with a brand new router I got off of Amazon yesterday (Archer C7 v2.0 (US)). Flashing sean56's file worked fine, so I tried flashing it with 15.05, which did not work. Now my router is stuck in a boot loop. I tried the TFTP recovery method with numerous images; the router downloads the image, but then reboots immediately, and is stuck in the loop again.
My plan is to solder on a serial connection this weekend the see what's happening.


I have no personal, hands-on experience, but have read a few threads on the boards in the past week or more where a seemingly normal flash of a TP-Link router -- a brand new unit recently purchased -- ended up going wrong, even though it seems the instructions were followed properly.

Please look over this General Discussion board plus Developers Only, for example.  Look for threads where flashes have failed, and especially where tftp recovery has failed (even when following instructions carefully).

I'm not really an expert, as I'm fairly new here.

But I wonder if TP-Link hardware manufactured over the last two, three, four months has introduced changes that are now causing widespread problems with OpenWRT....  And what those changes (u-boot, flash partitioning, what else could it be???  Experts?) are....  NB that this is sheer speculation on my part! yikes


For anyone playing along, please see this post/thread: … 88#p315588

If you're willing to consider some reddit posters reliable sources, please read: … er/d14ihwo

If there has been a flash partition change, it's my understanding that a serial boot log will tell a developer the memory start addresses and sizes.  These could be compared with what's now listed for the model/version in question on its OpenWRT hardware page.  HTH.


tl;dr -- Newest C7 units have a new flash chip not supported in CC/15.05.x.  A trunk build should be installed and is reported working.

cmsigler wrote:

tl;dr -- Newest C7 units have a new flash chip not supported in CC/15.05.x.  A trunk build should be installed and is reported working.

cmsigler, do you still need to TFTP an older TP-Link firmware over or load DD-WRT first? I've tried flashing the trunk build (openwrt-ar71xx-generic-archer-c7-v2-squashfs-factory.bin)from my factory firmware and am still getting an 18005 error, wrong version.

Is that the right version? Do I need to do anything else first?


I did a little detective work and was able to have luck.

@sean56 (OP) posted in December 2015 and @senseless ran into trouble on 2016-03-17, the day after they released 15.05.1.

My steps:

It worked without any hang-ups.

(Last edited by zachary_fields on 15 May 2016, 02:48)

Tried last post .  Now can't connect to router

(Last edited by jmsnyc on 21 Jun 2016, 02:42)

the issue is the same with all us region tp-link routers with the V3 header... there is a quick dirty solution that seems to work fine with out all the flash this then flash that ... it was posted around the forum someplace ?? 

essentially we can type code into the ssid slot to write a little script to the /tmp directory to restart httpd with the -f (basically flash any ??) flag. You will need to type the following cmds into the ssid slot and press the save button after each cmd, the final cmd will run the script. NOTE the ticks surrounding the code are not ' (an apostrophe) they are `(a grave or grave accent .. the button proceeding the number 1 on the keyboard)


`echo "httpd -k"> /tmp/s`
`echo "sleep 10">> /tmp/s`
`echo "httpd -r&">> /tmp/s`
`echo "sleep 10">> /tmp/s`
`echo "httpd -k">> /tmp/s`
`echo "sleep 10">> /tmp/s`
`echo "httpd -f">> /tmp/s`
`sh /tmp/s`

be sure to press the save button after each line of code, do not hit enter ... use only the save button. After you have entered and saved the last cmd you may or may not need to refresh the page. After that just load the firmware as usual using the firmware upgrade page and with any luck you should be able to flash the factory bin

Good luck

(Last edited by hostle19 on 21 Jun 2016, 02:59)

this wont help as I no longer can access interface... trying to figure out how to tftp

@jmsnyc I was also having a problem accessing the UI at some point (twice actually) and factory reset didn't help but a 30-30-30 hard reset fixed it for me...hope it helps.

Please share config file "dhcp-boot" barrier breaker openwrt for mr-tplink 3420

I have got bricked my router tplink 3420 v-2 while installing Barrier breaker to it, It has only power on and system LED blinking, I checked for eth0 packets it says
"ARP, Request who-has tell, length 46"

when sniffed udp packets it says
"IP &gt; BOOTP/DHCP, Request from&nbsp;(oui Unknown), length 300"
I tried tftp server with recovery file, ftp client method to put firmware, but no success, Kindly help me to solve it , I need it urgently back to work?
It doesnot ask for any recovery file specified name. Can anyone tell me what is the boot file name for barrier breaker 14.07 for mr3420 ?so that i may rename and flash it

The discussion might have continued from here.