OpenWrt Forum Archive

Topic: Can't watch my RTSP stream while using RJ45 but working on Wifi...

The content of this topic has been archived on 31 Mar 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello there,

i'm totally noobish and for some unknow reason i wanted to install this advanced piece of sofware, but now i'm in troubles hmm

i have the latest stable version (15.05)

My problem is the following :

i have one IP cam WiFi, i can watch the RTSP stream from devices conneted on the Wi-Fi, but i can't watch it from my PC connected on RJ45 (timeout for the rtsp video).

i have no idea why, the config is unmodified.

there some sreens, maybe it will help (?)

http://imgur.com/a/EN0OV/all

thanks much

i have done some testing :

i can ping my IP cam (wifi) from my Tablet (wifi)
i can ping my tablet (wifi) from my PC (rj45)
i can't ping (timeout) my IP cam (wifi) from my PC (rj45)
(very strange !!??)

it help ?

and it work fine if i don't use openwrt.

Edit
basically i can't have any access (ping, SSH, rtsp) from my computer to my ip cam.
to be sure i have even tried to turn off completly my pc firewall.

(Last edited by xiaxia on 17 Dec 2015, 11:24)

please post /etc/config/network and /etc/config/wireless.

Thanks J1mbo,

root@OpenWrt:~# vi /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd42:43be:3d74::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option macaddr '8c:be:be:55:5e:a2'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option force_link '1'
        option macaddr '8c:be:be:55:5e:a3'
        option proto 'dhcp'
        option peerdns '0'
        option dns '8.8.8.8'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t' 
root@OpenWrt:~# vi /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path '10180000.wmac'
        option htmode 'HT20'
        option txpower '20'
        option country '00'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option key 'testtest'
        option encryption 'psk2'

(Last edited by xiaxia on 17 Dec 2015, 10:57)

i switched back to the stock firmware of my router (xiaomi mini) which is also based on openwrt, and now it work again, very strange.
let me know if you want more details i can reinstall it.

The discussion might have continued from here.