OpenWrt Forum Archive

Topic: [Solved] USB Wireless not recognized - kmod-rtl8192cu

The content of this topic has been archived on 28 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I have just upgraded from CC 15.05 RC3 to CC 15.05 Final on my HooToo TM-02. (openwrt-15.05-ramips-rt305x-ht-tm02-squashfs-sysupgrade.bin).  I have been using an EDIMax 7811u wireless USB adapter with the kmod-rtl8192cu package.

I have loaded up all the USB parts and this package, but the device is not recognized in Luci.  I have 2 adapters and they both work fine on PCs.   I see references to phy0 but not phy1, which is what I would expect the device to appear as.  I see this single line in the kernel logs, but nothing else that I can identify as relevant to the device.

[   22.430000] usbcore: registered new interface driver rtl8192cu

Looking for suggestions on how to trouble shoot and enable the device.

I have the following installed

Basic USB (installed, not sure that all are required)
kmod-scsi-core
kmod-usb-storage
kmod-crypto-hash
kmod-lib-crc16
block-mount

The required kmod-rtl8192cu installs all of the following:
kmod-rtl8192cu                 43kb
kmod-rtl8192c-common    18kb
kmod-rtlwifi                       28kb
kmod-rtlwifi-usb                8kb

The ticket below suggested the need for wpad.  I know I do not need both, but mini did not seem to help
https://dev.openwrt.org/ticket/17649
wpad-mini                     238KB
wpad                             395kb

My original post on the topic: https://forum.openwrt.org/viewtopic.php?id=58548

(Last edited by RangerZ on 30 Dec 2015, 20:10)

It appears I neglected to install kmod-usb2.  Not sure it I need kmod-usb-ochi for USB data drives, but the wireless now works.

usb2 is sufficient.
ohci and/or uhci are for (older) usb 1.1 ports.

(Last edited by angelos on 31 Dec 2015, 18:06)

As I suspected.  I have got the USB thumb drive working with just the kmod-usb2

The discussion might have continued from here.