OpenWrt Forum Archive

Topic: installing OpenWrt in ZBT-WG2626

The content of this topic has been archived on 21 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello,
I am trying to install a local build into a ZBT-WG2626 using kermit over serial.

I have built both openwrt-ramips-mt7621-zbt-wg2626-initramfs-kernel.bin and
openwrt-ramips-7621-zbt-wg2626-squashfs-sysupgrade.bin.

tftp does not seem to work on my bootloader, hence trying kermit over serial.

I am typing loadb 0x80000000

then send via kermit, that seems to work

then I type  go 0x80000000

Then it just locks up.

Hoping to run from ram before I update it permanently!

Thank you,
Mike

Just curious: ZBT-WG2626 looks interesting. How much did it cost ?

I think it was about $80 with shipping, but I didn't buy it.

augustus_meyer wrote:

Just curious: ZBT-WG2626 looks interesting. How much did it cost ?

build quality is low compraring with simillar featured WITI or Pandorabox PBR-M1
those both are not ideal, but zbt is worse smile and also PBR-M1 have a latest 7603 2.4g chip (both witi and 2626 have a 7602 onboard)

(Last edited by stas2z on 25 Jan 2016, 21:42)

stas2z wrote:
augustus_meyer wrote:

Just curious: ZBT-WG2626 looks interesting. How much did it cost ?

build quality is low compraring with simillar featured WITI or Pandorabox PBR-M1

(Build quality: HW or FW ?)
May I quote you ? May be, I will meet one of the ZBT-managers @ Cebit in 2 months :-)
BTW: I dared sysupgrade -F on the WE826. And it worked.

(Last edited by augustus_meyer on 25 Jan 2016, 21:50)

augustus_meyer wrote:
stas2z wrote:
augustus_meyer wrote:

Just curious: ZBT-WG2626 looks interesting. How much did it cost ?

build quality is low compraring with simillar featured WITI or Pandorabox PBR-M1

(Build quality: HW or FW ?)
May I quote you ? May be, I will meet one of the ZBT-managers @ Cebit in 2 months :-)
BTW: I dared sysupgrade -F on the WE826. And it worked.

HW, sure you can quote me, tell him they need to ask screwhands schoolboys who soldered dip components to wash their flux, at least at the demo boards they send to vendors, if they really wanna get any contracts

SW is another question, looks so chinese smile stolen (im sure) breed bootloader (closed source chinese u-boot fork with stolen pepe2k code parts)+mtksdk 4.3. openwrt default profile (stolen also, cuz im sure they never bought SDK from Mediatek:)

(Last edited by stas2z on 26 Jan 2016, 00:30)

No advice how to use loadb to boot from ram??

Is the initramfs what I should be using? 
How do I tell what the load address should be? (and where to go from?)

THank you!
-Mike

omg laughing out loud, just found out they used second rgmii pins FOR LED big_smile big_smile big_smile
it means they limited transfer of GSW to 1Gbps (one way, or 500+500 duplex) instead of 2Gbps (1Gbps duplex)

(Last edited by stas2z on 26 Jan 2016, 19:36)

stas2z wrote:

they used second rgmii pins FOR LED

Which board ?

(Last edited by augustus_meyer on 26 Jan 2016, 19:27)

augustus_meyer wrote:
stas2z wrote:

they used second rgmii pins FOR LED

Which board ?

WG2626 smile

Hallo to Everybody,

here the Link of a shop where everbody can buy. http://www.innet24.de/advanced_search_r … =0&y=0

Where the Router and PCB-Board-Only can be bought. ALLNET has a special firmware with Chaos Calmer 15.05 with Dual-Core Support flashed on it by default. 

Thanks Schorschiz

Hi all!
I've flashed this router with openwrt sysupgrade. Now it boots up to some point and restarts. Failsafe is working but I can't flash the firmware with netcat. Any ideas?

The discussion might have continued from here.